Can be removed. I'd for traits we just want to ensure a specific trait is set, we never want the name to be changed (like no automatic .001
suffix). So _ensure()
is all we need.
I think we can remove most of the editing capabilities. Let's for now only have a list or traits that is managed internally, with no API functions to edit them. I guess we'd want that later to support custom asset types managed by add-ons, but we may want to use different ways to define those (e.g. a bl_asset_traits
property for a new asset type definition).
I think we should consistently use the term "asset traits", not just "traits".
Don't think we need this. I'd like to have a runtime only has of the asset traits in AssetRepresentation
. If we ever need the count of traits we can get the size from that.