Grease Pencil Outline Modifier not showing with duplicated camera in outliner #102375

Open
opened 2022-11-09 10:45:24 +01:00 by Reiner Prokein · 20 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 522.33

Blender Version
Broken: version: 3.4.0 Alpha, branch: master, commit date: 2022-10-19 10:48, hash: f0fba1a2d8
Worked: (newest version of Blender that worked as expected)

Short description of error
The outline modifier of a grease pencil is not showing with a camera that gots duplicated in the outliner

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

  • Remove the default cube
  • In the outliner copy and paste the default camera
  • Remove the first camera
  • Add a grease pencil stroke
  • Add a Outline modifier to it

The outline will not show.

This bug is related to this report. I am just not sure if it is two different causes and cases, or the same. https://developer.blender.org/T102373

outlinenotshowing.jpg

2022-11-09 10-30-57.mp4

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 522.33 **Blender Version** Broken: version: 3.4.0 Alpha, branch: master, commit date: 2022-10-19 10:48, hash: `f0fba1a2d8` Worked: (newest version of Blender that worked as expected) **Short description of error** The outline modifier of a grease pencil is not showing with a camera that gots duplicated in the outliner **Exact steps for others to reproduce the error** [Please describe the exact steps needed to reproduce the issue] [Based on the default startup or an attached .blend file (as simple as possible)] - Remove the default cube - In the outliner copy and paste the default camera - Remove the first camera - Add a grease pencil stroke - Add a Outline modifier to it The outline will not show. This bug is related to this report. I am just not sure if it is two different causes and cases, or the same. https://developer.blender.org/T102373 ![outlinenotshowing.jpg](https://archive.blender.org/developer/F13874527/outlinenotshowing.jpg) [2022-11-09 10-30-57.mp4](https://archive.blender.org/developer/F13874533/2022-11-09_10-30-57.mp4)
Author

Added subscriber: @tiles

Added subscriber: @tiles
Author

After realizing what the cause is: This issue is indeed the same issue than in the other task. You need a active camera for this modifier to function. And when you remove the active camera here, then the other is not active. And so the modifier stops working.

After realizing what the cause is: This issue is indeed the same issue than in the other task. You need a active camera for this modifier to function. And when you remove the active camera here, then the other is not active. And so the modifier stops working.
Member

Added subscribers: @antoniov, @PratikPB2123

Added subscribers: @antoniov, @PratikPB2123
Member

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'
Member

Hi, thanks for the report. I see we need active camera for outline modifier to work. but shouldn't it work if we manually set "duplicated" camera as active.
As far as I understood from quick testing, outline modifier only detects active camera if we re-add the modifier or toggle viewport visibility option of object/modifier
I'm not sure whether this is expected. @antoniov ?

Hi, thanks for the report. I see we need active camera for outline modifier to work. but shouldn't it work if we manually set "duplicated" camera as active. As far as I understood from quick testing, outline modifier only detects active camera if we re-add the modifier or toggle viewport visibility option of object/modifier I'm not sure whether this is expected. @antoniov ?
Antonio Vazquez self-assigned this 2022-11-10 10:23:34 +01:00

Changed status from 'Needs Developer To Reproduce' to: 'Confirmed'

Changed status from 'Needs Developer To Reproduce' to: 'Confirmed'

I have checked and the problem is the scene miss the camera when you delete the first one.

Before:

image.png

After:

image.png

As the scene camera is empty, the modifier cannot determine what is the camera to use.

@PratikPB2123 I can try to inform in the modifier, but do you think this is correct in the Outliner when you delete the camera that the scene gets NULL as camera? maybe it's correct just is double check if we could improve it or it's logic as today.

I have checked and the problem is the scene miss the camera when you delete the first one. Before: ![image.png](https://archive.blender.org/developer/F13882719/image.png) After: ![image.png](https://archive.blender.org/developer/F13882722/image.png) As the scene camera is empty, the modifier cannot determine what is the camera to use. @PratikPB2123 I can try to inform in the modifier, but do you think this is correct in the Outliner when you delete the camera that the scene gets NULL as camera? maybe it's correct just is double check if we could improve it or it's logic as today.

Added subscriber: @mendio

Added subscriber: @mendio

@mendio What do you think to add a warning in the top of the modifer. I cannot put in red because this would need a deep change in the modifiers code because I haven't the required data to check the scene camera and now this change is not logic with the futture plans we have.

image.png

@mendio What do you think to add a warning in the top of the modifer. I cannot put in red because this would need a deep change in the modifiers code because I haven't the required data to check the scene camera and now this change is not logic with the futture plans we have. ![image.png](https://archive.blender.org/developer/F13882750/image.png)

@mendio I could do this...but not sure it's the way to go.

image.png

@mendio I could do this...but not sure it's the way to go. ![image.png](https://archive.blender.org/developer/F13882770/image.png)
Member

but do you think this is correct in the Outliner when you delete the camera that the scene gets NULL as camera?

Yes, the current behavior make sense to me.


As the scene camera is empty, the modifier cannot determine what is the camera to use.

Totally agree with it
My point is: if we manually set the duplicated camera as active then outliner modifier doesn't detect the camera
How to reproduce:

  • Repeat all steps mentioned in the report as it is (or just open the attached file)
  • set the duplicated camera as active in scene properties tab (outline modifier won't work. Will work if we do this )
    #102375.blend
> but do you think this is correct in the Outliner when you delete the camera that the scene gets NULL as camera? Yes, the current behavior make sense to me. - - - > As the scene camera is empty, the modifier cannot determine what is the camera to use. Totally agree with it My point is: if we manually set the duplicated camera as active then outliner modifier doesn't detect the camera How to reproduce: - Repeat all steps mentioned in the report as it is (or just open the attached file) - set the duplicated camera as active in scene properties tab (outline modifier won't work. Will work if we do [this ](https://developer.blender.org/T102375#:~:text=outline%20modifier%20only%20detects%20active%20camera%20if%20we%20re%2Dadd%20the%20modifier%20or%20toggle%20viewport%20visibility%20option%20of%20object/modifier) ) [#102375.blend](https://archive.blender.org/developer/F13882769/T102375.blend)
Author

I personally find a warning a great improvement already.

Just wanted to add, doesn't the Line Art Modifier have the same problem? It is also dependant of a active camera from what i know. And there is the Outline tool in edit mode. Not a modifier, but also requires a active camera.

I personally find a warning a great improvement already. Just wanted to add, doesn't the Line Art Modifier have the same problem? It is also dependant of a active camera from what i know. And there is the Outline tool in edit mode. Not a modifier, but also requires a active camera.

Or maybe this:

image.png

@tiles Yes, maybe LineArt has the same issue. Not tested yet.

Or maybe this: ![image.png](https://archive.blender.org/developer/F13882780/image.png) @tiles Yes, maybe LineArt has the same issue. Not tested yet.

Tested LineArt. It works in some cases because it uses a different approach, but the result is a bit strange. You do get a result, but not the one you might expect.

Tested LineArt. It works in some cases because it uses a different approach, but the result is a bit strange. You do get a result, but not the one you might expect.

Added subscriber: @pablovazquez

Added subscriber: @pablovazquez

After talking with more members of the team, we think this is the best design that follows Blender UI.

image.png

Waiting for the opinion of @pablovazquez

After talking with more members of the team, we think this is the best design that follows Blender UI. ![image.png](https://archive.blender.org/developer/F13883128/image.png) Waiting for the opinion of @pablovazquez
Member

@antoniov, I agree with you about showing a warning message in modifiers panel. But question I raised was bit different. Did you check my last comment?

@antoniov, I agree with you about showing a warning message in modifiers panel. But question I raised was bit different. Did you check my last comment?

@PratikPB2123

My point is: if we manually set the duplicated camera as active then outliner modifier doesn't detect the camera

I think the problem is when you set the new camera to the scene, it looks we miss some update. As soon you update moving the frame, it's fixed... do you know how we could fix this? I don't want to add a refresh too aggressive to scene camera prop.

@PratikPB2123 > My point is: if we manually set the duplicated camera as active then outliner modifier doesn't detect the camera I think the problem is when you set the new camera to the scene, it looks we miss some update. As soon you update moving the frame, it's fixed... do you know how we could fix this? I don't want to add a refresh too aggressive to scene camera prop.

Warning message added in commit cad11f3098

Still pending the refresh issue.

Warning message added in commit cad11f3098c0 Still pending the refresh issue.
Antonio Vazquez added
Type
Known Issue
and removed
Type
Report
labels 2023-02-09 12:20:17 +01:00

Set as Known Issue because the main problem was fixed.

Set as Known Issue because the main problem was fixed.
Philipp Oeser removed the
Interest
Grease Pencil
label 2023-02-09 15:19:08 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#102375
No description provided.