UX Issue - Linked Action #115619

Closed
opened 2023-11-30 17:30:32 +01:00 by Maxime Caron · 1 comment

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 4070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 537.58

Blender Version
Broken: version: 3.5.0, branch: blender-v3.5-release, commit date: 2023-03-29 02:56, hash: 1be25cfff18b
Worked: (newest version of Blender that worked as expected)

Short description of error
When a linked object has a linked action, if you make a library override on it, you'll see green properties, you'll be able to modify its properties and even add keyframes on it, but when you'll reopen the file your keyframes won't be there.
It's really confusing to be able to change properties and see it directly in the scene while the changes won't be effectives at save.

Exact steps for others to reproduce the error
Add an object in a scene and animate its translations.
Link it in an other scene, select and make library override.
Change properties and add keyframes.

**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 4070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 537.58 **Blender Version** Broken: version: 3.5.0, branch: blender-v3.5-release, commit date: 2023-03-29 02:56, hash: `1be25cfff18b` Worked: (newest version of Blender that worked as expected) **Short description of error** When a linked object has a linked action, if you make a library override on it, you'll see green properties, you'll be able to modify its properties and even add keyframes on it, but when you'll reopen the file your keyframes won't be there. It's really confusing to be able to change properties and see it directly in the scene while the changes won't be effectives at save. **Exact steps for others to reproduce the error** Add an object in a scene and animate its translations. Link it in an other scene, select and make library override. Change properties and add keyframes.
Maxime Caron added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-11-30 17:30:33 +01:00
Member

Thx reporting! Same as #109781 though.

The over-arching issue is #98712.

Will close as a duplicate of #98712, please subscribe there if you want further updates.

Thx reporting! Same as #109781 though. The over-arching issue is #98712. Will close as a duplicate of #98712, please subscribe there if you want further updates.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-12-05 11:11:52 +01:00
Philipp Oeser added
Status
Duplicate
and removed
Status
Archived
labels 2023-12-05 11:12:01 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#115619
No description provided.