EEVEE-Next renders Tree Creature Demo completely black #118136

Closed
opened 2024-02-12 12:55:42 +01:00 by Steffen Dünner · 3 comments

System Information
Operating system: Linux-6.5.0-17-generic-x86_64-with-glibc2.35 64 Bits, X11 UI
Graphics card: NVIDIA GeForce RTX 2070 Super/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 535.154.05

Blender Version
Broken: version: 4.2.0 Alpha, branch: main, commit date: 2024-02-12 11:09, hash: 0bf9b10a93f0
Worked: (newest version of Blender that worked as expected)

Short description of error
The famous "Tree Creature" EEVEE Demo File by Daniel Bystedt renders fine in "old" EEVEE but completely black in latest EEVEE-Next

Exact steps for others to reproduce the error

**System Information** Operating system: Linux-6.5.0-17-generic-x86_64-with-glibc2.35 64 Bits, X11 UI Graphics card: NVIDIA GeForce RTX 2070 Super/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 535.154.05 **Blender Version** Broken: version: 4.2.0 Alpha, branch: main, commit date: 2024-02-12 11:09, hash: `0bf9b10a93f0` Worked: (newest version of Blender that worked as expected) **Short description of error** The famous "Tree Creature" EEVEE Demo File by Daniel Bystedt renders fine in "old" EEVEE but completely black in latest EEVEE-Next **Exact steps for others to reproduce the error** - Download and load https://download.blender.org/demo/eevee/tree_creature/tree_creature.blend - Switch the renderer to "EEVEE-Next" - Wait for the shaders to compile and in the end the render result turns black
Steffen Dünner added the
Priority
Normal
Status
Needs Triage
Type
Report
labels 2024-02-12 12:55:42 +01:00
Member

Can confirm

Can confirm
Member

This is because sun lights are disabled when the world material has a volume.
In theory, any constant volume density would prevent directional lights from having any effect.
AFAIK, this is the intended behavior and matches the Cycles one.

That said Cycles handles correctly situations where the density is not constant.
See this comment for example: https://blender.community/c/rightclickselect/QkEL/?sorting=hot#comment-54157
This setup won't work at all in EEVEE-Next, leaving the world volume pretty much non-usable.
So maybe we should rethink how to handle this. @fclem ?

This is because sun lights are disabled when the world material has a volume. In theory, any constant volume density would prevent directional lights from having any effect. AFAIK, this is the intended behavior and matches the Cycles one. That said Cycles handles correctly situations where the density is not constant. See this comment for example: https://blender.community/c/rightclickselect/QkEL/?sorting=hot#comment-54157 This setup won't work at all in EEVEE-Next, leaving the world volume pretty much non-usable. So maybe we should rethink how to handle this. @fclem ?

World volume is now meant to be use only with local lights. The previous behavior was a limitation (assuming zero density outside of view).
We replace it with a more physically based limitation (assuming constant non-zero density). Reasoning for this is explained in #114062.

We plan to add a conversion operator for old scene (see #93220 Add operator to migrate world volume to volume object.) that would fix the issue.

World volume is now meant to be use only with local lights. The previous behavior was a limitation (assuming zero density outside of view). We replace it with a more physically based limitation (assuming constant non-zero density). Reasoning for this is explained in #114062. We plan to add a conversion operator for old scene (see #93220 `Add operator to migrate world volume to volume object.`) that would fix the issue.
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2024-02-22 16:05:50 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#118136
No description provided.