Change over more surface project tools to use V3D_DEPTH_NO_OVERLAYS instead of V3D_DEPTH_NO_GPENCIL #121535

Closed
opened 2024-05-07 18:42:21 +02:00 by Sebastian Parborg · 1 comment

There as been a longer standing issue in Blender when using "surface project" that we would take objects that didn't have any actual surface into account.
For example when drawing curves either with Grease Pencil (#74389) or Curves:
curves_snapping_to_lights
(The user in this example was in camera view while drawing)

This has been fixed recently in Grease Pencil 3 where V3D_DEPTH_NO_OVERLAYS was intoduced.
We also changed this to be the case in the curve object drawing mode: #121530

However there are still other places left in Blender that still uses the older V3D_DEPTH_NO_GPENCIL method.

I propose to change all operators that has "surface project" functionallity to use V3D_DEPTH_NO_OVERLAYS as there are not many use cases for drawing on non 3d surfaces. This is because the end user can no really control what happens when projecting on to wire frame line objects in 3d space. (And because these objects do not really form a surface, so including these in "surface project" is misleading).

In addition to this, I also propose that we introduce more control over what objects we take into account when using "surface project".
Similar to V3D_DEPTH_OBJECT_ONLY, but instead only the selected objects would be used to create a depth buffer.

This would be useful for artists when drawing curve objects that creates actual geometry (grass, pebbels, water foam etc).
Currently there is no way for the user to designate exactly what objects they want to project onto which becomes a problem when they want to see the newly generated geometry but doesn't want to draw onto it. Or if they have a simplified surface object they want to draw onto that is behind a more detailed mesh.

I have a implementation of this in #121590

There as been a longer standing issue in Blender when using "surface project" that we would take objects that didn't have any actual surface into account. For example when drawing curves either with Grease Pencil (#74389) or Curves: ![curves_snapping_to_lights](/attachments/689cbedf-87db-4373-9af1-866551c308f2) (The user in this example was in camera view while drawing) This has been fixed recently in Grease Pencil 3 where `V3D_DEPTH_NO_OVERLAYS` was intoduced. We also changed this to be the case in the curve object drawing mode: #121530 However there are still other places left in Blender that still uses the older `V3D_DEPTH_NO_GPENCIL` method. I propose to change all operators that has "surface project" functionallity to use `V3D_DEPTH_NO_OVERLAYS` as there are not many use cases for drawing on non 3d surfaces. This is because the end user can no really control what happens when projecting on to wire frame line objects in 3d space. (And because these objects do not really form a surface, so including these in "surface project" is misleading). In addition to this, I also propose that we introduce more control over what objects we take into account when using "surface project". Similar to `V3D_DEPTH_OBJECT_ONLY`, but instead only the selected objects would be used to create a depth buffer. This would be useful for artists when drawing curve objects that creates actual geometry (grass, pebbels, water foam etc). Currently there is no way for the user to designate exactly what objects they want to project onto which becomes a problem when they want to see the newly generated geometry but doesn't want to draw onto it. Or if they have a simplified surface object they want to draw onto that is behind a more detailed mesh. I have a implementation of this in #121590
Sebastian Parborg added the
Type
Design
Module
Modeling
labels 2024-05-07 18:42:21 +02:00
Sebastian Parborg added this to the Modeling project 2024-05-07 18:42:21 +02:00
Author
Member

This has now been implemented.

This has now been implemented.
Blender Bot added the
Status
Archived
label 2024-05-27 13:38:38 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
1 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#121535
No description provided.