Polybuild keys assignment contradiction. #122380

Open
opened 2024-05-28 16:14:16 +02:00 by Paul Kotelevets · 2 comments

Polybuild tool keys assignment (Shift to remove geometry and Ctrl for adding new geometry) contains contradiction by design.
For example, it contradicts Ctrl snapping override, so snapping mode has to be set inverted in order to be used with Polybuild tool.
Also, in Blender Shift is mostly additive (like Shift+A, Shift+D to add a geomtery, Shift+pick to add elements to a selection) and Ctrl is subtractive (like Ctrl+X).
Inverting Shift and Ctrl functionality (using Shift to add geometry and Ctrl for removing geometry) will allow to reconcile the contradiction of a Polybuild tool with the rest of a Blender.

Polybuild tool keys assignment (Shift to remove geometry and Ctrl for adding new geometry) contains contradiction by design. For example, it contradicts Ctrl snapping override, so snapping mode has to be set inverted in order to be used with Polybuild tool. Also, in Blender Shift is mostly additive (like Shift+A, Shift+D to add a geomtery, Shift+pick to add elements to a selection) and Ctrl is subtractive (like Ctrl+X). Inverting Shift and Ctrl functionality (using Shift to add geometry and Ctrl for removing geometry) will allow to reconcile the contradiction of a Polybuild tool with the rest of a Blender.
Paul Kotelevets added the
Type
Design
label 2024-05-28 16:14:16 +02:00
Iliya Katushenock added this to the Modeling project 2024-05-28 16:14:45 +02:00
Contributor

Yes, thank you! I just don't use that tool because I keep using wrong keys and get frustrated every time

Yes, thank you! I just don't use that tool because I keep using wrong keys and get frustrated every time

Yes, thank you! I just don't use that tool because I keep using wrong keys and get frustrated every time

Same here, but to be honest Polybuild is a completely broken tool and should just be removed or rewritten. It has so many basic usability issues and bugs that it is not useful for anything in its current state. See for example #115351

> Yes, thank you! I just don't use that tool because I keep using wrong keys and get frustrated every time Same here, but to be honest Polybuild is a completely broken tool and should just be removed or rewritten. It has so many basic usability issues and bugs that it is not useful for anything in its current state. See for example https://projects.blender.org/blender/blender/issues/115351
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#122380
No description provided.