USD: Armature animations are not exported correctly #122636

Closed
opened 2024-06-02 21:33:58 +02:00 by Pronata Biswas · 11 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 4060 Ti/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 555.85

Blender Version
Broken: version: version: 4.1.1, branch: blender-v4.1-release, commit date: 2024-04-15 15:11, hash: e1743a0317bc
Worked: 4.0

Short description of error

  1. When exporting in the "USDC" file format, caches of all deformed meshes/objects are not exported correctly. Upon importing the USDC file, it shows all meshes as static, with no animations.

Exact steps for others to reproduce the error

  • Open the .blend file provided in the comment below
  • Export to USD with the Animation option selected
  • Try to Import that file back in and notice that only some objects are animated (similar with other usd applications too)

The resulting file after Export is much smaller in 4.2 compared to 4.0 so it's likely there's missing data.

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 4060 Ti/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 555.85 **Blender Version** Broken: version: version: 4.1.1, branch: blender-v4.1-release, commit date: 2024-04-15 15:11, hash: `e1743a0317bc` Worked: 4.0 **Short description of error** 1. When exporting in the "USDC" file format, caches of all deformed meshes/objects are not exported correctly. Upon importing the USDC file, it shows all meshes as static, with no animations. **Exact steps for others to reproduce the error** - Open the .blend file provided in the comment below - Export to USD with the Animation option selected - Try to Import that file back in and notice that only some objects are animated (similar with other usd applications too) The resulting file after Export is much smaller in 4.2 compared to 4.0 so it's likely there's missing data.
Pronata Biswas added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2024-06-02 21:33:59 +02:00
Author

I want to express my gratitude to the Blender Founder and Developers. I'm encountering some issues with exporting files in Blender. The problems are as follows:

  1. When exporting in the "USDC" file format, caches of all deformed meshes/objects are not exported correctly. Upon importing the USDC file, it shows all meshes as static, with no animations.
  2. Conversely, Blender crashes when I export it as an "Alembic" file format.
I want to express my gratitude to the Blender Founder and Developers. I'm encountering some issues with exporting files in Blender. The problems are as follows: 1. When exporting in the "USDC" file format, caches of all deformed meshes/objects are not exported correctly. Upon importing the USDC file, it shows all meshes as static, with no animations. 2. Conversely, Blender crashes when I export it as an "Alembic" file format.

The alembic crash is the same as #122517 and will be fixed by PR !122534

For USD, are you selecting the "Animation" option during Export? It is off by default.

The alembic crash is the same as #122517 and will be fixed by PR !122534 For USD, are you selecting the "Animation" option during Export? It is off by default.
Jesse Yurkovich added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2024-06-02 22:12:12 +02:00
Author

For USD, are you selecting the "Animation" option during Export? It is off by default.

I ticked on the Animation option before exporting the USDC file format.
The exact problem is that when I imported the USDC file (Exported with Blender 4.1.1), it shows that a single mesh object is animated but the rest of the mesh objects are static. But when I export with Blender 4.02/ 3.6 LTS it works.

> For USD, are you selecting the "Animation" option during Export? It is off by default. I ticked on the Animation option before exporting the USDC file format. The exact problem is that when I imported the USDC file (Exported with Blender 4.1.1), it shows that a single mesh object is animated but the rest of the mesh objects are static. But when I export with Blender 4.02/ 3.6 LTS it works.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2024-06-03 09:13:40 +02:00
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2024-06-03 09:14:07 +02:00
Iliya Katushenock added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2024-06-03 09:17:11 +02:00

I see the issue now. I'll change the title and description to only mention the USD problem since the alembic issue will be handled elsewhere.

I see the issue now. I'll change the title and description to only mention the USD problem since the alembic issue will be handled elsewhere.
Author

It also crashes (Blender 4.1.1) whenever I export as Alembic. However, you mentioned how to fix this issue. But I am not clear to solve this issue.
Would you help me how I can fix it?

It also crashes (Blender 4.1.1) whenever I export as Alembic. However, you mentioned how to fix this issue. But I am not clear to solve this issue. Would you help me how I can fix it?
Pratik Borhade changed title from Blender gets crashed during USD/ Alembic export. to USD: Armature animations are not exported correctly 2024-06-03 10:48:14 +02:00
Bastien Montagne added this to the USD project 2024-06-10 11:43:01 +02:00
Bastien Montagne added this to the 4.2 LTS milestone 2024-06-10 11:43:16 +02:00
Bastien Montagne added
Type
Bug
and removed
Type
Report
labels 2024-06-10 11:43:23 +02:00

I'm investigating this as well.

I'm investigating this as well.

I've confirmed that the UsdSkel export of this animation worked as expected in a build as of a couple of months ago, so I'm comparing the output to determine what might have changed.

I've confirmed that the UsdSkel export of this animation worked as expected in a build as of a couple of months ago, so I'm comparing the output to determine what might have changed.

I believe the issue is a bug in how the joint paths are saved. I.e., forward-slash separators in joint paths are being saved as underscores. E.g., path "mixamorig1_Hips/mixamorig1_Spine" is being saved as "mixamorig1_Hips_mixamorig1_Spine", so the skeleton binding fails. I think this is due to a recent change in how names are handled in the exporter, and am working on confirming this now.

I believe the issue is a bug in how the joint paths are saved. I.e., forward-slash separators in joint paths are being saved as underscores. E.g., path "mixamorig1_Hips/mixamorig1_Spine" is being saved as "mixamorig1_Hips_mixamorig1_Spine", so the skeleton binding fails. I think this is due to a recent change in how names are handled in the exporter, and am working on confirming this now.

I have a fix for this in pull request #123031.

I have a fix for this in pull request #123031.

It looks like there are actually 2 separate, unrelated issues. The bug I mentioned above was preventing the UsdSkel animation from being exported at all in Blender 4.2. The fix I have will address this. However, this is actually a different issue than what you were seeing in Blender 4.1. I apologize for the confusion.

The behavior you are seeing is actually an expected limitation when exporting skeletal animations (armatures) is enabled, as I will explain.

When exporting armature/skeletal animations, a known limitation is that only the armature modifier is applied to the mesh. In your example, the meshes that don't animate correctly actually have additional modifiers following the armature modifier, and these are dropped on export:

image

The immediate workaround for this is to export the animation as a point cache, by turning off Armature / Shapekeys in the export options. This will result in large files, but the animation will be intact.

It looks like there are actually 2 separate, unrelated issues. The bug I mentioned above was preventing the UsdSkel animation from being exported at all in Blender 4.2. The fix I have will address this. However, this is actually a different issue than what you were seeing in Blender 4.1. I apologize for the confusion. The behavior you are seeing is actually an expected limitation when exporting skeletal animations (armatures) is enabled, as I will explain. When exporting armature/skeletal animations, a known limitation is that only the armature modifier is applied to the mesh. In your example, the meshes that don't animate correctly actually have additional modifiers following the armature modifier, and these are dropped on export: ![image](/attachments/7280da5f-ec9c-4b4e-b3b4-2b214eb54a24) The immediate workaround for this is to export the animation as a point cache, by turning off Armature / Shapekeys in the export options. This will result in large files, but the animation will be intact.

The fix #123031 has been committed as 724a674bae , so I believe this can be closed? Indeed the rest of the issues are known limitations currently.

The fix #123031 has been committed as 724a674bae , so I believe this can be closed? Indeed the rest of the issues are known limitations currently.
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2024-06-24 16:35:06 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#122636
No description provided.