Extensions: Add-ons tab #122735

Closed
opened 2024-06-04 19:52:37 +02:00 by Dalai Felinto · 4 comments

Separate the extensions from the add-ons tab.

On the extensions tab we can install, uninstall, update.
On the add-ons tab we can do things related to user preferences (enable/disable and the preferences).


Overview:

image

Filtering options:

Setting menu options:

Extension detail:


For the Extensions tab the changes are:

  • Remove enable/disable from the extension headers.
  • Remove Preferences from the extension details.
  • Remove Legacy and Core add-ons.
  • Remove "Show Legacy Add-ons" from the menu.

In the future we can also:

  • Add a button to open the settings for the add-on from the Extensions tab.
Separate the extensions from the add-ons tab. On the extensions tab we can install, uninstall, update. On the add-ons tab we can do things related to user preferences (enable/disable and the preferences). --- Overview: ![image](/attachments/acb5b935-aa98-41ad-ad4d-cf49ac7d3d5d) Filtering options: <img src="https://projects.blender.org/blender/blender/attachments/676c3451-111e-4572-b47b-f976c943bd61" width=300> Setting menu options: <img src="https://projects.blender.org/attachments/7c4ddbeb-346d-46c3-954e-5f04c0f8bcff" width=300> Extension detail: <img src="https://projects.blender.org/blender/blender/attachments/ce2e3df8-e5b9-4de2-bb27-e49d079c8c0a" width=500> --- For the Extensions tab the changes are: * Remove enable/disable from the extension headers. * Remove Preferences from the extension details. * Remove Legacy and Core add-ons. * Remove "Show Legacy Add-ons" from the menu. --- In the future we can also: * Add a button to open the settings for the add-on from the Extensions tab.
Dalai Felinto added the
Type
Design
label 2024-06-04 19:52:37 +02:00
Dalai Felinto added this to the Python API project 2024-06-04 19:52:37 +02:00

Suggestion:

  • Remove the legacy add-ons filter option. I'm not sure this is really useful.
  • Make the enabled toggle a directly visible button. It's probably used often and there is enough space.
Suggestion: * Remove the legacy add-ons filter option. I'm not sure this is really useful. * Make the enabled toggle a directly visible button. It's probably used often and there is enough space.

Submitted !123420 which addresses this task as well as changes suggested by @brecht.

There were two issues I noticed while implementing the changes:

  • No way to tell which extensions were enabled.

    I think it's useful to know when an extension is installed but disabled since users may wish to remove extensions they're not using and it's needlessly awkward to make users switch to the add-on section just to check this.

    Currently installed but disabled add-ons show the text [disabled] after the name. Although some other way to easily identify installed-but-disabled add-ons would be fine too.

  • No way to tell the difference between extension/core/user add-ons.

    Without the ability to differentiation between add-ons which are extensions or core & legacy it seems arbitrary that some add-ons have a button to "Uninstall" directly in the add-on UI, others need to be uninstalled form the extensions section and some have no way to be uninstalled. Showing the add-on type (when showing details) makes this distraction clearer. Besides managing/removing add-ons, users should not have to be concerned with the type however.

    Currently the text `Add-on type: {Extension/Core/Legacy (User)} is shown in the details, I'm not set on calling this a "type" though, we could use some other term.

Submitted !123420 which addresses this task as well as changes suggested by @brecht. There were two issues I noticed while implementing the changes: - No way to tell which extensions were enabled. I think it's useful to know when an extension is installed but disabled since users may wish to remove extensions they're not using and it's needlessly awkward to make users switch to the add-on section just to check this. Currently installed but disabled add-ons show the text `[disabled]` after the name. Although some other way to easily identify installed-but-disabled add-ons would be fine too. - No way to tell the difference between extension/core/user add-ons. Without the ability to differentiation between add-ons which are extensions or core & legacy it seems arbitrary that some add-ons have a button to "Uninstall" directly in the add-on UI, others need to be uninstalled form the extensions section and some have no way to be uninstalled. Showing the add-on type (when showing details) makes this distraction clearer. Besides managing/removing add-ons, users should not have to be concerned with the type however. Currently the text `Add-on type: {Extension/Core/Legacy (User)} is shown in the details, I'm not set on calling this a "type" though, we could use some other term.

Committed 72ef03d5a1, closing.

Committed 72ef03d5a192e70eb42f788fb4bc5d07f2f160fa, closing.
Blender Bot added the
Status
Archived
label 2024-06-21 03:01:25 +02:00
Member

Hi @ideasman42, I see that add-on names are no longer translated. I’d argue that:

  1. though most add-ons are externally maintained, for the few that are built-in it’s not any more impractical to translate them than before, and can still be important.
  2. Add-ons can provide translations for the messages they introduce, including their name and description. They aren’t used until the add-on is enabled, but that’s better than nothing, and it was the same with legacy add-ons.

I’d like to propose bringing back these translations so add-on developers can choose to provide them.

Hi @ideasman42, I see that add-on names are no longer translated. I’d argue that: 1. though most add-ons are externally maintained, for the few that are built-in it’s not any more impractical to translate them than before, and can still be important. 2. Add-ons can provide translations for the messages they introduce, including their name and description. They aren’t used until the add-on is enabled, but that’s better than nothing, and it was the same with legacy add-ons. I’d like to propose bringing back these translations so add-on developers can choose to provide them.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#122735
No description provided.