Extensions: Silently fail to install Atomic Blender PDB #122857

Closed
opened 2024-06-07 01:25:39 +02:00 by Dalai Felinto · 0 comments

System Information
Operating system: Mac

Blender Version
Broken: 4.3 alpha (7daf5a9483)
Worked: -

Short description of error

I cannot install the Atomic Blender PDB extension. Either from the "Missing Built-in Add-ons" or straight from searching Atomic and installing it.

Exact steps for others to reproduce the error

  1. Remove your 4.2 preferences.
  2. Enable Atomic Blender PDB in 4.1, save preferences.
  3. Open 4.2 or 4.3, Import settings from 4.1.
  4. Go to Preferences > Extensions
  5. Open the "Missing Built-in Add-ons" panel.
  6. Find the Atomic there (be sad that the list is not alphabetical based on the names :/).
  7. Try to install it.

Although there are no errors on Blender, on the console I get:

Traceback (most recent call last):
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 3607, in <module>
    sys.exit(main())
             ^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 3600, in main
    result = args.func(args)
             ^^^^^^^^^^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 3304, in <lambda>
    func=lambda args: subcmd_client.install_packages(
                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 2643, in install_packages
    if not subcmd_client._install_package_from_file_impl(
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 2373, in _install_package_from_file_impl
    manifest = pkg_manifest_from_zipfile_and_validate(zip_fh, archive_subdir, strict=False)
               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 629, in pkg_manifest_from_zipfile_and_validate
    manifest = pkg_manifest_from_zipfile_and_validate_impl(
               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 616, in pkg_manifest_from_zipfile_and_validate_impl
    return pkg_manifest_from_dict_and_validate_impl(
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 472, in pkg_manifest_from_dict_and_validate_impl
    if (error_msg := pkg_manifest_is_valid_or_error(data, from_repo=from_repo, strict=strict)) is not None:
                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 1586, in pkg_manifest_is_valid_or_error
    error_list = pkg_manifest_is_valid_or_error_impl(
                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 1565, in pkg_manifest_is_valid_or_error_impl
    if (error_msg := x_check_fn(x_val, strict)) is not None:
                     ^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 1364, in pkg_manifest_validate_field_permissions
    if not isinstance(item_key, str):
                      ^^^^^^^^
UnboundLocalError: cannot access local variable 'item_key' where it is not associated with a value
Package should have been installed but not found: atomic_blender_pdb_xyz
**System Information** Operating system: Mac **Blender Version** Broken: 4.3 alpha (7daf5a9483498027d82f0d18e476b01fe18c3174) Worked: - **Short description of error** I cannot install the Atomic Blender PDB extension. Either from the "Missing Built-in Add-ons" or straight from searching Atomic and installing it. **Exact steps for others to reproduce the error** 1. Remove your 4.2 preferences. 2. Enable Atomic Blender PDB in 4.1, save preferences. 3. Open 4.2 or 4.3, Import settings from 4.1. 4. Go to Preferences > Extensions 5. Open the "Missing Built-in Add-ons" panel. 6. Find the Atomic there (be sad that the list is not alphabetical based on the names :/). 7. Try to install it. Although there are no errors on Blender, on the console I get: ``` Traceback (most recent call last): File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 3607, in <module> sys.exit(main()) ^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 3600, in main result = args.func(args) ^^^^^^^^^^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 3304, in <lambda> func=lambda args: subcmd_client.install_packages( ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 2643, in install_packages if not subcmd_client._install_package_from_file_impl( ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 2373, in _install_package_from_file_impl manifest = pkg_manifest_from_zipfile_and_validate(zip_fh, archive_subdir, strict=False) ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 629, in pkg_manifest_from_zipfile_and_validate manifest = pkg_manifest_from_zipfile_and_validate_impl( ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 616, in pkg_manifest_from_zipfile_and_validate_impl return pkg_manifest_from_dict_and_validate_impl( ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 472, in pkg_manifest_from_dict_and_validate_impl if (error_msg := pkg_manifest_is_valid_or_error(data, from_repo=from_repo, strict=strict)) is not None: ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 1586, in pkg_manifest_is_valid_or_error error_list = pkg_manifest_is_valid_or_error_impl( ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 1565, in pkg_manifest_is_valid_or_error_impl if (error_msg := x_check_fn(x_val, strict)) is not None: ^^^^^^^^^^^^^^^^^^^^^^^^^ File "/Users/dfelinto/src/blender/build_darwin_lite/bin/Blender.app/Contents/Resources/4.3/scripts/addons_core/bl_pkg/cli/blender_ext.py", line 1364, in pkg_manifest_validate_field_permissions if not isinstance(item_key, str): ^^^^^^^^ UnboundLocalError: cannot access local variable 'item_key' where it is not associated with a value Package should have been installed but not found: atomic_blender_pdb_xyz ```
Dalai Felinto added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2024-06-07 01:25:40 +02:00
Dalai Felinto added this to the Python API project 2024-06-07 01:25:40 +02:00
Dalai Felinto added
Module
Python API
Status
Confirmed
Type
Bug
and removed
Status
Needs Triage
Type
Report
labels 2024-06-07 01:26:07 +02:00
Campbell Barton was assigned by Dalai Felinto 2024-06-07 01:26:17 +02:00
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2024-06-07 04:51:32 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
1 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#122857
No description provided.