Extensions: Fix error when trying to install an unsupported package #123241

Closed
opened 2024-06-14 17:51:58 +02:00 by Dalai Felinto · 2 comments

System Information
Operating system: Linux-6.5.0-28-generic-x86_64-with-glibc2.35 64 Bits, X11 UI

Blender Version
Broken: version: 4.2.0 Beta, branch: blender-v4.2-release, commit date: 2024-06-14 14:54, hash: a87907b4259e
Worked: -

Short description of error

Wrong error message when installing unsupported extension.

Exact steps for others to reproduce the error

  • On Linux try to install Bioxel Nodes via dragging.
  • The error I get is:

image

I believe I will get the same error if I try to install an extension that is not listed (e.g., its blender_version_max = current Blender).

**System Information** Operating system: Linux-6.5.0-28-generic-x86_64-with-glibc2.35 64 Bits, X11 UI **Blender Version** Broken: version: 4.2.0 Beta, branch: blender-v4.2-release, commit date: 2024-06-14 14:54, hash: `a87907b4259e` Worked: - **Short description of error** Wrong error message when installing unsupported extension. **Exact steps for others to reproduce the error** * On Linux try to install [Bioxel Nodes](https://extensions.blender.org/add-ons/bioxelnodes/) via dragging. * The error I get is: ![image](/attachments/da522256-e29a-4547-8b27-0ddef950d25c) I believe I will get the same error if I try to install an extension that is not listed (e.g., its blender_version_max = current Blender).
Dalai Felinto added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2024-06-14 17:51:58 +02:00
Dalai Felinto added this to the Python API project 2024-06-14 17:51:59 +02:00
Member

Hi, encountered this once. On next attempt (after clearing extensions folder), I didn't get the "unknown repository" error

Guess installation works next time because the extension is now listed after first attempt?

Hi, encountered this once. On next attempt (after clearing extensions folder), I didn't get the "unknown repository" error Guess installation works next time because the extension is now listed after first attempt?
Member

its blender_version_max = current Blender

But blender_version_max has no value assigned in .toml file of "Bioxel Nodes" add-on.

> its blender_version_max = current Blender But `blender_version_max` has no value assigned in .toml file of "Bioxel Nodes" add-on.
Pratik Borhade added
Module
Python API
Status
Confirmed
and removed
Status
Needs Triage
labels 2024-06-18 12:11:22 +02:00
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2024-06-19 13:13:04 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#123241
No description provided.