Cloth stiffness scaling panel is not working #39371

Closed
opened 2014-03-23 19:51:21 +01:00 by Thomas Beck · 10 comments
Member

Hi Devs,

System Information
Ubuntu64, 16gb ram, haswel i7 4770k

Blender Version
Current dev c359de2

Short description of error
Normally, you should be able to influence the cloth stiffness via a vertex group and the appropriate panel: http://wiki.blender.org/index.php/Doc:2.4/Reference/Panels/Object/Physics/Cloth#Stiffness_Scaling . I know that this doc is for 2.4, but for 2.6 it's not even described even though it is available as a panel.

So my question is: Should this work? Or should we remove it alltogether?
Apart from that the cloth "pre roll" is not working at all - same question here.

Daniel @genscher, I think I got a bug for you here ;)

Exact steps for others to reproduce the error
I uploaded a file( ClothStiffness.blend ) that illustrates the issues, on the left side the one with the vertex group and on the right hand with the pre roll.

Many Greetings, Thomas

Hi Devs, **System Information** Ubuntu64, 16gb ram, haswel i7 4770k **Blender Version** Current dev c359de2 **Short description of error** Normally, you should be able to influence the cloth stiffness via a vertex group and the appropriate panel: http://wiki.blender.org/index.php/Doc:2.4/Reference/Panels/Object/Physics/Cloth#Stiffness_Scaling . I know that this doc is for 2.4, but for 2.6 it's not even described even though it is available as a panel. So my question is: Should this work? Or should we remove it alltogether? Apart from that the cloth "pre roll" is not working at all - same question here. Daniel @genscher, I think I got a bug for you here ;) **Exact steps for others to reproduce the error** I uploaded a file( [ClothStiffness.blend](https://archive.blender.org/developer/F82318/ClothStiffness.blend) ) that illustrates the issues, on the left side the one with the vertex group and on the right hand with the pre roll. Many Greetings, Thomas
Author
Member

Changed status to: 'Open'

Changed status to: 'Open'
Author
Member

Added subscriber: @plasmasolutions

Added subscriber: @plasmasolutions
Author
Member

As an addition: When I try to change the max values under the stiffness scaling vgroup boxes to smth. lower than the normal values on the "cloth" panel then they are reset to the normal values. This is wrong too as you should be able to set this to any value you like but not higher than the normal value ...

As an addition: When I try to change the max values under the stiffness scaling vgroup boxes to smth. lower than the normal values on the "cloth" panel then they are reset to the normal values. This is wrong too as you should be able to set this to any value you like but not higher than the normal value ...

Added subscriber: @koilz

Added subscriber: @koilz

For the vertex group striffness and bending, I think the weight for the vertex group allows the cloth to have a higher stiffness or bending, compared to the normal settings.
Heres a modified example: ClothStiffness2.blend

For the vertex group striffness and bending, I think the weight for the vertex group allows the cloth to have a higher stiffness or bending, compared to the normal settings. Heres a modified example: [ClothStiffness2.blend](https://archive.blender.org/developer/F82333/ClothStiffness2.blend)
Author
Member

Hi Koilz,

thanks for clarifying that - that solves the issue. So in fact you're defining with "max" the stiffness value that the vertices with a value of 1 will take... now it gets clearer. I'll close this issue now and make a new one with the Pre Roll, as this is a separate issue.

Thanks for your help,
Thomas

Hi Koilz, thanks for clarifying that - that solves the issue. So in fact you're defining with "max" the stiffness value that the vertices with a value of 1 will take... now it gets clearer. I'll close this issue now and make a new one with the Pre Roll, as this is a separate issue. Thanks for your help, Thomas
Author
Member

Changed status from 'Open' to: 'Archived'

Changed status from 'Open' to: 'Archived'
Thomas Beck self-assigned this 2014-03-24 09:11:32 +01:00
Author
Member

Koils example file explains it pretty good. This issue is a user incapacity...

Koils example file explains it pretty good. This issue is a user incapacity...

Added subscriber: @lfb3d

Added subscriber: @lfb3d

Thank you @koilz and @plasmasolutions for the additional information about Cloth Stiffness Scaling. Since there is limited documentation, this inspired me to elaborate on the feature and how it works, : http://blender.stackexchange.com/questions/32043/how-does-the-cloth-stiffness-scaling-option-work/32951

Thanks again!

Thank you @koilz and @plasmasolutions for the additional information about Cloth Stiffness Scaling. Since there is limited documentation, this inspired me to elaborate on the feature and how it works, : http://blender.stackexchange.com/questions/32043/how-does-the-cloth-stiffness-scaling-option-work/32951 Thanks again!
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#39371
No description provided.