Subsurf UV is not working (correctly) #48110

Closed
opened 2016-04-11 12:33:59 +02:00 by Andy Goralczyk · 5 comments
Member

Blender Version
Broken: since 2.75
Worked: 2.74

Subsurf UV does not seem to work. I checked this file creature.blend from the blender cloud; in the latest blender and there is a visible seam in the center. the seam is not present in 2.73. subsurf UV used to fix that seam.

Exact steps for others to reproduce the error
Open the attached file, enter textured mode or render viewport to preview the texture.
See screenshot: Screenshot - 11-04-16 - 12:31:26.png

For comparison, this is 2.74: Screenshot - 11-04-16 - 12:32:28.png

**Blender Version** Broken: since 2.75 Worked: 2.74 Subsurf UV does not seem to work. I checked this file [creature.blend](https://archive.blender.org/developer/F302133/creature.blend) from the blender cloud; in the latest blender and there is a visible seam in the center. the seam is not present in 2.73. subsurf UV used to fix that seam. **Exact steps for others to reproduce the error** Open the attached file, enter textured mode or render viewport to preview the texture. See screenshot: ![Screenshot - 11-04-16 - 12:31:26.png](https://archive.blender.org/developer/F302138/Screenshot_-_11-04-16_-_12_31_26.png) For comparison, this is 2.74: ![Screenshot - 11-04-16 - 12:32:28.png](https://archive.blender.org/developer/F302140/Screenshot_-_11-04-16_-_12_32_28.png)
Author
Member

Changed status to: 'Open'

Changed status to: 'Open'
Author
Member

Added subscriber: @eyecandy

Added subscriber: @eyecandy

Added subscriber: @ideasman42

Added subscriber: @ideasman42

This was an intentional change where overlapping UV's (which are commonly used with mirrored meshed) used to contract when subsurf UV's were enabled.

This meant that duplicating and flipping a mesh would give different UV's to having only a single side.

So a change was committed to treat edges along these ares as seams.

This was an intentional change, caused by: #44530

Also, if you check the UV coords, they contract noticeably from the UV boundaries creature.png

... this is an example of how the previous behavior was problematic, that mirroring geometry would noticeably change the sub-surfed coords.

Think this report can be closed as intended change in behavior.

This was an intentional change where overlapping UV's (which are commonly used with mirrored meshed) used to contract when subsurf UV's were enabled. This meant that duplicating and flipping a mesh would give different UV's to having only a single side. So a change was committed to treat edges along these ares as seams. This was an intentional change, caused by: #44530 Also, if you check the UV coords, they contract noticeably from the UV boundaries ![creature.png](https://archive.blender.org/developer/F302148/creature.png) ... this is an example of how the previous behavior was problematic, that mirroring geometry would noticeably change the sub-surfed coords. Think this report can be closed as intended change in behavior.

Changed status from 'Open' to: 'Archived'

Changed status from 'Open' to: 'Archived'
Campbell Barton self-assigned this 2016-04-11 13:10:48 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#48110
No description provided.