UV / Image Editor's Proportional Edit (Connected) doesn't take edge connections into account. #51422

Closed
opened 6 years ago by AdamPreisler · 20 comments

Blender Version
Broken: 2.78

Bug Description
When Proportional Edit (Connected) is active, the same translation of a vertex in 3D View doesn't equal UV / Image Editor's translation of the same vertex.

UV / Image Editor doesn't take distance by edge into account (only checks if it's an island).

Both movements should be like seen in 3D View.

Exact steps for others to reproduce the error
Bug_ProportionalEditConnectedUV2.blend

  • Open the File
  • Try to move the selected vertex in both 3D View and then in UV / Image Editor
**Blender Version** Broken: 2.78 **Bug Description** When Proportional Edit (Connected) is active, the same translation of a vertex in 3D View doesn't equal UV / Image Editor's translation of the same vertex. UV / Image Editor doesn't take distance by edge into account (only checks if it's an island). Both movements should be like seen in 3D View. **Exact steps for others to reproduce the error** [Bug_ProportionalEditConnectedUV2.blend](https://archive.blender.org/developer/F589082/Bug_ProportionalEditConnectedUV2.blend) - Open the File - Try to move the selected vertex in both 3D View and then in UV / Image Editor
Poster

Changed status to: 'Open'

Changed status to: 'Open'
Poster

Added subscriber: @AdamPreisler

Added subscriber: @AdamPreisler
Owner

#54843 was marked as duplicate of this issue

#54843 was marked as duplicate of this issue

Added subscriber: @bliblubli

Added subscriber: @bliblubli

I can confirm the bug.

I can confirm the bug.

Added subscriber: @declara91

Added subscriber: @declara91
brecht commented 5 years ago
Owner

Added subscriber: @thornydre

Added subscriber: @thornydre
Mets commented 4 years ago
Collaborator

Added subscriber: @Mets

Added subscriber: @Mets
Mets commented 4 years ago
Collaborator

I don't even have the option for connected proportional editing in the UV editor anymore, am I just being an idiot? Or was it removed until this gets fixed? Or was it removed with no intention of coming back?

I don't even have the option for connected proportional editing in the UV editor anymore, am I just being an idiot? Or was it removed until this gets fixed? Or was it removed with no intention of coming back?
Collaborator

Added subscriber: @mano-wii

Added subscriber: @mano-wii
Collaborator

This works as designed (only considers islands), but would be interesting to implement.
Marking as To Do

This works as designed (only considers islands), but would be interesting to implement. Marking as To Do

Added subscriber: @zazizizou

Added subscriber: @zazizizou

Added subscriber: @Microbob

Added subscriber: @Microbob

I'm new to blender dev and I'm interested to take a look into this issue.

I've just tested the OP's blender file in blender 2.83.1 and 2.90 alpha (I do see the issue is listed to be broken in 2.78) and I've found a couple of things

  1. The UV unwrapped mesh seems to be incredibly small compared to the edit-mode version (the proportional editing circle is massive in the UV editor as compared to edit mode)

  2. The connected mode seems to be ignored in the UV editor

  3. The translations of the vertices seem to be the same, and I'm actually experiencing a different bug (what I listed above) than what the OP described when trying to reproduce

Please let me know if you have any tips for how to proceed, and if the bug is still there and I'm reproducing it incorrectly.

Thanks!

I'm new to blender dev and I'm interested to take a look into this issue. I've just tested the OP's blender file in blender 2.83.1 and 2.90 alpha (I do see the issue is listed to be broken in 2.78) and I've found a couple of things 1. The UV unwrapped mesh seems to be incredibly small compared to the edit-mode version (the proportional editing circle is massive in the UV editor as compared to edit mode) 2. The connected mode seems to be ignored in the UV editor 3. The translations of the vertices seem to be the same, and I'm actually experiencing a different bug (what I listed above) than what the OP described when trying to reproduce Please let me know if you have any tips for how to proceed, and if the bug is still there and I'm reproducing it incorrectly. Thanks!
APEC commented 3 years ago

Added subscriber: @APEC

Added subscriber: @APEC

Added subscriber: @yulia_maliauka

Added subscriber: @yulia_maliauka

Hi everyone, I was able to confirm the bug in 2.83, but it looks like it's been fixed at some point in 2.91.0. Can anybody confirm that this is still an issue or should this task be closed?

And by fixed, I mean that the proportional edit mode's 'connected only' option seems to behave similarly in the UV editor as it does in the 3D view. There might be other translation issues that were not addressed.

Hi everyone, I was able to confirm the bug in 2.83, but it looks like it's been fixed at some point in 2.91.0. Can anybody confirm that this is still an issue or should this task be closed? And by fixed, I mean that the proportional edit mode's 'connected only' option seems to behave similarly in the UV editor as it does in the 3D view. There might be other translation issues that were not addressed.
Collaborator

Changed status from 'Confirmed' to: 'Needs User Info'

Changed status from 'Confirmed' to: 'Needs User Info'
Mets commented 3 years ago
Collaborator

Changed status from 'Needs User Info' to: 'Resolved'

Changed status from 'Needs User Info' to: 'Resolved'
Mets closed this issue 3 years ago
Mets self-assigned this 3 years ago
Mets commented 3 years ago
Collaborator

This sounds like it must've been fixed by D8289 just a couple weeks back!

This sounds like it must've been fixed by [D8289](https://archive.blender.org/developer/D8289) just a couple weeks back!
Sign in to join this conversation.
No Label
Interest/Performance
legacy module/Animation & Rigging
legacy module/Core
legacy module/Development Management
legacy module/Eevee & Viewport
legacy module/Grease Pencil
legacy module/Modeling
legacy module/Nodes & Physics
legacy module/Pipeline, Assets & IO
legacy module/Platforms, Builds, Tests & Devices
legacy module/Python API
legacy module/Rendering & Cycles
legacy module/Sculpt, Paint & Texture
legacy module/Triaging
legacy module/User Interface
legacy module/VFX & Video
legacy project/1.0.0-beta.2
legacy project/Alembic
legacy project/Animation & Rigging
legacy project/Asset Browser
legacy project/Asset Browser (Archived)
legacy project/Asset Browser Project Overview
legacy project/Audio
legacy project/Automated Testing
legacy project/BF Blender: 2.8
legacy project/BF Blender: After Release
legacy project/BF Blender: Next
legacy project/BF Blender: Regressions
legacy project/BF Blender: Unconfirmed
legacy project/Blender 2.70
legacy project/Blender Asset Bundle
legacy project/Code Quest
legacy project/Collada
legacy project/Compositing
legacy project/Core
legacy project/Cycles
legacy project/Datablocks and Libraries
legacy project/Dependency Graph
legacy project/Development Management
legacy project/Eevee
legacy project/EEVEE & Viewport
legacy project/Freestyle
legacy project/Game Animation
legacy project/Game Audio
legacy project/Game Data Conversion
legacy project/Game Engine
legacy project/Game Logic
legacy project/Game Physics
legacy project/Game Python
legacy project/Game Rendering
legacy project/Game UI
legacy project/Geometry Nodes
legacy project/Good First Issue
legacy project/GPU / Viewport
legacy project/Grease Pencil
legacy project/GSoC
legacy project/Images & Movies
legacy project/Import/Export
legacy project/Infrastructure: Websites
legacy project/LibOverrides - Usability and UX
legacy project/Line Art
legacy project/Masking
legacy project/Milestone 1: Basic, Local Asset Browser
legacy project/Modeling
legacy project/Modifiers
legacy project/Motion Tracking
legacy project/Nodes
legacy project/Nodes & Physics
legacy project/OpenGL Error
legacy project/Overrides
legacy project/Papercut
legacy project/Performance
legacy project/Physics
legacy project/Pipeline, Assets & I/O
legacy project/Platform: FreeBSD
legacy project/Platform: Linux
legacy project/Platform: macOS
legacy project/Platforms, Builds, Tests & Devices
legacy project/Platform: Windows
legacy project/Pose Library Basics
legacy project/Python API
legacy project/Render & Cycles
legacy project/Render Pipeline
legacy project/Retrospective
legacy project/Sculpt, Paint & Texture
legacy project/Text Editor
legacy project/Tracker Curfew
legacy project/Translations
legacy project/Triaging
legacy project/Undo
legacy project/USD
legacy project/User Interface
legacy project/UV Editing
legacy project/VFX & Video
legacy project/Video Sequencer
legacy project/Virtual Reality
legacy project/Wintab High Frequency
Meta/Good First Issue
Meta/Papercut
migration/requires-manual-verification
Module › Animation & Rigging
Module › Core
Module › Development Management
Module › Eevee & Viewport
Module › Grease Pencil
Module › Modeling
Module › Nodes & Physics
Module › Pipeline, Assets & IO
Module › Platforms, Builds Tests & Devices
Module › Platforms, Builds, Tests & Devices
Module › Python API
Module › Render & Cycles
Module › Sculpt, Paint & Texture
Module › Triaging
Module › User Interface
Module › VFX & Video
Priority › High
Priority › Low
Priority › Normal
Priority › Unbreak Now!
Status › Archived
Status › Confirmed
Status › Duplicate
Status › Needs Information from Developers
Status › Needs Information from User
Status › Needs Triage
Status › Resolved
Type › Bug
Type › Design
Type › Known Issue
Type › Patch
Type › Report
Type › To Do
No Milestone
No project
No Assignees
12 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#51422
Loading…
There is no content yet.