Force field not affecting rigid body simulation #58991

Closed
opened 4 years ago by thornydre · 24 comments

System Information
Operating system: Windoxs 10
Graphics card: GeForce GTX 1060

Blender Version
Broken: 2.80, 6a4e8096973, blender2.8, 2015-12-07 18.28
Worked: 2.79

Short description of error
Adding a force field to a rigid body simulation does not change anything.

Exact steps for others to reproduce the error

  • Quick rigid body setup with a sphere falling on a plane
  • Add a "Force" force field
  • Start the simulation
**System Information** Operating system: Windoxs 10 Graphics card: GeForce GTX 1060 **Blender Version** Broken: 2.80, 6a4e8096973, blender2.8, 2015-12-07 18.28 Worked: 2.79 **Short description of error** Adding a force field to a rigid body simulation does not change anything. **Exact steps for others to reproduce the error** - Quick rigid body setup with a sphere falling on a plane - Add a "Force" force field - Start the simulation
Owner

#64493 was marked as duplicate of this issue

#64493 was marked as duplicate of this issue
Owner

#59135 was marked as duplicate of this issue

#59135 was marked as duplicate of this issue
Poster

Added subscriber: @thornydre

Added subscriber: @thornydre

Added subscriber: @StephenSwaney

Added subscriber: @StephenSwaney

Please attach a .blend showing the problem.

Please attach a .blend showing the problem.
Poster

Sorry about that, here is a file for 2.80:
rigi_body_2_80.blend

And the same file working in 2.79:
rigi_body_2_79.blend

Sorry about that, here is a file for 2.80: [rigi_body_2_80.blend](https://archive.blender.org/developer/F5888449/rigi_body_2_80.blend) And the same file working in 2.79: [rigi_body_2_79.blend](https://archive.blender.org/developer/F5888448/rigi_body_2_79.blend)

Thank you!

Thank you!
sreich was assigned by ZedDB 4 years ago
ZedDB commented 4 years ago
Collaborator

Added subscriber: @Cyclic51

Added subscriber: @Cyclic51
sreich commented 4 years ago

Added subscribers: @mont29, @Sergey

Added subscribers: @mont29, @Sergey
sreich commented 4 years ago

Ok, I fixed part of this in 5cc015f0ad.
However there's another regression. Changes to force fields don't mark the rigid body cache as outdated (the PTCACHE_OUTDATED flag needs to be set).
I don't think I have time to figure out how the depsgraph works to add the proper relations for that, so I think either @Sergey or @mont29 should take a look.

Ok, I fixed part of this in 5cc015f0ad05. However there's another regression. Changes to force fields don't mark the rigid body cache as outdated (the PTCACHE_OUTDATED flag needs to be set). I don't think I have time to figure out how the depsgraph works to add the proper relations for that, so I think either @Sergey or @mont29 should take a look.
sreich removed their assignment 4 years ago
sreich commented 4 years ago

Added subscriber: @sreich

Added subscriber: @sreich
Collaborator

Added subscriber: @JacquesLucke

Added subscriber: @JacquesLucke
Collaborator

@sreich, is this still an issue?

@sreich, is this still an issue?
Sergey commented 4 years ago
Owner

I can not reproduce the issue, behavior seems to be the same in 2.79 and current master.
There was a of fixes done in the area, so probably got fixed as a part of another issue?

I can not reproduce the issue, behavior seems to be the same in 2.79 and current master. There was a of fixes done in the area, so probably got fixed as a part of another issue?
sreich commented 4 years ago

As I mentioned there is a second regression here, in that changes to the force field don't invalidate rigid body cache.
Simple way to reproduce:

  1. Add a rigid body.
  2. Add a force field.
  3. Simulate a few frames.
  4. Change force field strength and see that the rigid body cache hasn't been invalidated.
As I mentioned there is a second regression here, in that changes to the force field don't invalidate rigid body cache. Simple way to reproduce: 1. Add a rigid body. 2. Add a force field. 3. Simulate a few frames. 4. Change force field strength and see that the rigid body cache hasn't been invalidated.
ZedDB commented 4 years ago
Collaborator
Added subscribers: @mushroomeo, @christopher.burns, @Ekiwnox, @ZedDB
Sergey was assigned by ZedDB 4 years ago

Added subscriber: @a.monti

Added subscriber: @a.monti

This comment was removed by @a.monti

*This comment was removed by @a.monti*
Poster

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
thornydre closed this issue 4 years ago
Poster

This task seems to be resolved

This task seems to be resolved

Definitely not resolved for me..
Adding force fields or changing their parameters don't trigger cache invalidation for rigid bodies.

Changing parameters works for particles and soft bodies, but adding new force fields don't.

Definitely not resolved for me.. Adding force fields or changing their parameters don't trigger cache invalidation for rigid bodies. Changing parameters works for particles and soft bodies, but adding new force fields don't.
Sergey commented 4 years ago
Owner

If there are still issues make a new report, with all the requested information.

If there are still issues make a new report, with all the requested information.

In #58991#707341, @Sergey wrote:
If there are still issues make a new report, with all the requested information.

There are already a couple merged into this one: #64493 and #59135
and also this one created yesterday: #66105

I was commenting here since @ZedDB seemed to have choosen this as the main task for the issue, I can open a new one if you want so though.

> In #58991#707341, @Sergey wrote: > If there are still issues make a new report, with all the requested information. There are already a couple merged into this one: #64493 and #59135 and also this one created yesterday: #66105 I was commenting here since @ZedDB seemed to have choosen this as the main task for the issue, I can open a new one if you want so though.
Sergey commented 4 years ago
Owner

If your issue has already an open task there is no need to open a new one. But when a task is not fully resolved for you, or re-appeared, or anything like is totally worth opening a new task.

This helps keeping track of changes and fixes, saves time when we need to look in a history (we can easily get all relevant information from a task, without need to read an entire conversation trying to not miss any crucial detail).

If your issue has already an open task there is no need to open a new one. But when a task is not fully resolved for you, or re-appeared, or anything like is totally worth opening a new task. This helps keeping track of changes and fixes, saves time when we need to look in a history (we can easily get all relevant information from a task, without need to read an entire conversation trying to not miss any crucial detail).
Sign in to join this conversation.
No Label
good first issue
legacy module/Animation & Rigging
legacy module/Core
legacy module/Development Management
legacy module/Eevee & Viewport
legacy module/Grease Pencil
legacy module/Modeling
legacy module/Nodes & Physics
legacy module/Pipeline, Assets & IO
legacy module/Platforms, Builds, Tests & Devices
legacy module/Python API
legacy module/Rendering & Cycles
legacy module/Sculpt, Paint & Texture
legacy module/Triaging
legacy module/User Interface
legacy module/VFX & Video
legacy project/1.0.0-beta.2
legacy project/2.81
legacy project/2.82
legacy project/2.83
legacy project/2.90
legacy project/2.91
legacy project/2.92
legacy project/3.0
legacy project/3.1
legacy project/3.2
legacy project/3.3
legacy project/Alembic
legacy project/Animation & Rigging
legacy project/Asset Browser
legacy project/Asset Browser (Archived)
legacy project/Asset Browser Project Overview
legacy project/Audio
legacy project/Automated Testing
legacy project/BF Blender: 2.8
legacy project/BF Blender: After Release
legacy project/BF Blender: Next
legacy project/BF Blender: Regressions
legacy project/BF Blender: Unconfirmed
legacy project/Blender 2.70
legacy project/Blender Asset Bundle
legacy project/Code Quest
legacy project/Collada
legacy project/Compositing
legacy project/Core
legacy project/Cycles
legacy project/Datablocks and Libraries
legacy project/Dependency Graph
legacy project/Development Management
legacy project/Eevee
legacy project/EEVEE & Viewport
legacy project/Freestyle
legacy project/Game Animation
legacy project/Game Audio
legacy project/Game Data Conversion
legacy project/Game Engine
legacy project/Game Logic
legacy project/Game Physics
legacy project/Game Python
legacy project/Game Rendering
legacy project/Game UI
legacy project/Geometry Nodes
legacy project/Good First Issue
legacy project/GPU / Viewport
legacy project/Grease Pencil
legacy project/GSoC
legacy project/Images & Movies
legacy project/Import/Export
legacy project/Infrastructure: Websites
legacy project/LibOverrides - Usability and UX
legacy project/Line Art
legacy project/Masking
legacy project/Milestone 1: Basic, Local Asset Browser
legacy project/Modeling
legacy project/Modifiers
legacy project/Motion Tracking
legacy project/Nodes
legacy project/Nodes & Physics
legacy project/OpenGL Error
legacy project/Overrides
legacy project/Papercut
legacy project/Performance
legacy project/Physics
legacy project/Pipeline, Assets & I/O
legacy project/Platform: FreeBSD
legacy project/Platform: Linux
legacy project/Platform: macOS
legacy project/Platforms, Builds, Tests & Devices
legacy project/Platform: Windows
legacy project/Pose Library Basics
legacy project/Python API
legacy project/Render & Cycles
legacy project/Render Pipeline
legacy project/Retrospective
legacy project/Sculpt, Paint & Texture
legacy project/Text Editor
legacy project/Tracker Curfew
legacy project/Translations
legacy project/Triaging
legacy project/Undo
legacy project/USD
legacy project/User Interface
legacy project/UV Editing
legacy project/VFX & Video
legacy project/Video Sequencer
legacy project/Virtual Reality
legacy project/Wintab High Frequency
migration/requires-manual-verification
Module › Animation & Rigging
Module › Core
Module › Development Management
Module › Eevee & Viewport
Module › EEVEE & Viewport
Module › Grease Pencil
Module › Modeling
Module › Nodes & Physics
Module › Pipeline, Assets & IO
Module › Platforms, Builds Tests & Devices
Module › Platforms, Builds, Tests & Devices
Module › Python API
Module › Rendering & Cycles
Module › Sculpt, Paint & Texture
Module › Triaging
Module › User Interface
Module › VFX & Video
papercut
performance
Priority › High
Priority › Low
Priority › Normal
Priority › Unbreak Now!
Status › Archived
Status › Confirmed
Status › Duplicate
Status › Needs Information from Developers
Status › Needs Information from User
Status › Needs Triage
Status › Resolved
Type › Bug
Type › Design
Type › Known Issue
Type › Patch
Type › Report
Type › To Do
No Milestone
No project
No Assignees
8 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#58991
Loading…
There is no content yet.