Vertex/Weight Paint: Global undo causes brush & tool settings to be handled along with vertex paint data #70814

Closed
opened 3 years ago by Stan_Pancakes · 19 comments

Blender Version
Broken: blender-2.81-95f020c853d6
Broken: blender-2.82-bde328352be2

Short description of error
Picking a color to paint with, brush strength and radius, etc., are undone if the brush stroke following these changes is undone.

Exact steps for others to reproduce the error

  1. Create a new scene.
  2. Select the cube and enter vertex paint mode.
  3. Pick a different color.
  4. Perform one stroke (i.e. click).
  5. Undo.

Expected: stroke is undone, new color selection remains.
Current: stroke is undone, color selection is also undone.

**Blender Version** Broken: blender-2.81-95f020c853d6 Broken: blender-2.82-bde328352be2 **Short description of error** Picking a color to paint with, brush strength and radius, etc., are undone if the brush stroke following these changes is undone. **Exact steps for others to reproduce the error** 1. Create a new scene. 2. Select the cube and enter vertex paint mode. 3. Pick a different color. 4. Perform one stroke (i.e. click). 5. Undo. Expected: stroke is undone, new color selection remains. Current: stroke is undone, color selection is also undone.
Poster

Added subscriber: @Stan_Pancakes

Added subscriber: @Stan_Pancakes
Owner

Added subscriber: @ideasman42

Added subscriber: @ideasman42
Owner

Changed status from 'Open' to: 'Archived'

Changed status from 'Open' to: 'Archived'
ideasman42 closed this issue 3 years ago
ideasman42 self-assigned this 3 years ago
Owner

Currently vertex/weight paint undo manages all data including brushes.

While we could support moving some settings outside of undo that's a feature request.

Closing.

Currently vertex/weight paint undo manages all data including brushes. While we could support moving some settings outside of undo that's a feature request. Closing.
Poster

A bug in the design is still a bug. The behavior is unexpected, moreover it's inconsistent across Blender's paint modes:

  • in texture paint, undoing a stroke does not undo preceding color selection
  • in sculpt mode, undoing a stroke does not undo preceding strength selection
  • in vertex color paint, undoing a stroke undoes preceding color selection
  • in weight paint, undoing a stroke undoes preceding weight selection

Why should this even need a feature request?

A bug in the design is still a bug. The behavior is unexpected, moreover it's inconsistent across Blender's paint modes: - in texture paint, undoing a stroke does *not* undo preceding color selection - in sculpt mode, undoing a stroke does *not* undo preceding strength selection - in vertex color paint, undoing a stroke *undoes* preceding color selection - in weight paint, undoing a stroke *undoes* preceding weight selection Why should this even need a feature request?

Added subscriber: @WilliamReynish

Added subscriber: @WilliamReynish

Changed status from 'Archived' to: 'Confirmed'

Changed status from 'Archived' to: 'Confirmed'
WilliamReynish reopened this issue 3 years ago

I could reproduce the issue.

I am re-opening this. IMO this is very clearly a bug - in this case one undo action goes back two steps.

Maybe it's not trivial to fix, but it's still a bug.

I could reproduce the issue. I am re-opening this. IMO this is very clearly a bug - in this case one undo action goes back two steps. Maybe it's not trivial to fix, but it's still a bug.
Poster

Perhaps it could be worded differently, I'll edit the title and description.

Perhaps it could be worded differently, I'll edit the title and description.
Stan_Pancakes changed title from Vertex Paint color selection doesn't create undo step to Vertex Paint: undoing paint stroke also undoes preceding tool changes 3 years ago
ideasman42 changed title from Vertex Paint: undoing paint stroke also undoes preceding tool changes to Vertex/Weight Paint: Global undo causes brush & tool settings to be handled along with vertex paint data 3 years ago
Owner

Marking as TODO in the sculpt paint module, since this is working as intended (since undo was initially supported I would guess), even if it arguably should work differently.

Marking as TODO in the sculpt paint module, since this is working as intended *(since undo was initially supported I would guess)*, even if it arguably should work differently.

Added subscriber: @DanielGrauer

Added subscriber: @DanielGrauer
Leul commented 3 years ago

Added subscriber: @Leul

Added subscriber: @Leul
Leul commented 3 years ago

This bug is really annoying, is there no hope for it..?

This bug is really annoying, is there no hope for it..?
Collaborator

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Collaborator

Note #69760 (Undo/Adjust Last Operation: vertex and weightpaint operators/strokes undo more then they should (change back any setting changed prior to execution)) is related (though that one is for operators)

Note #69760 (Undo/Adjust Last Operation: vertex and weightpaint operators/strokes undo more then they should (change back any setting changed prior to execution)) is related (though that one is for operators)
pwcb commented 3 years ago

Added subscriber: @pwcb

Added subscriber: @pwcb
pwcb commented 3 years ago

This effects everything from the vertex group you have selected, to all brush settings. So you'll switch the bone you want to paint for, change the brush size and weight, make a mark and undo it, and all these settings will be undone. Extremely annoying.

I'm guessing someone saw how Photoshop will lump any layer setting changes in with the next brushstroke you make as a single undo and thought this was a feature, when it's something everyone complains about. I can't think of any other reasoning that would make this seem appealing.

This effects everything from the vertex group you have selected, to all brush settings. So you'll switch the bone you want to paint for, change the brush size and weight, make a mark and undo it, and all these settings will be undone. Extremely annoying. I'm guessing someone saw how Photoshop will lump any layer setting changes in with the next brushstroke you make as a single undo and thought this was a feature, when it's something everyone complains about. I can't think of any other reasoning that would make this seem appealing.
Leul commented 3 years ago

am hoping D7518 will solve this

am hoping [D7518](https://archive.blender.org/developer/D7518) will solve this
Owner

Closed as duplicate of #71759

Closed as duplicate of #71759
ideasman42 closed this issue 3 years ago
Sign in to join this conversation.
No Label
good first issue
legacy module/Animation & Rigging
legacy module/Core
legacy module/Development Management
legacy module/Eevee & Viewport
legacy module/Grease Pencil
legacy module/Modeling
legacy module/Nodes & Physics
legacy module/Pipeline, Assets & IO
legacy module/Platforms, Builds, Tests & Devices
legacy module/Python API
legacy module/Rendering & Cycles
legacy module/Sculpt, Paint & Texture
legacy module/Triaging
legacy module/User Interface
legacy module/VFX & Video
legacy project/1.0.0-beta.2
legacy project/2.81
legacy project/2.82
legacy project/2.83
legacy project/2.90
legacy project/2.91
legacy project/2.92
legacy project/3.0
legacy project/3.1
legacy project/3.2
legacy project/3.3
legacy project/Alembic
legacy project/Animation & Rigging
legacy project/Asset Browser
legacy project/Asset Browser (Archived)
legacy project/Asset Browser Project Overview
legacy project/Audio
legacy project/Automated Testing
legacy project/BF Blender: 2.8
legacy project/BF Blender: After Release
legacy project/BF Blender: Next
legacy project/BF Blender: Regressions
legacy project/BF Blender: Unconfirmed
legacy project/Blender 2.70
legacy project/Blender Asset Bundle
legacy project/Code Quest
legacy project/Collada
legacy project/Compositing
legacy project/Core
legacy project/Cycles
legacy project/Datablocks and Libraries
legacy project/Dependency Graph
legacy project/Development Management
legacy project/Eevee
legacy project/EEVEE & Viewport
legacy project/Freestyle
legacy project/Game Animation
legacy project/Game Audio
legacy project/Game Data Conversion
legacy project/Game Engine
legacy project/Game Logic
legacy project/Game Physics
legacy project/Game Python
legacy project/Game Rendering
legacy project/Game UI
legacy project/Geometry Nodes
legacy project/Good First Issue
legacy project/GPU / Viewport
legacy project/Grease Pencil
legacy project/GSoC
legacy project/Images & Movies
legacy project/Import/Export
legacy project/Infrastructure: Websites
legacy project/LibOverrides - Usability and UX
legacy project/Line Art
legacy project/Masking
legacy project/Milestone 1: Basic, Local Asset Browser
legacy project/Modeling
legacy project/Modifiers
legacy project/Motion Tracking
legacy project/Nodes
legacy project/Nodes & Physics
legacy project/OpenGL Error
legacy project/Overrides
legacy project/Papercut
legacy project/Performance
legacy project/Physics
legacy project/Pipeline, Assets & I/O
legacy project/Platform: FreeBSD
legacy project/Platform: Linux
legacy project/Platform: macOS
legacy project/Platforms, Builds, Tests & Devices
legacy project/Platform: Windows
legacy project/Pose Library Basics
legacy project/Python API
legacy project/Render & Cycles
legacy project/Render Pipeline
legacy project/Retrospective
legacy project/Sculpt, Paint & Texture
legacy project/Text Editor
legacy project/Tracker Curfew
legacy project/Translations
legacy project/Triaging
legacy project/Undo
legacy project/USD
legacy project/User Interface
legacy project/UV Editing
legacy project/VFX & Video
legacy project/Video Sequencer
legacy project/Virtual Reality
legacy project/Wintab High Frequency
migration/requires-manual-verification
Module › Animation & Rigging
Module › Core
Module › Development Management
Module › Eevee & Viewport
Module › EEVEE & Viewport
Module › Grease Pencil
Module › Modeling
Module › Nodes & Physics
Module › Pipeline, Assets & IO
Module › Platforms, Builds Tests & Devices
Module › Platforms, Builds, Tests & Devices
Module › Python API
Module › Rendering & Cycles
Module › Sculpt, Paint & Texture
Module › Triaging
Module › User Interface
Module › VFX & Video
papercut
performance
Priority › High
Priority › Low
Priority › Normal
Priority › Unbreak Now!
Status › Archived
Status › Confirmed
Status › Duplicate
Status › Needs Information from Developers
Status › Needs Information from User
Status › Needs Triage
Status › Resolved
Type › Bug
Type › Design
Type › Known Issue
Type › Patch
Type › Report
Type › To Do
No Milestone
No project
No Assignees
7 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#70814
Loading…
There is no content yet.