Weird face dots in UV editor with cage mode on of subdivision modifier. #71194

Closed
opened 3 years ago by SouvikKarmakar · 9 comments

System Information
Operating system: Win 10 pro
Graphics card: Nvidia Gtx 960

Blender Version
Broken: 2.81 (sub 16), branch: master, commit date: 2019-10-28 18:34, hash: 7c1fbe24ca, type: Release
Worked: (optional)

Short description of error
Blender UV face dot issue.jpg
As you can see in this screenshot I am having weird face dots position in uv editor in cage mode on of subdivision modifier. If I uncheck cage mode face dots appear properly.
Exact steps for others to reproduce the error
Just turn on cage of subdivision modifier and see where the face dots goes in uv editor.

Example file
Face_dot_issue.blend

**System Information** Operating system: Win 10 pro Graphics card: Nvidia Gtx 960 **Blender Version** Broken: 2.81 (sub 16), branch: master, commit date: 2019-10-28 18:34, hash: 7c1fbe24ca33, type: Release Worked: (optional) **Short description of error** ![Blender UV face dot issue.jpg](https://archive.blender.org/developer/F7869547/Blender_UV_face_dot_issue.jpg) As you can see in this screenshot I am having weird face dots position in uv editor in cage mode on of subdivision modifier. If I uncheck cage mode face dots appear properly. **Exact steps for others to reproduce the error** Just turn on cage of subdivision modifier and see where the face dots goes in uv editor. **Example file** [Face_dot_issue.blend](https://archive.blender.org/developer/F7873305/Face_dot_issue.blend)
Poster

Added subscriber: @SouvikKarmakar

Added subscriber: @SouvikKarmakar
ideasman42 was assigned by SouvikKarmakar 3 years ago
Owner

Please include blend file.

Please include blend file.
Poster

Example file added to the descriiption.

Example file added to the descriiption.
Collaborator

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Collaborator

Looks like corrupt geometry, getting a bunch of these, needs more investigation

Invalid Index: at /blender/source/blender/bmesh/intern/bmesh_mesh.c:1717, BM_mesh_elem_index_ensure_ex, vert[2011] invalid index 15, 'Should Never Fail!', 'BM_mesh_elem_index_ensure_ex
Looks like corrupt geometry, getting a bunch of these, needs more investigation ``` Invalid Index: at /blender/source/blender/bmesh/intern/bmesh_mesh.c:1717, BM_mesh_elem_index_ensure_ex, vert[2011] invalid index 15, 'Should Never Fail!', 'BM_mesh_elem_index_ensure_ex ```
Poster

In #71194#803583, @lichtwerk wrote:
Looks like corrupt geometry, getting a bunch of these, needs more investigation

Invalid Index: at /blender/source/blender/bmesh/intern/bmesh_mesh.c:1717, BM_mesh_elem_index_ensure_ex, vert[2011] invalid index 15, 'Should Never Fail!', 'BM_mesh_elem_index_ensure_ex

We can also see it in suzzane.Subsurface modifier with cage on and in uv editor face select mode on.
Suzanne.blend

> In #71194#803583, @lichtwerk wrote: > Looks like corrupt geometry, getting a bunch of these, needs more investigation > > ``` > Invalid Index: at /blender/source/blender/bmesh/intern/bmesh_mesh.c:1717, BM_mesh_elem_index_ensure_ex, vert[2011] invalid index 15, 'Should Never Fail!', 'BM_mesh_elem_index_ensure_ex > ``` We can also see it in suzzane.Subsurface modifier with cage on and in uv editor face select mode on. [Suzanne.blend](https://archive.blender.org/developer/F7873440/Suzanne.blend)
Collaborator

Not sure what was wrong, not getting the invalid index anymore, need to look at this with a fresh eye...

Not sure what was wrong, not getting the invalid index anymore, need to look at this with a fresh eye...
Owner

This issue was referenced by 5cf5dfcfad

This issue was referenced by 5cf5dfcfadf5d276931ea4e5f634b92cccdba124
Owner

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
ideasman42 closed this issue 3 years ago
Sign in to join this conversation.
No Label
good first issue
legacy module/Animation & Rigging
legacy module/Core
legacy module/Development Management
legacy module/Eevee & Viewport
legacy module/Grease Pencil
legacy module/Modeling
legacy module/Nodes & Physics
legacy module/Pipeline, Assets & IO
legacy module/Platforms, Builds, Tests & Devices
legacy module/Python API
legacy module/Rendering & Cycles
legacy module/Sculpt, Paint & Texture
legacy module/Triaging
legacy module/User Interface
legacy module/VFX & Video
legacy project/1.0.0-beta.2
legacy project/2.81
legacy project/2.82
legacy project/2.83
legacy project/2.90
legacy project/2.91
legacy project/2.92
legacy project/3.0
legacy project/3.1
legacy project/3.2
legacy project/3.3
legacy project/Alembic
legacy project/Animation & Rigging
legacy project/Asset Browser
legacy project/Asset Browser (Archived)
legacy project/Asset Browser Project Overview
legacy project/Audio
legacy project/Automated Testing
legacy project/BF Blender: 2.8
legacy project/BF Blender: After Release
legacy project/BF Blender: Next
legacy project/BF Blender: Regressions
legacy project/BF Blender: Unconfirmed
legacy project/Blender 2.70
legacy project/Blender Asset Bundle
legacy project/Code Quest
legacy project/Collada
legacy project/Compositing
legacy project/Core
legacy project/Cycles
legacy project/Datablocks and Libraries
legacy project/Dependency Graph
legacy project/Development Management
legacy project/Eevee
legacy project/EEVEE & Viewport
legacy project/Freestyle
legacy project/Game Animation
legacy project/Game Audio
legacy project/Game Data Conversion
legacy project/Game Engine
legacy project/Game Logic
legacy project/Game Physics
legacy project/Game Python
legacy project/Game Rendering
legacy project/Game UI
legacy project/Geometry Nodes
legacy project/Good First Issue
legacy project/GPU / Viewport
legacy project/Grease Pencil
legacy project/GSoC
legacy project/Images & Movies
legacy project/Import/Export
legacy project/Infrastructure: Websites
legacy project/LibOverrides - Usability and UX
legacy project/Line Art
legacy project/Masking
legacy project/Milestone 1: Basic, Local Asset Browser
legacy project/Modeling
legacy project/Modifiers
legacy project/Motion Tracking
legacy project/Nodes
legacy project/Nodes & Physics
legacy project/OpenGL Error
legacy project/Overrides
legacy project/Papercut
legacy project/Performance
legacy project/Physics
legacy project/Pipeline, Assets & I/O
legacy project/Platform: FreeBSD
legacy project/Platform: Linux
legacy project/Platform: macOS
legacy project/Platforms, Builds, Tests & Devices
legacy project/Platform: Windows
legacy project/Pose Library Basics
legacy project/Python API
legacy project/Render & Cycles
legacy project/Render Pipeline
legacy project/Retrospective
legacy project/Sculpt, Paint & Texture
legacy project/Text Editor
legacy project/Tracker Curfew
legacy project/Translations
legacy project/Triaging
legacy project/Undo
legacy project/USD
legacy project/User Interface
legacy project/UV Editing
legacy project/VFX & Video
legacy project/Video Sequencer
legacy project/Virtual Reality
legacy project/Wintab High Frequency
migration/requires-manual-verification
Module › Animation & Rigging
Module › Core
Module › Development Management
Module › Eevee & Viewport
Module › EEVEE & Viewport
Module › Grease Pencil
Module › Modeling
Module › Nodes & Physics
Module › Pipeline, Assets & IO
Module › Platforms, Builds Tests & Devices
Module › Platforms, Builds, Tests & Devices
Module › Python API
Module › Rendering & Cycles
Module › Sculpt, Paint & Texture
Module › Triaging
Module › User Interface
Module › VFX & Video
papercut
performance
Priority › High
Priority › Low
Priority › Normal
Priority › Unbreak Now!
Status › Archived
Status › Confirmed
Status › Duplicate
Status › Needs Information from Developers
Status › Needs Information from User
Status › Needs Triage
Status › Resolved
Type › Bug
Type › Design
Type › Known Issue
Type › Patch
Type › Report
Type › To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#71194
Loading…
There is no content yet.