Sculpt/Vertex/Weight Paint Brush Size Gets Undone After Undoing a Stroke #71759

Closed
opened 2019-11-22 02:59:36 +01:00 by Seth Quick · 129 comments

System Information
Operating system: Win 10
Graphics card: 1060 3gb

Blender Version
Broken: version: 2.83 (sub 0), branch: master, commit date: 2020-01-10 15:03, hash: 89578a8f6e

Short description of error
After changing the size, then doing a strike and immediately undoing it, the brush size gets undone as well.

Steps to reproduce

  • Splash Screen > Sculpting or File > New > Sculpting.
  • Change the size of the brush ]
  • Sculpt: Only one stroke.
  • Undo
**System Information** Operating system: Win 10 Graphics card: 1060 3gb **Blender Version** Broken: version: 2.83 (sub 0), branch: master, commit date: 2020-01-10 15:03, hash: `89578a8f6e` **Short description of error** After changing the size, then doing a strike and immediately undoing it, the brush size gets undone as well. **Steps to reproduce** - Splash Screen > Sculpting or File > New > Sculpting. - Change the size of the brush `]` - Sculpt: Only one stroke. - Undo
Author

Added subscriber: @SethTooQuick

Added subscriber: @SethTooQuick

#82029 was marked as duplicate of this issue

#82029 was marked as duplicate of this issue

#77076 was marked as duplicate of this issue

#77076 was marked as duplicate of this issue

#70814 was marked as duplicate of this issue

#70814 was marked as duplicate of this issue

#76087 was marked as duplicate of this issue

#76087 was marked as duplicate of this issue

#73749 was marked as duplicate of this issue

#73749 was marked as duplicate of this issue

#73040 was marked as duplicate of this issue

#73040 was marked as duplicate of this issue

#71985 was marked as duplicate of this issue

#71985 was marked as duplicate of this issue

#72984 was marked as duplicate of this issue

#72984 was marked as duplicate of this issue

#72560 was marked as duplicate of this issue

#72560 was marked as duplicate of this issue

#72435 was marked as duplicate of this issue

#72435 was marked as duplicate of this issue

#71824 was marked as duplicate of this issue

#71824 was marked as duplicate of this issue

Added subscriber: @ideasman42

Added subscriber: @ideasman42

I can't redo this in the official 2.81 release.

This was fixed as part of #71434.

If this happens in the 2.81 release, please detail the exact steps to redo.

I can't redo this in the official 2.81 release. This was fixed as part of #71434. If this happens in the 2.81 release, please detail the exact steps to redo.

Added subscriber: @TheRedWaxPolice

Added subscriber: @TheRedWaxPolice

@ideasman42 I can confirm, it's still happening... at least on 2.82 (blender-2.82-f903835370bc-windows64)

2019-11-22_04-18-00.mp4

@ideasman42 I can confirm, it's still happening... at least on 2.82 (blender-2.82-f903835370bc-windows64) [2019-11-22_04-18-00.mp4](https://archive.blender.org/developer/F8153657/2019-11-22_04-18-00.mp4)

This is working for me on the default cube.

Please post steps to redo this from the default startup, or a blend file with steps to redo.

This is working for me on the default cube. Please post steps to redo this from the default startup, or a blend file with steps to redo.
Author

Tried it on a default cube as well, and it works fine. Must be when you start it up as a sculpt session from the splash screen?

Tried it on a default cube as well, and it works fine. Must be when you start it up as a sculpt session from the splash screen?
Author

This seems to be the case.

This seems to be the case.
Author

It only happens when you start it in sculpting layout.
Change Size, Stroke, Undo: Happens
Stroke, Change Size, Undo: Happens
Stroke, Stroke, Change Size, Undo: Doesn't Happen
Change Size, Stroke, Stroke, Undo: Doesn't Happen

Copied Sphere, put it in normal layout, Stroke Change Size etc.: Doesn't Happen

This bug kinda sucks and noticed it right off the bat.

It only happens when you start it in sculpting layout. Change Size, Stroke, Undo: Happens Stroke, Change Size, Undo: Happens Stroke, Stroke, Change Size, Undo: Doesn't Happen Change Size, Stroke, Stroke, Undo: Doesn't Happen Copied Sphere, put it in normal layout, Stroke Change Size etc.: Doesn't Happen This bug kinda sucks and noticed it right off the bat.

Added subscriber: @AFWS

Added subscriber: @AFWS

Yep, switch to sculpt layout and it happens. It’s not just the brush size ,but any brush settings. Had this happen in past without going to sculpt layout.

Yep, switch to sculpt layout and it happens. It’s not just the brush size ,but any brush settings. Had this happen in past without going to sculpt layout.
Campbell Barton self-assigned this 2019-11-22 14:10:57 +01:00
Member

Added subscriber: @filouROD

Added subscriber: @filouROD

Added subscriber: @ErickNyanduKabongo

Added subscriber: @ErickNyanduKabongo

I m countering this as well, one more thing to note is, this is happening with many settings under " show tool settings" on the top bar, for example brush, texture, stroke, falloff, ... Better workflow would be, undo should not change this settings.

I m countering this as well, one more thing to note is, this is happening with many settings under " show tool settings" on the top bar, for example brush, texture, stroke, falloff, ... Better workflow would be, undo **should not** change this settings.

Added subscribers: @bowserlm, @mano-wii, @Regnas

Added subscribers: @bowserlm, @mano-wii, @Regnas

Closed as duplicate of #72560

Closed as duplicate of #72560

Changed status from 'Duplicate' to: 'Open'

Changed status from 'Duplicate' to: 'Open'

Added subscriber: @Diego_mb

Added subscriber: @Diego_mb

Added subscriber: @gobb_blend

Added subscriber: @gobb_blend

The same has been happening with image texture painting for a long time. Very frustrating.

The same has been happening with image texture painting for a long time. Very frustrating.

Agreed with the above. Was just doing some texture painting and undo'ing the stroke would literally get rid of my texture altogether, forcing me to have to import it again and again.

Agreed with the above. Was just doing some texture painting and undo'ing the stroke would literally get rid of my texture altogether, forcing me to have to import it again and again.
Campbell Barton was unassigned by Dalai Felinto 2019-12-23 13:43:01 +01:00

Added subscribers: @mooncaine, @iss, @rocketman

Added subscribers: @mooncaine, @iss, @rocketman

Can somebody with this problem try loading factory settings and see if that helps?

Can somebody with this problem try loading factory settings and see if that helps?
Member

Added subscribers: @EthicalVegan, @lichtwerk, @PabloDobarro

Added subscribers: @EthicalVegan, @lichtwerk, @PabloDobarro
Member

I can still reproduce the bug in the latest master.
You need to start blender in sculpt mode directly (by using the sculpt template, for example). The bug happens only when undoing the first step after opening the file:
2020-01-10 22-35-33.mp4

I can still reproduce the bug in the latest master. You need to start blender in sculpt mode directly (by using the sculpt template, for example). The bug happens only when undoing the first step after opening the file: [2020-01-10 22-35-33.mp4](https://archive.blender.org/developer/F8269022/2020-01-10_22-35-33.mp4)
Member

Added subscriber: @Frozen_Death_Knight

Added subscriber: @Frozen_Death_Knight

Added subscriber: @Pasang

Added subscriber: @Pasang

@PabloDobarro, The bug is happening all the time in this file. I'm using the latest master.
Frog Topology21.blend

@PabloDobarro, The bug is happening all the time in this file. I'm using the latest master. [Frog Topology21.blend](https://archive.blender.org/developer/F8272075/Frog_Topology21.blend)

Added subscriber: @CobraA

Added subscriber: @CobraA

Undo shouldn’t affect any of these settings whether it’s the brush size,strength or falloff ....., it's still happening in others modes(weight paint, vertex paint, texture paint...etc.
Really annoying when you undo and you're not aware of the changes and then have to reset them.

Undo shouldn’t affect any of these settings whether it’s the brush size,strength or falloff ....., it's still happening in others modes(weight paint, vertex paint, texture paint...etc. Really annoying when you undo and you're not aware of the changes and then have to reset them.
Member

Added subscriber: @JulienKaspar

Added subscriber: @JulienKaspar

@CobraA Agreed. It's for good reason programs like Photoshop do not affect tool settings and only actions taken that would affect the canvas like adding/removing/modifying layers and filters. If you want to reset a tool you add a reset button to it, not have undo deal with it. It just creates massive problems when you need to go back to a previous state of an object and your tools begin resetting for no good reason. Incredibly impractical to say the least.

@CobraA Agreed. It's for good reason programs like Photoshop do not affect tool settings and only actions taken that would affect the canvas like adding/removing/modifying layers and filters. If you want to reset a tool you add a reset button to it, not have undo deal with it. It just creates massive problems when you need to go back to a previous state of an object and your tools begin resetting for no good reason. Incredibly impractical to say the least.

Added subscriber: @ckohl_art

Added subscriber: @ckohl_art
Author

This is really true. It gets old when I undo a lot only for the settings I tampered with to my liking to just be reset when all I wanted to do was undo the stuff I created. Is this something that should be asked to be changed on Right Click Select?

This is really true. It gets old when I undo a lot only for the settings I tampered with to my liking to just be reset when all I wanted to do was undo the stuff I created. Is this something that should be asked to be changed on Right Click Select?

Added subscriber: @JohnCox-3

Added subscriber: @JohnCox-3

This seems to be fixed since today by this commit:
https://developer.blender.org/rB9e382dd2a3d8569201a3e5c1a8478166c77e9029

if you build the latest master branch or use the buildbot can people test this is true.
Should be included in tomorrow's build.

This seems to be fixed since today by this commit: https://developer.blender.org/rB9e382dd2a3d8569201a3e5c1a8478166c77e9029 if you build the latest master branch or use the buildbot can people test this is true. Should be included in tomorrow's build.

I just built Blender and I'm not able to reproduce this bug in sculpt mode anymore. Texture paint mode appears to be fixed as well.
However, in vertex paint mode and weight paint mode, any changes made to the tool settings still get reverted when pressing Ctrl+Z.

Would be nice if there was one clean solution that fixes it for all modes.

I just built Blender and I'm not able to reproduce this bug in sculpt mode anymore. Texture paint mode appears to be fixed as well. However, in vertex paint mode and weight paint mode, any changes made to the tool settings still get reverted when pressing Ctrl+Z. Would be nice if there was one clean solution that fixes it for all modes.
Member

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Philipp Oeser self-assigned this 2020-03-19 20:08:30 +01:00
Member

OKi, I assume this can be closed as resolved then (can also confirm this seems fixed).

However, in vertex paint mode and weight paint mode, any changes made to the tool settings still get reverted when pressing Ctrl+Z.

This should be tracked in a separate report (might already be covered by #69760 (Undo/Adjust Last Operation: vertex and weightpaint operators/strokes undo more then they should (change back any setting changed prior to execution)) in a way?)

Will close as resolved (everyone feel free to comment again if issues persist)

OKi, I assume this can be closed as resolved then (can also confirm this seems fixed). > However, in vertex paint mode and weight paint mode, any changes made to the tool settings still get reverted when pressing Ctrl+Z. This should be tracked in a separate report (might already be covered by #69760 (Undo/Adjust Last Operation: vertex and weightpaint operators/strokes undo more then they should (change back any setting changed prior to execution)) in a way?) Will close as resolved (everyone feel free to comment again if issues persist)

@lichtwerk This doesn't seem fixed.
Same steps:
Launch blender
Go to File->New->Sculpting
Increase the brush radius
Perform a stroke
Now undo
The brush stroke and the brush radius are undone at the same time

Also tested with the new experimental 'Undo Speedup', same issue...
blender-2.83-42012493a8e1-windows64

@lichtwerk This doesn't seem fixed. Same steps: Launch blender Go to File->New->Sculpting Increase the brush radius Perform a stroke Now undo The brush stroke and the brush radius are undone at the same time Also tested with the new experimental 'Undo Speedup', same issue... blender-2.83-42012493a8e1-windows64

In #71759#894876, @TheRedWaxPolice wrote:
@lichtwerk This doesn't seem fixed.
Same steps:
Launch blender
Go to File->New->Sculpting
Increase the brush radius
Perform a stroke
Now undo
The brush stroke and the brush radius are undone at the same time

This is true only after the very first stroke.
Try this:
Increase brush radius
Perform a stroke
Perform a second stroke
Undo
The brush radius stays the same for me

> In #71759#894876, @TheRedWaxPolice wrote: > @lichtwerk This doesn't seem fixed. > Same steps: > Launch blender > Go to File->New->Sculpting > Increase the brush radius > Perform a stroke > Now undo > The brush stroke and the brush radius are undone at the same time This is true only after the very first stroke. Try this: Increase brush radius Perform a stroke Perform a second stroke Undo The brush radius stays the same for me

In #71759#894877, @JohnCox-3 wrote:
This is true only after the very first stroke.

That is exactly the bug we are dealing with here...

> In #71759#894877, @JohnCox-3 wrote: > This is true only after the very first stroke. That is exactly the bug we are dealing with here...
Member

Changed status from 'Resolved' to: 'Confirmed'

Changed status from 'Resolved' to: 'Confirmed'
Philipp Oeser removed their assignment 2020-03-20 07:23:26 +01:00

In #71759#894879, @TheRedWaxPolice wrote:

In #71759#894877, @JohnCox-3 wrote:
This is true only after the very first stroke.

That is exactly the bug we are dealing with here...

OK, I see @PabloDobarro comment about the first stroke now; but the description doesn't say that -- who can update to make that clear?

> In #71759#894879, @TheRedWaxPolice wrote: >> In #71759#894877, @JohnCox-3 wrote: >> This is true only after the very first stroke. > > That is exactly the bug we are dealing with here... OK, I see @PabloDobarro comment about the first stroke now; but the description doesn't say that -- who can update to make that clear?
Member

Added subscribers: @Vyach, @ankitm

Added subscribers: @Vyach, @ankitm

This comment was removed by @Vyach

*This comment was removed by @Vyach*

Removed subscriber: @EthicalVegan

Removed subscriber: @EthicalVegan

Added subscribers: @Stan_Pancakes, @pwcb, @Leul, @DanielGrauer, @WilliamReynish

Added subscribers: @Stan_Pancakes, @pwcb, @Leul, @DanielGrauer, @WilliamReynish

Added subscriber: @brothermechanic

Added subscriber: @brothermechanic
Campbell Barton changed title from 2.81 Sculpt Brush Size Gets Undone After Undoing a Stroke to 2.81 Sculpt/Vertex/Weight Paint Brush Size Gets Undone After Undoing a Stroke 2020-05-26 09:35:27 +02:00

Added subscriber: @TingJoyBits

Added subscriber: @TingJoyBits

Added subscriber: @DarkKnight

Added subscriber: @DarkKnight

Added subscriber: @Wladimus

Added subscriber: @Wladimus

Just to confirm that problem is still present in 2.83.

Just to confirm that problem is still present in 2.83.

Added subscriber: @info-27

Added subscriber: @info-27
Seth Quick changed title from 2.81 Sculpt/Vertex/Weight Paint Brush Size Gets Undone After Undoing a Stroke to Sculpt/Vertex/Weight Paint Brush Size Gets Undone After Undoing a Stroke 2020-06-13 23:41:11 +02:00

poke. Any news? This problem really pushes away users to make sculpt in Blender. First try and first strokes, and you get annoying bug.

poke. Any news? This problem really pushes away users to make sculpt in Blender. First try and first strokes, and you get annoying bug.

Added subscriber: @riceart

Added subscriber: @riceart

Bug still exists in 2.90. First stroke after brush reset in sculpt mode (not a big deal). Vertex paint and weight paint unfortunately bugged.

Bug still exists in 2.90. First stroke after brush reset in sculpt mode (not a big deal). Vertex paint and weight paint unfortunately bugged.

Added subscriber: @kakachiex2

Added subscriber: @kakachiex2

283.2 > 290 this bug is annoying it reset all tool setting in sculpt mode

283.2 > 290 this bug is annoying it reset all tool setting in sculpt mode

This is impractical it supposed to no modify tools setting...🤕

This is impractical it supposed to no modify tools setting...🤕

Added subscriber: @JCo

Added subscriber: @JCo

Just adding another frustrated voice to this issue. Specifically, in Vertex and Weight Paint this issue is really irritating.

Just adding another frustrated voice to this issue. Specifically, in Vertex and Weight Paint this issue is really irritating.

This behaviour is the same in Grease Pencil too (undo changes the active tool and the tool settings). imo it'd be more appropriate & convenient if changes to tools (selected tool and tool settings) were not recorded in the undo stack, or optionally ignored while undoing/redoing.

related:
https://developer.blender.org/T77719
https://blender.community/c/rightclickselect/PHfbbc/

This behaviour is the same in Grease Pencil too (undo changes the active tool and the tool settings). imo it'd be more appropriate & convenient if changes to tools (selected tool and tool settings) were not recorded in the undo stack, or optionally ignored while undoing/redoing. related: https://developer.blender.org/T77719 https://blender.community/c/rightclickselect/PHfbbc/
Member

Added subscriber: @mont29

Added subscriber: @mont29
Member

@ideasman42 @mont29 Any clue about what can be causing this to start looking into it? Debugging brushes with this brush is quite hard as you need to set all parameters again to the same values every time you test something and undo. Also, this is causing issues in other areas. For some reason, when this happens the PBVH rebuilds, so all topology info caches and persistent layers are lost.

@ideasman42 @mont29 Any clue about what can be causing this to start looking into it? Debugging brushes with this brush is quite hard as you need to set all parameters again to the same values every time you test something and undo. Also, this is causing issues in other areas. For some reason, when this happens the PBVH rebuilds, so all topology info caches and persistent layers are lost.

@PabloDobarro I'd guess this is caused by to initial undo step being a memfile undo step, so reading it is similar to reading the blend file.

However the issue you mention is quite different to the brush size being undone, so it would be good to open a new report for this.

@PabloDobarro I'd guess this is caused by to initial undo step being a memfile undo step, so reading it is similar to reading the blend file. However the issue you mention is quite different to the brush size being undone, so it would be good to open a new report for this.

Not only size will be reset, but diferent parameters. Falloff, texture etc.

Not only size will be reset, but diferent parameters. Falloff, texture etc.

Added subscriber: @Cultmethod

Added subscriber: @Cultmethod

I am new to this, sorry if I'm posting inappropriately. I just wanted to confirm that I am getting this bug as well on 2.83.5 LTS. It's making sculpting extremely frustrating. I set up a custom brush, do a test sculpt on the mesh, undo, and then all the prams I've set up for that new brush revert back to defaults.

Undo behavior is a nightmare right now in sculpting.

I am new to this, sorry if I'm posting inappropriately. I just wanted to confirm that I am getting this bug as well on 2.83.5 LTS. It's making sculpting extremely frustrating. I set up a custom brush, do a test sculpt on the mesh, undo, and then all the prams I've set up for that new brush revert back to defaults. Undo behavior is a nightmare right now in sculpting.
Member

Is this fixed in the latest master and 2.90? I tested this and it seems to be fixed when getting to the "Sculpt Mode" undo step.
The only times I can still reproduce this issue is whit Multires when undoing to a "Multires Apply Base" or "Multires Subdivide" undo step.

Is this fixed in the latest master and 2.90? I tested this and it seems to be fixed when getting to the "Sculpt Mode" undo step. The only times I can still reproduce this issue is whit Multires when undoing to a "Multires Apply Base" or "Multires Subdivide" undo step.

In #71759#1013123, @JulienKaspar wrote:
Is this fixed in the latest master

Still dead....
2020-09-11_04-17-03.gif

> In #71759#1013123, @JulienKaspar wrote: > Is this fixed in the latest master Still dead.... ![2020-09-11_04-17-03.gif](https://archive.blender.org/developer/F8864047/2020-09-11_04-17-03.gif)

Added subscriber: @Thane5

Added subscriber: @Thane5

Added subscriber: @CheesecakeCG

Added subscriber: @CheesecakeCG

Added subscriber: @Ulf3000

Added subscriber: @Ulf3000

still existing in grease pencil draw mode...

still existing in grease pencil draw mode...
Member

@mont29 Do you know if this is something that can be fixed in a reasonable amount of time? Otherwise maybe we should lower the priority or move it to known issues.

@mont29 Do you know if this is something that can be fixed in a reasonable amount of time? Otherwise maybe we should lower the priority or move it to known issues.

I think this should be a known issue indeed, there is not much to be done here (as in, not fixable without serious design work).

Only proper solution I can see that would be relatively easy to implement would be to decide to treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps. But such a change should be validated as a design decision first.

I think this should be a known issue indeed, there is not much to be done here (as in, not fixable without serious design work). Only proper solution I can see that would be relatively easy to implement would be to decide to treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps. But such a change should be validated as a design decision first.

treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps.

would dearly love that change to happen! (battling against unwanted tool changes every day while using grease pencil)

> treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps. would dearly love that change to happen! (battling against unwanted tool changes every day while using grease pencil)

In #71759#1025505, @mont29 wrote:
treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps.

+1

> In #71759#1025505, @mont29 wrote: > treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps. +1

Only proper solution I can see that would be relatively easy to implement would be to decide to treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps. But such a change should be validated as a design decision first.

Yo @mont29 I believe it will be better to seriously consider this option, since unintentionally changing brush settings is so annoying and brush settings should be changed only by the user because a brush is tool like other tool people use, changing the settings is like creating another tool. the butcher will want some knife to cut in certain way and have certain type sharpness. It will be annoying and may be dangerous for him to pick a knife and realize that it is not cutting as he wishes. This undo bug can change so many brush settings without warning the user about the change, this can be a source of many frustrations.

> Only proper solution I can see that would be relatively easy to implement would be to decide to treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps. But such a change should be validated as a design decision first. Yo @mont29 I believe it will be better to seriously consider this option, since unintentionally changing brush settings is so annoying and **brush settings should be changed only by the user** because a brush is tool like other tool people use, changing the settings is like creating another tool. the butcher will want some knife to cut in certain way and have certain type sharpness. It will be annoying and may be dangerous for him to pick a knife and realize that it is not cutting as he wishes. This undo bug can change so many brush settings without warning the user about the change, this can be a source of many frustrations.
Member

@mont29 I think that if is possible to consider brush settings as UI data that would be an acceptable solution. Should I open another task for this so we can discuss this and move this report to know issue?

@mont29 I think that if is possible to consider brush settings as UI data that would be an acceptable solution. Should I open another task for this so we can discuss this and move this report to know issue?
Author

Removed subscriber: @SethTooQuick

Removed subscriber: @SethTooQuick

I am with the others on this. Make it behave similarly to the UI. In all my years of using any art program, being able to affect your brush settings by using undo/redo has never been a thing. If the user wants to change the brush settings they can do it manually, not through some strange unintuitive system where the settings behave like some form of operator like a regular brush stroke.

I am with the others on this. Make it behave similarly to the UI. In all my years of using any art program, being able to affect your brush settings by using undo/redo has never been a thing. If the user wants to change the brush settings they can do it manually, not through some strange unintuitive system where the settings behave like some form of operator like a regular brush stroke.

In #71759#1025506, @info-27 wrote:
would dearly love that change to happen! (battling against unwanted tool changes every day while using grease pencil)

+1
At least there should be temporary solution, because this bug spoils workflow A LOT

> In #71759#1025506, @info-27 wrote: > would dearly love that change to happen! (battling against unwanted tool changes every day while using grease pencil) +1 At least there should be temporary solution, because this bug spoils workflow A LOT

In #71759#1025667, @Frozen_Death_Knight wrote:
I am with the others on this. Make it behave similarly to the UI. In all my years of using any art program, being able to affect your brush settings by using undo/redo has never been a thing. If the user wants to change the brush settings they can do it manually, not through some strange unintuitive system where the settings behave like some form of operator like a regular brush stroke.

+1 here as well. This strikes me as the most obvious and user friendly solution.

> In #71759#1025667, @Frozen_Death_Knight wrote: > I am with the others on this. Make it behave similarly to the UI. In all my years of using any art program, being able to affect your brush settings by using undo/redo has never been a thing. If the user wants to change the brush settings they can do it manually, not through some strange unintuitive system where the settings behave like some form of operator like a regular brush stroke. +1 here as well. This strikes me as the most obvious and user friendly solution.
Contributor

Added subscriber: @Gilberto.R

Added subscriber: @Gilberto.R
Contributor

In #71759#1025505, @mont29 wrote:

Only proper solution I can see that would be relatively easy to implement would be to decide to treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps. But such a change should be validated as a design decision first.

Yes please, this is the most annoying bug. Any solution to this is very welcome by the users. You can know by the number of duplicate reports and reactions that this is still a High Priority.

> In #71759#1025505, @mont29 wrote: > Only proper solution I can see that would be relatively easy to implement would be to decide to treat brush settings as we do with UI data, or the position of the 3D cursor for example, and ignore any of their changes in undo steps. But such a change should be validated as a design decision first. Yes please, this is the most annoying bug. Any solution to this is very welcome by the users. You can know by the number of duplicate reports and reactions that this is still a High Priority.

Added subscriber: @moisessalvador

Added subscriber: @moisessalvador

The problem lies more in these things not generating and undo item in the undo history, and so they are grouped together with the next undoable action like the stroke.

If I change brush size and paint a stroke, I think I still would like for it to be undoable in some cases, BUT after two undos, not one.

The problem lies more in these things not generating and undo item in the undo history, and so they are grouped together with the next undoable action like the stroke. If I change brush size and paint a stroke, I think I still would like for it to be undoable in some cases, BUT after two undos, not one.

In #71759#1026353, @moisessalvador wrote:
I think I still would like for it to be undoable in some cases

Only when you are tweaking brush and testing it.
BUT! If you will test it witn few strokes, you should do Ctrl+Z few times and it is faster to tweak back manually or reset brush to initial.
Some 2D applications have two options: reset to saved state and reset to «factory settings».

So undoing brush setting is not so much useful.
May be including brush in undo-history should be optional: switch it on, tweak your brushes, switch it off and never care, than Undo will spoil your brush.
I don`t feel this option should be on by default.

> In #71759#1026353, @moisessalvador wrote: > I think I still would like for it to be undoable in some cases Only when you are tweaking brush and testing it. BUT! If you will test it witn few strokes, you should do Ctrl+Z few times and it is faster to tweak back manually or reset brush to initial. Some 2D applications have two options: reset to saved state and reset to «factory settings». So undoing brush setting is not so much useful. May be including brush in undo-history should be optional: switch it on, tweak your brushes, switch it off and never care, than Undo will spoil your brush. I don`t feel this option should be on by default.

Added subscriber: @UrielAlc

Added subscriber: @UrielAlc

This comment was removed by @UrielAlc

*This comment was removed by @UrielAlc*

+1 This is the worst bug ever :(

+1 This is the worst bug ever :(

Added subscriber: @MallNinjaMax

Added subscriber: @MallNinjaMax

Confirmed in 2.90.1. I stumbled on an even worse case. I just used the smudge brush in Image Editor Paint, did about 8-10 strokes, and a single undo switched my brush back to Draw. I've had a couple moments where a single undo in image paint undoes everything I recently did in 3D view, but I'm having difficulty recreating it.

Switching back and forth between 3D and 2D texture painting is pretty wack. I never know what's going to happen. It's making it really difficult to work.

Confirmed in 2.90.1. I stumbled on an even worse case. I just used the smudge brush in Image Editor Paint, did about 8-10 strokes, and a single undo switched my brush back to Draw. I've had a couple moments where a single undo in image paint undoes everything I recently did in 3D view, but I'm having difficulty recreating it. Switching back and forth between 3D and 2D texture painting is pretty wack. I never know what's going to happen. It's making it really difficult to work.

Added subscriber: @mousesanya

Added subscriber: @mousesanya

Confirmed in 2.90.1 as well

It's a burning pain in the neck, especially for novices. As a novice in Blender, I do a lot of mistakes and experiments, so I use CTRL+Z (Undo) regularly. So it would be extremely convenient If Undo operation in Blender does not affect tool settings after the first stroke of a brush (for example).

Confirmed in 2.90.1 as well It's a burning pain in the neck, especially for novices. As a novice in Blender, I do a lot of mistakes and experiments, so I use CTRL+Z (Undo) regularly. So it would be extremely convenient If Undo operation in Blender does not affect tool settings after the first stroke of a brush (for example).
Bastien Montagne self-assigned this 2020-10-20 14:42:43 +02:00

Added subscriber: @rajq123

Added subscriber: @rajq123

Added subscriber: @EvandroFerreiradaCosta

Added subscriber: @EvandroFerreiradaCosta

This bug, or unintended behavior, was NOT present in version 2.79. It also worked properly not only in Sculpt but in every other mode such as Vertex Paint and Weight Paint.
Maybe it would be proper to also add to the description that it worked properly in 2.79

This bug, or unintended behavior, was NOT present in version 2.79. It also worked properly not only in Sculpt but in every other mode such as Vertex Paint and Weight Paint. Maybe it would be proper to also add to the description that it worked properly in 2.79

Added subscriber: @TioMegamanX

Added subscriber: @TioMegamanX

This bug persists all across many other tools including texture paint, selections, locking/unlocking (like in vertex groups), in general it doesn't just undo the last step but sometimes several steps related to the tool you are using.

This bug persists all across many other tools including texture paint, selections, locking/unlocking (like in vertex groups), in general it doesn't just undo the last step but sometimes several steps related to the tool you are using.

Removed subscriber: @moisessalvador

Removed subscriber: @moisessalvador

This issue was referenced by 5610ccdc08

This issue was referenced by 5610ccdc080497042a24592432ade575e2fab489

This issue was referenced by bc0a6b0400

This issue was referenced by bc0a6b0400ceeda971384bd88014ea7eb6007ad0

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'

Added subscriber: @PrettyFireNOI7

Added subscriber: @PrettyFireNOI7
Contributor

Added subscriber: @Rawalanche

Added subscriber: @Rawalanche
Contributor

It is so incredibly embarrassing this has not been solved yet, after so many years. This basically makes sculpting in Blender borderline impossible. Undoing any sculpt tool stroke also undoes the last setting which was changed... So it takes just a few random Ctrl-Z presses to completely ruin many minutes of work. Incredible...

It is so incredibly embarrassing this has not been solved yet, after so many years. This basically makes sculpting in Blender borderline impossible. Undoing any sculpt tool stroke also undoes the last setting which was changed... So it takes just a few random Ctrl-Z presses to completely ruin many minutes of work. Incredible...

There is still undo for Dyntopo switch with brush strokes.

upd: fixed

There is still undo for Dyntopo switch with brush strokes. upd: fixed

Added subscriber: @DoomWalker

Added subscriber: @DoomWalker

I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed.

I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed.

In #71759#1104226, @DoomWalker wrote:
I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed.

Yeah sculpting in 2.80+ is overhyped.

> In #71759#1104226, @DoomWalker wrote: > I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed. Yeah sculpting in 2.80+ is overhyped.

In #71759#1104226, @DoomWalker wrote:
I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed.

What would be more helpful is reporting a new bug report because a lot of settings arent changing with an Undo. This is marked as solved because it is supposed to be solved. I am on blender 2.91.2 and the only thing is noticed was that the texture for the brush was reset to standard.

> In #71759#1104226, @DoomWalker wrote: > I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed. What would be more helpful is reporting a new bug report because a lot of settings arent changing with an Undo. This is marked as solved because it is supposed to be solved. I am on blender 2.91.2 and the only thing is noticed was that the texture for the brush was reset to standard.

In #71759#1104230, @riceart wrote:

In #71759#1104226, @DoomWalker wrote:
I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed.

Yeah sculpting in 2.80+ is overhyped.

Its certainly underwhelming. As if it wasn't tedious enough building up your own brush sets with all this appending and fake user nonsense!

> In #71759#1104230, @riceart wrote: >> In #71759#1104226, @DoomWalker wrote: >> I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed. > > Yeah sculpting in 2.80+ is overhyped. Its certainly underwhelming. As if it wasn't tedious enough building up your own brush sets with all this appending and fake user nonsense!

In #71759#1104236, @DarkKnight wrote:

In #71759#1104226, @DoomWalker wrote:
I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed.

What would be more helpful is reporting a new bug report because a lot of settings arent changing with an Undo. This is marked as solved because it is supposed to be solved. I am on blender 2.91.2 and the only thing is noticed was that the texture for the brush was reset to standard.

I'm on the same version, and almost every brush setting reverts with undo.

> In #71759#1104236, @DarkKnight wrote: >> In #71759#1104226, @DoomWalker wrote: >> I've just run into this bug whilst trying to customise some brushes. I can't believe this problem has been persisting for years and hasn't been fixed. I don't think I can carry on using Blender with something this annoying hanging over my head when sculpting. Looks like I'm defecting to Z Brush for sculpting. Very disappointed. > > What would be more helpful is reporting a new bug report because a lot of settings arent changing with an Undo. This is marked as solved because it is supposed to be solved. I am on blender 2.91.2 and the only thing is noticed was that the texture for the brush was reset to standard. I'm on the same version, and almost every brush setting reverts with undo.

Added subscriber: @MattCurtis

Added subscriber: @MattCurtis

Please stop adding random context-less comments in this closed, marked-as-solved report, it is utterly useless.

If you still have issues with undo and brush settings in current master (a.k.a. future 2.93 release currently), create a new report, with full proper required information.

Please stop adding random context-less comments in this closed, marked-as-solved report, it is utterly useless. If you still have issues with undo and brush settings **in current master** (a.k.a. future 2.93 release currently), create a new report, with full proper required information.
Thomas Dinges added this to the 2.92 milestone 2023-02-08 16:16:04 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
44 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#71759
No description provided.