Optix Viewport Denoiser Makes Objects Glow When Using High Exposure Even When There is no Light in the Scene #77552

Open
opened 2020-06-07 03:31:48 +02:00 by Zijun Zhou · 13 comments
Contributor

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce MX130/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 446.14

Blender Version
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-06 14:18, hash: aed11c673e
Worked: (newest version of Blender that worked as expected)

Short description of error
The latest build added the feature to let non-RTX GPUs use the denoiser, so I tested it on my scene right away. However, the objects in the scene start glowing when the denoiser starts working. The scene was lit using the Physical Lights feature that the Photographer 3 addon has provided, which offers units like Lumen and Candela, etc. And since physically correct light values can sometimes be very dim (like a candle = 1 candela), sometimes be very bright (like the Sun at noon 111,000 lux), Photographer offers real life camera's settings for modifying the exposure in the color management in the render settings to adjust the overall brightness. And in my scene, I used a candle, which is very dim. Therefore the exposure has been set very high. It has been fine until the denoiser came.

Exact steps for others to reproduce the error
Based on the default startup

  1. Delete the default point light
  2. Turn the World Background Strength to 0
  3. Turn the Exposure in the Render Settings under Color Management to 10
  4. Change the render engine to Cycles
  5. Turn on render view, you should see nothing but complete darkness
  6. Turn on the Optix Viewport denoiser
  7. Wait for a while and see the default cube glowing

I don't know if this is a bug or not, if it is not, please at least get some work around. Like making the denoiser refresh when the exposure changes or something?

image.png

**System Information** Operating system: Windows-10-10.0.18362-SP0 64 Bits Graphics card: GeForce MX130/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 446.14 **Blender Version** Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-06 14:18, hash: `aed11c673e` Worked: (newest version of Blender that worked as expected) **Short description of error** The latest build added the feature to let non-RTX GPUs use the denoiser, so I tested it on my scene right away. However, the objects in the scene start glowing when the denoiser starts working. The scene was lit using the Physical Lights feature that the Photographer 3 addon has provided, which offers units like Lumen and Candela, etc. And since physically correct light values can sometimes be very dim (like a candle = 1 candela), sometimes be very bright (like the Sun at noon 111,000 lux), Photographer offers real life camera's settings for modifying the exposure in the color management in the render settings to adjust the overall brightness. And in my scene, I used a candle, which is very dim. Therefore the exposure has been set very high. It has been fine until the denoiser came. **Exact steps for others to reproduce the error** Based on the default startup 1. Delete the default point light 2. Turn the World Background Strength to 0 3. Turn the Exposure in the Render Settings under Color Management to 10 4. Change the render engine to Cycles 5. Turn on render view, you should see nothing but complete darkness 6. Turn on the Optix Viewport denoiser 7. Wait for a while and see the default cube glowing I don't know if this is a bug or not, if it is not, please at least get some work around. Like making the denoiser refresh when the exposure changes or something? ![image.png](https://archive.blender.org/developer/F8588268/image.png)
Author
Contributor

Added subscriber: @Eary

Added subscriber: @Eary

Added subscriber: @filibis

Added subscriber: @filibis
Author
Contributor

Just want to stress it here just in case, I encountered the problem when using the addon but the problem is completely reproducible without the addon. I have asked my friend, who doesn't have the addon, to try the steps and he can reproduce the problem just like that. Just saying it here just in case.

Just want to stress it here just in case, I encountered the problem when using the addon but the problem is completely reproducible without the addon. I have asked my friend, who doesn't have the addon, to try the steps and he can reproduce the problem just like that. Just saying it here just in case.
Member

Added subscribers: @pmoursnv, @lichtwerk

Added subscribers: @pmoursnv, @lichtwerk
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

Can confirm.

This might be something the AI is confused with, or an issue with non-RTX cards?
Btw. this can also be observed with a light (on unlit surfaces)
image.png

It is also a bit of an uncommon situation, but will confirm for now.

CC @pmoursnv

Can confirm. This might be something the AI is confused with, or an issue with non-RTX cards? Btw. this can also be observed with a light (on unlit surfaces) ![image.png](https://archive.blender.org/developer/F8636548/image.png) It is also a bit of an uncommon situation, but will confirm for now. CC @pmoursnv
Member

That's just the nature of AI denoising. The HDR denoiser that comes with OptiX was trained for a specific usecase (AI is only ever as good as the data that was used to train it), which is HDR images with color data between 0-10'000 that on average is not close to zero (see also https://raytracing-docs.nvidia.com/optix7/guide/index.html#ai_denoiser#nvidia-ai-denoiser).
In this particular case this contract cannot be abhold, since the scene is very very dark and therefore values are very close to zero (it's only later after tonemapping that the final image gets scaled up using the exposure value). The AI is therefore unable to produce a good output.

This could only be solved by running the denoiser on the LDR image after tonemapping and exposure has been applied already. But that is handled by Blender and not Cycles (which is where the denoiser lives) and so is not possible with the current architecture. I'd put this in the Known Issue category.

That's just the nature of AI denoising. The HDR denoiser that comes with OptiX was trained for a specific usecase (AI is only ever as good as the data that was used to train it), which is HDR images with color data between 0-10'000 that on average is not close to zero (see also https://raytracing-docs.nvidia.com/optix7/guide/index.html#ai_denoiser#nvidia-ai-denoiser). In this particular case this contract cannot be abhold, since the scene is very very dark and therefore values are very close to zero (it's only later after tonemapping that the final image gets scaled up using the exposure value). The AI is therefore unable to produce a good output. This could only be solved by running the denoiser on the LDR image after tonemapping and exposure has been applied already. But that is handled by Blender and not Cycles (which is where the denoiser lives) and so is not possible with the current architecture. I'd put this in the Known Issue category.
Author
Contributor

Alright, I think I would just use open image denoise then.

Alright, I think I would just use open image denoise then.
Author
Contributor

Added subscriber: @chafouin

Added subscriber: @chafouin
Author
Contributor

@pmoursnv I told the author of Photographer @chafouin what you have said, and he said:

Terrible idea, do not do it on LDR. You should be able to just pre-expose the values that you feed into the denoiser.

I think it may be necessay to let you know this, and probably get you guys to talk directly.

@pmoursnv I told the author of Photographer @chafouin what you have said, and he said: > Terrible idea, do not do it on LDR. You should be able to just pre-expose the values that you feed into the denoiser. I think it may be necessay to let you know this, and probably get you guys to talk directly.
Author
Contributor

The option to use Optix Denoise for non-RTX cards is... gone? I can no longer find it!
EDIT: Nevermind, Optix is back in today's 2.90 build.

The option to use Optix Denoise for non-RTX cards is... gone? I can no longer find it! EDIT: Nevermind, Optix is back in today's 2.90 build.

Added subscriber: @brecht

Added subscriber: @brecht

I think the proper solution here would be to use Exposure in the Film panel, and for denoising to take that into account.

Exposure in color management is not intended to be used for this case, compositing or saving .exr files with very low values does not work well either.

I think the proper solution here would be to use Exposure in the Film panel, and for denoising to take that into account. Exposure in color management is not intended to be used for this case, compositing or saving .exr files with very low values does not work well either.
Philipp Oeser removed the
Interest
Render & Cycles
label 2023-02-09 14:02:06 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#77552
No description provided.