Crash when sculpting on geometry and dyntopo enabled #79597

Closed
opened 3 years ago by Bebin · 21 comments
Bebin commented 3 years ago

System Information
Operating system: Linux-5.4.0-42-generic-x86_64-with-debian-bullseye-sid 64 Bits
Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 440.100

Blender Version
Broken: version: 2.91.0 Alpha, branch: master, commit date: 2020-08-06 15:29, hash: 97c56b7628
Worked: version 2.83.4

Short description of error
blender crash when enabling dyntopo on geometry and start sculpting

Exact steps for others to reproduce the error

  1. create a simple cube
  2. switch to sculpt mode
  3. enable dyntopo
  4. start sculpt on the geometry with mirror modifier
    Blender Crashes
**System Information** Operating system: Linux-5.4.0-42-generic-x86_64-with-debian-bullseye-sid 64 Bits Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 440.100 **Blender Version** Broken: version: 2.91.0 Alpha, branch: master, commit date: 2020-08-06 15:29, hash: `97c56b7628` Worked: version 2.83.4 **Short description of error** blender crash when enabling dyntopo on geometry and start sculpting **Exact steps for others to reproduce the error** 1. create a simple cube 2. switch to sculpt mode 3. enable dyntopo 4. start sculpt on the geometry with mirror modifier Blender Crashes
Bebin commented 3 years ago
Poster

Added subscriber: @Bebin

Added subscriber: @Bebin
Owner

#79845 was marked as duplicate of this issue

#79845 was marked as duplicate of this issue
Owner

#79824 was marked as duplicate of this issue

#79824 was marked as duplicate of this issue
Owner

#79774 was marked as duplicate of this issue

#79774 was marked as duplicate of this issue
Owner

#79722 was marked as duplicate of this issue

#79722 was marked as duplicate of this issue
Owner

#79644 was marked as duplicate of this issue

#79644 was marked as duplicate of this issue
Bebin changed title from Crash when enabling dynatopo on geometry with mirror modifier to Crash when sculpting on geometry with mirror modifier and enabling dyntopo 3 years ago
rjg commented 3 years ago
Collaborator

Added subscribers: @PabloDobarro, @rjg

Added subscribers: @PabloDobarro, @rjg
rjg commented 3 years ago
Collaborator

Can confirm. It seems this was caused by 5f51438185 @pablodp606.

_BLI_assert_abort() Line 51	C
BM_vert_at_index(BMesh * bm, const int index) Line 102	C
SCULPT_vertex_co_get(SculptSession * ss, int index) Line 145	C
SCULPT_active_vertex_co_get(SculptSession * ss) Line 250	C
SCULPT_cursor_geometry_info_update(bContext * C, SculptCursorGeometryInfo * out, const float * mouse, bool use_sampled_normal) Line 7011	C
paint_cursor_sculpt_session_update_and_init(PaintCursorContext * pcontext) Line 1362	C
paint_cursor_draw_3D_view_brush_cursor(PaintCursorContext * pcontext) Line 1736	C
paint_draw_cursor(bContext * C, int x, int y, void * UNUSED_unused) Line 1857	C
wm_paintcursor_draw(bContext * C, ScrArea * area, ARegion * region) Line 124	C
wm_draw_window_onscreen(bContext * C, wmWindow * win, int view) Line 780	C
wm_draw_window(bContext * C, wmWindow * win) Line 830	C
wm_draw_update(bContext * C) Line 1030	C
WM_main(bContext * C) Line 482	C
main(int argc, const unsigned char * * UNUSED_argv_c) Line 548	C
Can confirm. It seems this was caused by 5f5143818591 @pablodp606. ``` _BLI_assert_abort() Line 51 C BM_vert_at_index(BMesh * bm, const int index) Line 102 C SCULPT_vertex_co_get(SculptSession * ss, int index) Line 145 C SCULPT_active_vertex_co_get(SculptSession * ss) Line 250 C SCULPT_cursor_geometry_info_update(bContext * C, SculptCursorGeometryInfo * out, const float * mouse, bool use_sampled_normal) Line 7011 C paint_cursor_sculpt_session_update_and_init(PaintCursorContext * pcontext) Line 1362 C paint_cursor_draw_3D_view_brush_cursor(PaintCursorContext * pcontext) Line 1736 C paint_draw_cursor(bContext * C, int x, int y, void * UNUSED_unused) Line 1857 C wm_paintcursor_draw(bContext * C, ScrArea * area, ARegion * region) Line 124 C wm_draw_window_onscreen(bContext * C, wmWindow * win, int view) Line 780 C wm_draw_window(bContext * C, wmWindow * win) Line 830 C wm_draw_update(bContext * C) Line 1030 C WM_main(bContext * C) Line 482 C main(int argc, const unsigned char * * UNUSED_argv_c) Line 548 C ```
rjg commented 3 years ago
Collaborator

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
lichtwerk changed title from Crash when sculpting on geometry with mirror modifier and enabling dyntopo to Crash when sculpting on geometry and dyntopo enabled 3 years ago
Collaborator

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Collaborator

I have changed the report description, because it also crashes without a mirror modifier.

I have changed the report description, because it also crashes without a mirror modifier.
Collaborator

Added subscribers: @toki46-3, @yulia_maliauka

Added subscribers: @toki46-3, @yulia_maliauka
Collaborator

Added subscribers: @YAFU, @mano-wii

Added subscribers: @YAFU, @mano-wii
TomG commented 3 years ago

Added subscriber: @TomG

Added subscriber: @TomG
TomG commented 3 years ago

Still crashes on
2.91.0 Alpha , hash: 6fe609d4c3 , commit date: 2020-08-13 13:24

Still crashes on 2.91.0 Alpha , hash: `6fe609d4c3` , commit date: 2020-08-13 13:24
rjg commented 3 years ago
Collaborator

@TomG The patch D8489 is under review.

@TomG The patch [D8489](https://archive.blender.org/developer/D8489) is under review.
brecht commented 3 years ago
Owner

Added subscriber: @ThomasJohann

Added subscriber: @ThomasJohann
Owner

This issue was referenced by 9c241eae48

This issue was referenced by 9c241eae487f29f6eb3e996fb2d39c82ceeb0b75
Collaborator

Added subscribers: @Sun_Xiao_Fang, @Diogo_Valadares

Added subscribers: @Sun_Xiao_Fang, @Diogo_Valadares
ankitm commented 3 years ago
Collaborator

Added subscriber: @JulienKaspar

Added subscriber: @JulienKaspar
Collaborator

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
PabloDobarro closed this issue 3 years ago
PabloDobarro self-assigned this 3 years ago
ThomasDinges added this to the 2.91 milestone 14 hours ago
Sign in to join this conversation.
No Label
Interest/Performance
legacy module/Animation & Rigging
legacy module/Core
legacy module/Development Management
legacy module/Eevee & Viewport
legacy module/Grease Pencil
legacy module/Modeling
legacy module/Nodes & Physics
legacy module/Pipeline, Assets & IO
legacy module/Platforms, Builds, Tests & Devices
legacy module/Python API
legacy module/Rendering & Cycles
legacy module/Sculpt, Paint & Texture
legacy module/Triaging
legacy module/User Interface
legacy module/VFX & Video
legacy project/1.0.0-beta.2
legacy project/Alembic
legacy project/Animation & Rigging
legacy project/Asset Browser
legacy project/Asset Browser (Archived)
legacy project/Asset Browser Project Overview
legacy project/Audio
legacy project/Automated Testing
legacy project/BF Blender: 2.8
legacy project/BF Blender: After Release
legacy project/BF Blender: Next
legacy project/BF Blender: Regressions
legacy project/BF Blender: Unconfirmed
legacy project/Blender 2.70
legacy project/Blender Asset Bundle
legacy project/Code Quest
legacy project/Collada
legacy project/Compositing
legacy project/Core
legacy project/Cycles
legacy project/Datablocks and Libraries
legacy project/Dependency Graph
legacy project/Development Management
legacy project/Eevee
legacy project/EEVEE & Viewport
legacy project/Freestyle
legacy project/Game Animation
legacy project/Game Audio
legacy project/Game Data Conversion
legacy project/Game Engine
legacy project/Game Logic
legacy project/Game Physics
legacy project/Game Python
legacy project/Game Rendering
legacy project/Game UI
legacy project/Geometry Nodes
legacy project/Good First Issue
legacy project/GPU / Viewport
legacy project/Grease Pencil
legacy project/GSoC
legacy project/Images & Movies
legacy project/Import/Export
legacy project/Infrastructure: Websites
legacy project/LibOverrides - Usability and UX
legacy project/Line Art
legacy project/Masking
legacy project/Milestone 1: Basic, Local Asset Browser
legacy project/Modeling
legacy project/Modifiers
legacy project/Motion Tracking
legacy project/Nodes
legacy project/Nodes & Physics
legacy project/OpenGL Error
legacy project/Overrides
legacy project/Papercut
legacy project/Performance
legacy project/Physics
legacy project/Pipeline, Assets & I/O
legacy project/Platform: FreeBSD
legacy project/Platform: Linux
legacy project/Platform: macOS
legacy project/Platforms, Builds, Tests & Devices
legacy project/Platform: Windows
legacy project/Pose Library Basics
legacy project/Python API
legacy project/Render & Cycles
legacy project/Render Pipeline
legacy project/Retrospective
legacy project/Sculpt, Paint & Texture
legacy project/Text Editor
legacy project/Tracker Curfew
legacy project/Translations
legacy project/Triaging
legacy project/Undo
legacy project/USD
legacy project/User Interface
legacy project/UV Editing
legacy project/VFX & Video
legacy project/Video Sequencer
legacy project/Virtual Reality
legacy project/Wintab High Frequency
Meta/Good First Issue
Meta/Papercut
migration/requires-manual-verification
Module › Animation & Rigging
Module › Core
Module › Development Management
Module › Eevee & Viewport
Module › Grease Pencil
Module › Modeling
Module › Nodes & Physics
Module › Pipeline, Assets & IO
Module › Platforms, Builds Tests & Devices
Module › Platforms, Builds, Tests & Devices
Module › Python API
Module › Render & Cycles
Module › Sculpt, Paint & Texture
Module › Triaging
Module › User Interface
Module › VFX & Video
Priority › High
Priority › Low
Priority › Normal
Priority › Unbreak Now!
Status › Archived
Status › Confirmed
Status › Duplicate
Status › Needs Information from Developers
Status › Needs Information from User
Status › Needs Triage
Status › Resolved
Type › Bug
Type › Design
Type › Known Issue
Type › Patch
Type › Report
Type › To Do
No Milestone
No project
No Assignees
8 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#79597
Loading…
There is no content yet.