Duplicate doesn't preserve active spline #80135

Closed
opened 2020-08-26 14:24:09 +02:00 by tt · 7 comments

System Information
Operating system: Linux-5.4.0-42-generic-x86_64-with-debian-bullseye-sid 64 Bits
Graphics card: GeForce GTX 1070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 440.100

Blender Version
Broken: version: 2.90.0 Beta, branch: master, commit date: 2020-08-25 16:00, hash: 21cb6f09ff
Worked: (newest version of Blender that worked as expected)

Short description of error
When duplicating a bezier or nurbs curve and selecting the origin curve it is not highlighted as selected. or the duplicate is "overshadowing" the origin object. Since every duplicated mesh is highlighted this is not expected behaviour and probably a bug. you can select them alternatingly from the viewport and see the selection in the outliner, but not in the viewport.
I found this in 2.83.5 and tested in 2.9 too.

Exact steps for others to reproduce the error
add bezier curve. duplicate. select origin object.

**System Information** Operating system: Linux-5.4.0-42-generic-x86_64-with-debian-bullseye-sid 64 Bits Graphics card: GeForce GTX 1070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 440.100 **Blender Version** Broken: version: 2.90.0 Beta, branch: master, commit date: 2020-08-25 16:00, hash: `21cb6f09ff` Worked: (newest version of Blender that worked as expected) **Short description of error** When duplicating a bezier or nurbs curve and selecting the origin curve it is not highlighted as selected. or the duplicate is "overshadowing" the origin object. Since every duplicated mesh is highlighted this is not expected behaviour and probably a bug. you can select them alternatingly from the viewport and see the selection in the outliner, but not in the viewport. I found this in 2.83.5 and tested in 2.9 too. **Exact steps for others to reproduce the error** add bezier curve. duplicate. select origin object.

Added subscriber: @ToxicTuba

Added subscriber: @ToxicTuba

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

Added subscriber: @ideasman42

Added subscriber: @ideasman42

Confirmed the duplicate curve is not set active.

Confirmed the duplicate curve is not set active.
Campbell Barton changed title from duplicate of curve selected but not highlighted to Duplicate doesn't preserve active spline 2020-08-27 03:18:18 +02:00

This issue was referenced by 7071daaee3

This issue was referenced by 7071daaee3f65b155466c4da1ba825b0407b2fe4

This issue was referenced by 1725e46cee

This issue was referenced by 1725e46cee167d615db6be1dba64090459ac2321

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Campbell Barton self-assigned this 2020-08-28 06:36:37 +02:00
Thomas Dinges added this to the 2.90 milestone 2023-02-08 16:25:40 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
Eevee & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest/Import
Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest: Wayland
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
Eevee & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#80135
There is no content yet.