Improve usability of Group Colors in animation editors #81744

Closed
opened 2020-10-15 18:23:33 +02:00 by Luciano Muñoz Sessarego · 9 comments

Problem:

Without going into much detail, as it stands in the animation editors for the right contrast to be achieved between the white text and the colours they have to be dim but to be useful in the view port they need to be bright (again for contrast).

Blender's default colors unselected in the viewport:
2020-10-27 10_37_17-Blender.png

Original Group Colors selected in the viewport:
2020-10-27 10_38_12-Blender.png

Brightly colored bones are especially important in the 3D Viewport when they have thin shapes. Dimmer bone colors are hard to see over Blender's dark wireframe and dark background.

It's really hard to tell apart the selected ones from the non selected ones.
If i didn't show you the first picture and you only looked at the second picture you wouldn't have a clue whether any bone is selected or unselected.

The Rigify add-on uses bright bone colors to aid visibility in the 3D Viewport. However, this makes the channel list unreadable, as can be seen in the image below.

For optimal readability in the Channel List the colors would have to be darker, which conflicts with the requirements for the 3D Viewport.

2020-10-27 10_58_27-Blender.png

This method has 1 great side and very important for animation which is making very obvious and clear which bones are selected, unselected and active.

And the downside is that the dope sheet/graph editor gets even more unreadable when you expand the channel's attributes:
2020-10-27 11_00_28-Blender.png

Leaving us in at a point of: bright groups will give us the readability we need in the viewport but mess completely the animation editors and on the default colors improving the readability in the animation editor but making it really hard on the eyes in the viewport.

So currently the existing solution
Here comes:
2020-10-27 11_02_07-Blender.png

An option that has been there for ages and has proven not only useful but for anyone that works with character rigs is the first button they press every time they go to the graph editor posing a new problem: the option is local to the file, so every new shot, every new animation you need to un-tick this box in every animation editor.

So there are a few things here we propose which

First: Move the option to the Animation preferences panel
Pros: you as user chose how do you like it to stay, even if it its on by default you turn it on once and that's it.
Cons: it's still on by default.

Second: Redesign the way the bone group colors are presented in the animation editors
Pros: done well means we could eventually get rid of the option to turn on/off if we come to a solution that is non intrusive a-la outliner, taking full advantage of all the ideas that at this moment seem to be playing against each other.
Cons: longer process to design and implement correctly.

In adition to the presentation of the bone group colors in the animation editors we also can see that creating and editing group colors can be time consuming and way more complex than we want it to be, we'll propose a simplified yet powerful version that will be more clear and faster to setup.

Problem: Without going into much detail, as it stands in the animation editors for the right contrast to be achieved between the white text and the colours they have to be dim but to be useful in the view port they need to be bright (again for contrast). Blender's default colors unselected in the viewport: ![2020-10-27 10_37_17-Blender.png](https://archive.blender.org/developer/F9109804/2020-10-27_10_37_17-Blender.png) Original Group Colors selected in the viewport: ![2020-10-27 10_38_12-Blender.png](https://archive.blender.org/developer/F9109794/2020-10-27_10_38_12-Blender.png) Brightly colored bones are especially important in the 3D Viewport when they have thin shapes. Dimmer bone colors are hard to see over Blender's dark wireframe and dark background. It's really hard to tell apart the selected ones from the non selected ones. If i didn't show you the first picture and you only looked at the second picture you wouldn't have a clue whether any bone is selected or unselected. The Rigify add-on uses bright bone colors to aid visibility in the 3D Viewport. However, this makes the channel list unreadable, as can be seen in the image below. For optimal readability in the Channel List the colors would have to be darker, which conflicts with the requirements for the 3D Viewport. ![2020-10-27 10_58_27-Blender.png](https://archive.blender.org/developer/F9109897/2020-10-27_10_58_27-Blender.png) This method has 1 great side and very important for animation which is making very obvious and clear which bones are selected, unselected and active. And the downside is that the dope sheet/graph editor gets even more unreadable when you expand the channel's attributes: ![2020-10-27 11_00_28-Blender.png](https://archive.blender.org/developer/F9109906/2020-10-27_11_00_28-Blender.png) Leaving us in at a point of: bright groups will give us the readability we need in the viewport but mess completely the animation editors and on the default colors improving the readability in the animation editor but making it really hard on the eyes in the viewport. So currently the existing solution Here comes: ![2020-10-27 11_02_07-Blender.png](https://archive.blender.org/developer/F9109918/2020-10-27_11_02_07-Blender.png) An option that has been there for ages and has proven not only useful but for anyone that works with character rigs is the first button they press every time they go to the graph editor posing a new problem: the option is local to the file, so every new shot, every new animation you need to un-tick this box in every animation editor. So there are a few things here we propose which First: **Move the option to the Animation preferences panel** Pros: you as user chose how do you like it to stay, even if it its on by default you turn it on once and that's it. Cons: it's still on by default. Second: **Redesign the way the bone group colors are presented in the animation editors** Pros: done well means we could eventually get rid of the option to turn on/off if we come to a solution that is non intrusive a-la outliner, taking full advantage of all the ideas that at this moment seem to be playing against each other. Cons: longer process to design and implement correctly. In adition to the presentation of the bone group colors in the animation editors we also can see that creating and editing group colors can be time consuming and way more complex than we want it to be, we'll propose a simplified yet powerful version that will be more clear and faster to setup.
Author
Member

Added subscriber: @LucianoMunoz

Added subscriber: @LucianoMunoz

#81476 was marked as duplicate of this issue

#81476 was marked as duplicate of this issue

#96159 was marked as duplicate of this issue

#96159 was marked as duplicate of this issue

Added subscriber: @ChristiaanMoleman

Added subscriber: @ChristiaanMoleman

Added subscribers: @stibbot, @RedMser, @mano-wii

Added subscribers: @stibbot, @RedMser, @mano-wii

A possible design fix would be to make the text and icons in the channel list follow the bone colour, and let the background stay grey. That lets you keep the bright colours for the 3D viewport and still be able to read them in the channel list.
Here's a mockup.
image.png

A possible design fix would be to make the text and icons in the channel list follow the bone colour, and let the background stay grey. That lets you keep the bright colours for the 3D viewport and still be able to read them in the channel list. Here's a mockup. ![image.png](https://archive.blender.org/developer/F12898741/image.png)

That works for that theme, but I think any possible colour change is going to depend entirely on the surrounding theme. It might be better to just give up on displaying group colours on text in these windows. Perhaps indicate the group colour in an icon or tab separate from the text, alongside it, or just don't show group colours at all here. Their main function is differentiating groups in the workspace, not the Graph Editor, it seems to me.

That works for that theme, but I think any possible colour change is going to depend entirely on the surrounding theme. It might be better to just give up on displaying group colours on text in these windows. Perhaps indicate the group colour in an icon or tab separate from the text, alongside it, or just don't show group colours at all here. Their main function is differentiating groups in the workspace, not the Graph Editor, it seems to me.

Another approach would be a tile of colour to give an indication of the group, without affecting the functional elements' readability, just there is a rgb tile to indicate the xyz channels you could add one to indicate the group.

Another approach would be a tile of colour to give an indication of the group, without affecting the functional elements' readability, just there is a rgb tile to indicate the xyz channels you could add one to indicate the group.
Philipp Oeser removed the
Interest
Animation & Rigging
label 2023-02-09 14:36:10 +01:00

For the record, #112861 fixes part of this issue.
The rest can be handled in #113941.

For the record, #112861 fixes part of this issue. The rest can be handled in #113941.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-10-19 16:39:37 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
6 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#81744
No description provided.