UI bugs in NLA Editor and Action Editor #87681

Closed
opened 2021-04-21 15:18:02 +02:00 by Matthew Hinson · 16 comments
Member

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: Intel(R) UHD Graphics 620 Intel 4.5.0 - Build 26.20.100.7262

Blender Version
Broken: version: 2.93.0 Beta, branch: master, commit date: 2021-04-20 15:45, hash: 3735986e87
Worked: (unknown)

Short description of error
The NLA Editor and Action Editor have a number of small UI bugs related to refreshing and unlinking.

Exact steps for others to reproduce the error

  • Load the default startup scene and switch to the Animation workspace.
  • Load the NLA editor into the top left area and open its sidebar.
  • Switch the Dope Sheet editor to the Action Editor mode.
  • With the default cube selected, click the dot next to "Location X" in the Properties editor to create an action.

Bug 1: the sidebar in the NLA editor stays empty. You have to click the blue "Cube" header or the orange "CubeAction" track to populate it, even though the Cube is already selected.


the following issues have been resolved already:

Bug 2: once the NLA sidebar is populated, the Unlink button is disabled (fixed by 3930b8c69e).
There's seemingly no reason for this, and indeed, the Unlink button in the Action Editor is enabled as expected. (More generally, it appears that the Unlink button for the Edited Action in the NLA sidebar is only enabled when a strip in another track is selected, even though there's seemingly no relation between these.)

  • Click "Push Down" in the Action Editor.

Bug 3: the Properties editor still hilights the "Location X" property in yellow as though there were a keyframe (fixed by 0ae23636e7).
You have to hover the mouse over it to update it and get the correct information. (The editor similarly doesn't update when entering or exiting Tweak mode.)

  • Click the dot next to "Rotation X" in the Properties editor to create a new action (CubeAction.001).
  • In the NLA editor, where the original "CubeAction" strip is still selected, press Tab to enter Tweak mode.
  • In the Action Editor, which now displays CubeAction, click the Unlink button.

the following 3 bugs habe been fixed by fd29a161cc:

Bug 4: despite the selector in the Action Editor saying "CubeAction", clicking its Unlink button unlinks CubeAction.001. Presumably, the Unlink button (or even the entire selector with all its buttons) should be disabled when in Tweak mode, as is the case for the selector in the NLA sidebar.

Bug 5: at this point, the "New" button in the NLA sidebar is visible but disabled. (It's enabled in the Action Editor, as is expected.)

  • Use the NLA sidebar selector to load CubeAction.001 back into the editing track.

Bug 6: the "Push Down" button in the NLA editing track becomes visible but is disabled. (It's enabled in the Action Editor, as is expected.)

**System Information** Operating system: Windows-10-10.0.18362-SP0 64 Bits Graphics card: Intel(R) UHD Graphics 620 Intel 4.5.0 - Build 26.20.100.7262 **Blender Version** Broken: version: 2.93.0 Beta, branch: master, commit date: 2021-04-20 15:45, hash: `3735986e87` Worked: (unknown) **Short description of error** The NLA Editor and Action Editor have a number of small UI bugs related to refreshing and unlinking. **Exact steps for others to reproduce the error** * Load the default startup scene and switch to the Animation workspace. * Load the NLA editor into the top left area and open its sidebar. * Switch the Dope Sheet editor to the Action Editor mode. * With the default cube selected, click the dot next to "Location X" in the Properties editor to create an action. Bug 1: the sidebar in the NLA editor stays empty. You have to click the blue "Cube" header or the orange "CubeAction" track to populate it, even though the Cube is already selected. --- the following issues have been resolved already: Bug 2: once the NLA sidebar is populated, the Unlink button is disabled (fixed by 3930b8c69e). There's seemingly no reason for this, and indeed, the Unlink button in the Action Editor is enabled as expected. (More generally, it appears that the Unlink button for the Edited Action in the NLA sidebar is only enabled when a strip in another track is selected, even though there's seemingly no relation between these.) * Click "Push Down" in the Action Editor. Bug 3: the Properties editor still hilights the "Location X" property in yellow as though there were a keyframe (fixed by 0ae23636e7). You have to hover the mouse over it to update it and get the correct information. (The editor similarly doesn't update when entering or exiting Tweak mode.) * Click the dot next to "Rotation X" in the Properties editor to create a new action (CubeAction.001). * In the NLA editor, where the original "CubeAction" strip is still selected, press Tab to enter Tweak mode. * In the Action Editor, which now displays CubeAction, click the Unlink button. the following 3 bugs habe been fixed by fd29a161cc: Bug 4: despite the selector in the Action Editor saying "CubeAction", clicking its Unlink button unlinks CubeAction.001. Presumably, the Unlink button (or even the entire selector with all its buttons) should be disabled when in Tweak mode, as is the case for the selector in the NLA sidebar. Bug 5: at this point, the "New" button in the NLA sidebar is visible but disabled. (It's enabled in the Action Editor, as is expected.) * Use the NLA sidebar selector to load CubeAction.001 back into the editing track. Bug 6: the "Push Down" button in the NLA editing track becomes visible but is disabled. (It's enabled in the Action Editor, as is expected.)
Author
Member

Added subscriber: @Matthew-Hinson

Added subscriber: @Matthew-Hinson
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Philipp Oeser self-assigned this 2021-04-21 15:54:42 +02:00
Member

We might have to split this in multiple reports, but I can confirm pretty much all of this, will check.

We might have to split this in multiple reports, but I can confirm pretty much all of this, will check.

This issue was referenced by 0ae23636e7

This issue was referenced by 0ae23636e7e337b70ade5b172af291ac46a517ff

This issue was referenced by c2ba9be098

This issue was referenced by c2ba9be09810026ad7f0fe79857ee65c878e49b3

This issue was referenced by 3930b8c69e

This issue was referenced by 3930b8c69e274df4aab91f7469510c8636a96cbf

This issue was referenced by fd29a161cc

This issue was referenced by fd29a161cc892730859f6b28a026460f9dd4a1c5
Member

in regards to Bug 1:

  • nla_animdata_panel_poll will call nla_panel_context and at this point the (only?) bAnimListElem from ANIM_animdata_filter is of type ANIMTYPE_NLAACTION.
  • that type is not covered so poll will never be true
  • investigating ANIMTYPE_NLAACTION atm. to see if just permitting it along the other types in nla_panel_context with be OK (seems to work - but want to be sure)
  • also would still need to explain the difference between this (ANIMTYPE_NLAACTION) and what happens after clicking header/track (then we also get ANIMTYPE_OBJECT afaict)
in regards to Bug 1: - `nla_animdata_panel_poll` will call `nla_panel_context` and at this point the (only?) bAnimListElem from `ANIM_animdata_filter` is of type `ANIMTYPE_NLAACTION`. - that type is not covered so poll will never be true - investigating `ANIMTYPE_NLAACTION` atm. to see if just permitting it along the other types in `nla_panel_context` with be OK (seems to work - but want to be sure) - also would still need to explain the difference between this (ANIMTYPE_NLAACTION) and what happens after clicking header/track (then we also get `ANIMTYPE_OBJECT` afaict)

Added subscriber: @dr.sybren

Added subscriber: @dr.sybren

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'

Bug 1: the sidebar in the NLA editor stays empty. You have to click the blue "Cube" header or the orange "CubeAction" track to populate it, even though the Cube is already selected.

This I cannot reproduce in the 3.0 release branch (68e86c4816), so I'll assume this has been fixed too.

> Bug 1: the sidebar in the NLA editor stays empty. You have to click the blue "Cube" header or the orange "CubeAction" track to populate it, even though the Cube is already selected. This I cannot reproduce in the 3.0 release branch (68e86c4816), so I'll assume this has been fixed too.
Member

Changed status from 'Resolved' to: 'Confirmed'

Changed status from 'Resolved' to: 'Confirmed'
Member

In #87681#1248953, @dr.sybren wrote:

Bug 1: the sidebar in the NLA editor stays empty. You have to click the blue "Cube" header or the orange "CubeAction" track to populate it, even though the Cube is already selected.

This I cannot reproduce in the 3.0 release branch (68e86c4816), so I'll assume this has been fixed too.

This still true, will reopen

> In #87681#1248953, @dr.sybren wrote: >> Bug 1: the sidebar in the NLA editor stays empty. You have to click the blue "Cube" header or the orange "CubeAction" track to populate it, even though the Cube is already selected. > > This I cannot reproduce in the 3.0 release branch (68e86c4816), so I'll assume this has been fixed too. This still true, will reopen
Member

Actually will merge this into #97372 (NLA Sidebar tab doesn’t refresh on keyframe creation and there is no UI change to indicate action selection in the track list) since that one is just isolated to the only remaining issue here

Actually will merge this into #97372 (NLA Sidebar tab doesn’t refresh on keyframe creation and there is no UI change to indicate action selection in the track list) since that one is just isolated to the only remaining issue here
Member

Closed as duplicate of #97372

Closed as duplicate of #97372
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#87681
No description provided.