Grease Pencil layer transformations ignored by select tool #90690

Closed
opened 2021-08-15 19:18:03 +02:00 by Wilbur Jaywright · 15 comments

System Information
Operating system: Windows 10 Home 64 bit
Graphics card: NVidia RTX 2060 SUPER

Blender Version
Broken: 2.93.2

Short description of error
Having transformed a grease pencil layer (GP object selected: Properties editor, Object Data properties, Transform panel), then entered edit mode on that layer, attempting to use any of the standard selection tools reveals that they are ignoring the layer transformation: if the layer was moved to the far right, selecting a stroke where it appears to be does nothing, but selecting where it was when the layer was at zero transformation causes it to be selected even if there is nothing where the user is actually selecting.

Exact steps for others to reproduce the error

  • Open a default file.
  • Delete the default cube.
  • Add a grease pencil Stroke primitive.
  • Go to the Object Date properties tab, and make sure the Lines layer is selected.
  • In said tab, go to the Transform panel, and move the layer 1.5 m to the right (positive X axis).
  • Use circle select (by default the C key) to attempt to select the stroke. Then attempt selecting where the stroke used to be before transforming it.

Pre-sorted file for demonstration. Happy bug hunting. God bless the Blender development team!

GP_error.blend

**System Information** Operating system: Windows 10 Home 64 bit Graphics card: NVidia RTX 2060 SUPER **Blender Version** Broken: 2.93.2 **Short description of error** Having transformed a grease pencil layer (GP object selected: Properties editor, Object Data properties, Transform panel), then entered edit mode on that layer, attempting to use any of the standard selection tools reveals that they are ignoring the layer transformation: if the layer was moved to the far right, selecting a stroke where it appears to be does nothing, but selecting where it was when the layer was at zero transformation causes it to be selected even if there is nothing where the user is actually selecting. **Exact steps for others to reproduce the error** - Open a default file. - Delete the default cube. - Add a grease pencil Stroke primitive. - Go to the Object Date properties tab, and make sure the Lines layer is selected. - In said tab, go to the Transform panel, and move the layer 1.5 m to the right (positive X axis). - Use circle select (by default the C key) to attempt to select the stroke. Then attempt selecting where the stroke used to be before transforming it. Pre-sorted file for demonstration. Happy bug hunting. God bless the Blender development team! [GP_error.blend](https://archive.blender.org/developer/F10282592/GP_error.blend)

Added subscriber: @zargul

Added subscriber: @zargul

Added subscriber: @antoniov

Added subscriber: @antoniov

Changed status from 'Needs Triage' to: 'Needs User Info'

Changed status from 'Needs Triage' to: 'Needs User Info'

This bug was solved in 3.0. Could you test last build to verify the bug has gone?

This bug was solved in 3.0. Could you test last build to verify the bug has gone?

I am downloading 3.0.0 Alpha now. Should I try it in 2.93.3 if it is gone in 3?

I am downloading 3.0.0 Alpha now. Should I try it in 2.93.3 if it is gone in 3?

No, just test 3.0 is solved.

No, just test 3.0 is solved.
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123

Changed status from 'Needs User Info' to: 'Resolved'

Changed status from 'Needs User Info' to: 'Resolved'
Wilbur Jaywright self-assigned this 2021-08-15 20:52:37 +02:00

Bug has been fixed in 3.0.0 alpha.

Bug has been fixed in 3.0.0 alpha.
Member

@zargul , can you reproduce with present blender-v2.93-release branch build: https://builder.blender.org/download/daily/ ?

I guess the commit can be backported to 2.93 if it does not contain major changes.

@zargul , can you reproduce with present `blender-v2.93-release` branch build: https://builder.blender.org/download/daily/ ? I guess the commit can be backported to 2.93 if it does not contain major changes.
Member

Changed status from 'Resolved' to: 'Needs Triage'

Changed status from 'Resolved' to: 'Needs Triage'
Member

Reopening the report because I can reproduce on recent blender-v2.93-release branch build.

Will find the good commit.

Reopening the report because I can reproduce on recent `blender-v2.93-release` branch build. Will find the good commit.
Member

Following Commit fixes the issue on master: ce64cfd6ed

Will add it to #88449: Blender LTS: Maintenance Task 2.93

Following Commit fixes the issue on master: ce64cfd6ed Will add it to `#88449: Blender LTS: Maintenance Task 2.93`
Member

Changed status from 'Needs Triage' to: 'Resolved'

Changed status from 'Needs Triage' to: 'Resolved'
Wilbur Jaywright was unassigned by Pratik Borhade 2021-08-17 09:43:53 +02:00
Antonio Vazquez was assigned by Pratik Borhade 2021-08-17 09:43:53 +02:00
Member

Will close the report. I added the commit in Blender LTS: Maintenance Task 2.93

Soon this will be again in working state with 2.93 daily builds. Thanks for the report!

Will close the report. I added the commit in `Blender LTS: Maintenance Task 2.93` Soon this will be again in working state with 2.93 daily builds. Thanks for the report!
Thomas Dinges added this to the 2.93 LTS milestone 2023-02-07 18:46:13 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#90690
No description provided.