Failure to import this FBX (but Unity handles it well) #91062

Closed
opened 2021-08-31 01:03:55 +02:00 by CJ · 14 comments
First-time contributor

System Information
Operating system: Linux + Windows (tested on both)

Blender Version
Broken: version 2.93 (both Windows and Linux are broken for this bug)

Short description of error
Blender fails to import this FBX, but Unity is able to do so.

Exact steps for others to reproduce the error
Just try to import this FBX here pixcap_task_work.rar

**System Information** Operating system: Linux + Windows (tested on both) **Blender Version** Broken: version 2.93 (both Windows and Linux are broken for this bug) **Short description of error** Blender fails to import this FBX, but Unity is able to do so. **Exact steps for others to reproduce the error** Just try to import this FBX here [pixcap_task_work.rar](https://archive.blender.org/developer/F10354233/pixcap_task_work.rar)
Author
First-time contributor

Added subscriber: @mrlooi

Added subscriber: @mrlooi
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

This is an issue with the babylonjs exporter, see https://forum.babylonjs.com/t/transparency-mode-blender-import-issue/14968

It has also been reported before, see blender/blender-addons#81657 (FBX Import error (enum with -1 value -- e.g. as done by the babylonjs exporter from 3dsmax)), will merge these reports.
Since this has been on other exporters as well, see blender/blender-addons#90627 (Fbx import assertion error(unknown location -1)), will look into a quick patch though.

This is an issue with the babylonjs exporter, see https://forum.babylonjs.com/t/transparency-mode-blender-import-issue/14968 It has also been reported before, see blender/blender-addons#81657 (FBX Import error (enum with -1 value -- e.g. as done by the babylonjs exporter from 3dsmax)), will merge these reports. Since this has been on other exporters as well, see blender/blender-addons#90627 (Fbx import assertion error(unknown location -1)), will look into a quick patch though.
Member

Closed as duplicate of blender/blender-addons#81657

Closed as duplicate of blender/blender-addons#81657
Author
First-time contributor

?? How is it the babylonjs exporter? BJS doesn't have a FBX exporter. I exported this from 3DS Max.
Can we re-open it??

?? How is it the babylonjs exporter? BJS doesn't have a FBX exporter. I exported this from 3DS Max. Can we re-open it??
Author
First-time contributor

where are you getting babylonjs exporter from??

where are you getting babylonjs exporter from??
Member

This FBX has a property called babylonTransparencyMode.
Possible values are: ['Opaque', 'Cutoff', 'Blend']
Value is set to -1.
This is invalid usage, see the link I posted above.

Looks like the exporter is available here https://doc.babylonjs.com/extensions/Exporters/3DSMax

But I have a patch ready which will make this invalid FBX still import gracefully (will put the patch up in a bit):
image.png

This FBX has a property called `babylonTransparencyMode`. Possible values are: ['Opaque', 'Cutoff', 'Blend'] Value is set to -1. This is invalid usage, see the link I posted above. Looks like the exporter is available here https://doc.babylonjs.com/extensions/Exporters/3DSMax But I have a patch ready which will make this invalid FBX still import gracefully (will put the patch up in a bit): ![image.png](https://archive.blender.org/developer/F10356217/image.png)
First-time contributor

This issue was referenced by blender/blender-addons@770d08b71f

This issue was referenced by blender/blender-addons@770d08b71f6bca3f7b3ab36b65469b571f859d60
First-time contributor

This issue was referenced by blender/blender-addons@2fe7db7171

This issue was referenced by blender/blender-addons@2fe7db71710f0f1c53f590b1d75654121e32523b
First-time contributor

This issue was referenced by blender/blender-addons@4e30cfd306

This issue was referenced by blender/blender-addons@4e30cfd30603c3bd8e4f7ecdea77cc65ec213d3a
Author
First-time contributor

Ok thanks! Lookin forward to it : )

Ok thanks! Lookin forward to it : )
Member

If you need it now, you can try D12354

If you need it now, you can try [D12354](https://archive.blender.org/developer/D12354)
Author
First-time contributor

Those asserts can be sneaky
Cheerzz

Those asserts can be sneaky Cheerzz
Member

Changed status from 'Duplicate' to: 'Resolved'

Changed status from 'Duplicate' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#91062
No description provided.