GPencil: Scripting weight_get and Vertex Groups not working at expected with several groups #91511

Closed
opened 2021-09-19 02:40:30 +02:00 by Kluya Storm · 7 comments

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 960M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 391.25

Blender Version
Broken: version: 2.93.1, branch: master, commit date: 2021-06-22 05:57, hash: 1b8d33b18cGreasepencil weight_get and vertex_group.blend

Short description of error

  • weight_get will result in a vertex_group index error (RuntimeError: Error: Groups: index out of range) even when the stroke is weight-painted completely
  • Running weight_set along stroke first, weight-painting manually, and then running weight_get will not throw the error (most of the time).
  • The vertex_group index property of weight_get will result in a (RuntimeError: Error: Groups: index out of range) if a lower vertex_group index property had resulted in an index out of range error.

Exact steps for others to reproduce the error
See attached blend.

I've included 3 examples:
A try and except script to get the vertex weight of 4 strokes which fails on 3 upper vertex group indices.
A script that sets the vertex weight of all points to 0 and after which when you weight paint manually and rerun the first script, you get the vertex weight successfully
A script where you create the vertex_group and set them with a specific value successfully, but when you try to read them back with weight_get, it results with a vertex group index out of range

**System Information** Operating system: Windows-10-10.0.18362-SP0 64 Bits Graphics card: GeForce GTX 960M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 391.25 **Blender Version** Broken: version: 2.93.1, branch: master, commit date: 2021-06-22 05:57, hash: `1b8d33b18c`[Greasepencil weight_get and vertex_group.blend](https://archive.blender.org/developer/F10481110/Greasepencil_weight_get_and_vertex_group.blend) **Short description of error** - weight_get will result in a vertex_group index error (RuntimeError: Error: Groups: index out of range) even when the stroke is weight-painted completely - Running weight_set along stroke first, weight-painting manually, and then running weight_get will not throw the error (most of the time). - The vertex_group index property of weight_get will result in a (RuntimeError: Error: Groups: index out of range) if a lower vertex_group index property had resulted in an index out of range error. **Exact steps for others to reproduce the error** See attached blend. I've included 3 examples: A try and except script to get the vertex weight of 4 strokes which fails on 3 upper vertex group indices. A script that sets the vertex weight of all points to 0 and after which when you weight paint manually and rerun the first script, you get the vertex weight successfully A script where you create the vertex_group and set them with a specific value successfully, but when you try to read them back with weight_get, it results with a vertex group index out of range
Author

Added subscriber: @kluya

Added subscriber: @kluya

Added subscriber: @antoniov

Added subscriber: @antoniov

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Antonio Vazquez self-assigned this 2021-09-20 11:02:57 +02:00

The problem is checking the number of available weights.

The problem is checking the number of available weights.

This issue was referenced by cc31c159a1

This issue was referenced by cc31c159a1501b25df014a9b39b720e4ef8d53b3

This issue was referenced by 1f51672d71

This issue was referenced by 1f51672d7126d8c0a0b962060c01632e6e07dd5f
Antonio Vazquez changed title from Greasepencil Scripting weight_get and Vertex Groups to GPencil: Scripting weight_get and Vertex Groups not working at expected with several groups 2021-09-20 11:10:44 +02:00

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#91511
No description provided.