Cycles: motion blur only applies on Left view #93995

Closed
opened 2021-12-12 18:08:18 +01:00 by Billy Poirotte · 16 comments

System Information
Operating system: Win 10
Graphics card: RTX 2060 NVIDIA

Blender Version
Broken: 3.0, 2.93
Caused by 97f1e4782a

Short description of error
When rendering a stereoscopic animation with the motion blur option activated, motion blur only applies on Left view and not to both views. There is no motion blur on the right view.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Add objects to the scene
Setup a camera animation
Turn on stereoscopy
Turn on motion blur option
Render

Test File:
STEREOSCOPY MOTION BLUR BUG.blend

**System Information** Operating system: Win 10 Graphics card: RTX 2060 NVIDIA **Blender Version** Broken: 3.0, 2.93 Caused by 97f1e4782a **Short description of error** When rendering a stereoscopic animation with the motion blur option activated, motion blur only applies on Left view and not to both views. There is no motion blur on the right view. **Exact steps for others to reproduce the error** Based on the default startup or an attached .blend file (as simple as possible). Add objects to the scene Setup a camera animation Turn on stereoscopy Turn on motion blur option Render Test File: [STEREOSCOPY MOTION BLUR BUG.blend](https://archive.blender.org/developer/F12734634/STEREOSCOPY_MOTION_BLUR_BUG.blend)
Author

Added subscriber: @Bil55

Added subscriber: @Bil55

#95758 was marked as duplicate of this issue

#95758 was marked as duplicate of this issue
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

Hi, thanks for the report. Looks like a regression (Works fine here on 2.92, 2.93.0LTS)

Hi, thanks for the report. Looks like a regression (Works fine here on 2.92, 2.93.0LTS)

Added subscriber: @michael64

Added subscriber: @michael64

Yes, this is a regression. The last version that produced properly motion blurred images for the left and right view was 2.93.1.
The fix for #89884 had the side effect of breaking motion blur for the right image.
Blender 2.93.2 was the first version in which motion blur with stereoscopy stopped working.

Keeping the mentioned fix while not setting has_updates_ to false (intern/cycles/blender/sync.cpp) for motion blur scenes
keeps the Carros.blend example from flickering in the cycles render preview
while enabling the motion blur for the right image of this scene.

  if (scene->need_motion() != Scene::MOTION_BLUR) {
    has_updates_ = false;
  }

Likewise

  if (scene->need_motion() == Scene::MOTION_NONE) {
    has_updates_ = false;
  }

should also work to handle the cases of both tickets but I am unsure
if has_updates_ should be set to false for the MOTION_PASS case.
Could this cause the the cycles render preview to flicker? I don't know.

Yes, this is a regression. The last version that produced properly motion blurred images for the left and right view was 2.93.1. The fix for #89884 had the side effect of breaking motion blur for the right image. Blender 2.93.2 was the first version in which motion blur with stereoscopy stopped working. Keeping the mentioned fix while not setting has_updates_ to false (intern/cycles/blender/sync.cpp) for motion blur scenes keeps the Carros.blend example from flickering in the cycles render preview while enabling the motion blur for the right image of this scene. ``` if (scene->need_motion() != Scene::MOTION_BLUR) { has_updates_ = false; } ``` Likewise ``` if (scene->need_motion() == Scene::MOTION_NONE) { has_updates_ = false; } ``` should also work to handle the cases of both tickets but I am unsure if has_updates_ should be set to false for the MOTION_PASS case. Could this cause the the cycles render preview to flicker? I don't know.
Member

The fix for #89884 had the side effect of breaking motion blur for the right image.

Hi @michael64 , I don't think this has been introduced with the fix of #89884.
Its actually broken between 9dabb342ba - a1556fa05c

(Unsure about the commit which caused this issue)

> The fix for #89884 had the side effect of breaking motion blur for the right image. Hi @michael64 , I don't think this has been introduced with the fix of `#89884`. Its actually broken between 9dabb342ba - a1556fa05c (Unsure about the commit which caused this issue)
Pratik Borhade changed title from Stereoscopy + motion blur to Cycles: motion blur only applies on Left view 2021-12-13 12:10:52 +01:00

I was git bisecting between v2.93.1 and v2.93.2 to find the first commit that introduced the motion blur error into the blender-v2.93-release branch which is fdb811f030.
That code of fdb811f030 seems to be an identical backport of 97f1e4782a which might be what you were looking for on the master branch.

Checking out 97f1e4782a, compiling and running it with this scene results in missing motion blur for the right view. Loading the Carros.blend scene from #89884 and switching to render preview with Cycles works fine.

Now checking out the direct ancestor of 97f1e4782a which is 1c1fa15ce1, compiling and running it
results in the opposite. This ancestor had correct motion blur for the right view but switching
to render preview with Cycles now results in Cycles continously rerendering the first sample.

Is 97f1e4782a what you were looking for? My two fix suggestions are of course still the same for the same code on the master branch.

I was git bisecting between v2.93.1 and v2.93.2 to find the first commit that introduced the motion blur error into the blender-v2.93-release branch which is fdb811f030. That code of fdb811f030 seems to be an identical backport of 97f1e4782a which might be what you were looking for on the master branch. Checking out 97f1e4782a, compiling and running it with this scene results in missing motion blur for the right view. Loading the Carros.blend scene from #89884 and switching to render preview with Cycles works fine. Now checking out the direct ancestor of 97f1e4782a which is 1c1fa15ce1, compiling and running it results in the opposite. This ancestor had correct motion blur for the right view but switching to render preview with Cycles now results in Cycles continously rerendering the first sample. Is 97f1e4782a what you were looking for? My two fix suggestions are of course still the same for the same code on the master branch.
Member

Added subscriber: @Sergey

Added subscriber: @Sergey
Member

Is 97f1e4782a what you were looking for?

Hi Michael. Thanks for bisecting.
cc @Sergey

My two fix suggestions are of course still the same for the same code on the master branch.

Please submit a diff so that developer can review your fix: https://developer.blender.org/differential/diff/create/

(Also see Contributing code wiki to understand the process.)

> Is `97f1e4782a` what you were looking for? Hi Michael. Thanks for bisecting. cc @Sergey > My two fix suggestions are of course still the same for the same code on the master branch. Please submit a diff so that developer can review your fix: https://developer.blender.org/differential/diff/create/ (Also see [Contributing code ](https://wiki.blender.org/wiki/Process/Contributing_Code) wiki to understand the process.)

The proposed diff is D13567.

The proposed diff is [D13567](https://archive.blender.org/developer/D13567).
Michael was assigned by Pratik Borhade 2021-12-14 11:25:58 +01:00

This issue was referenced by 1c04d22ebf

This issue was referenced by 1c04d22ebf803d19bd9174a3a57249513fbe7093

This issue was referenced by b32f5a922f

This issue was referenced by b32f5a922f05989ff129c3d266ebbed14b751e2a

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Member

Added subscribers: @dscherr, @Alaska

Added subscribers: @dscherr, @Alaska
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
6 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#93995
No description provided.