Line Art - intersection lines do not receive weight transfers #94033

Open
opened 2021-12-13 19:21:07 +01:00 by Antoine · 11 comments

System Information
Operating system: Win10
Graphics card: NVIDIA GeForce GTX 1660 Ti with Max-Q Design

Blender Version
Broken: blender-3.1.0-alpha master 03015a9b22 windows amd64 release
Broken: blender-2.93
Worked: None?

Line Art can use vertex weights transferred from meshes to modulate line effects. This works on contours and other type of lines, but not intersections.

Exact steps for others to reproduce the error
1- setup a Line Art scene with two spheres interescting
2- paint random weights in a vertex group
3- use the Vertex Weights Transfer to access the weights through Line Art
4- add a Thickness modifier to the line
5- set the Vertex Group on the Thickness modifier

lineart_intersection_weights.png

intersection_weight_debug.blend

**System Information** Operating system: Win10 Graphics card: NVIDIA GeForce GTX 1660 Ti with Max-Q Design **Blender Version** Broken: blender-3.1.0-alpha master 03015a9b222e windows amd64 release Broken: blender-2.93 Worked: None? Line Art can use vertex weights transferred from meshes to modulate line effects. This works on contours and other type of lines, but not intersections. **Exact steps for others to reproduce the error** 1- setup a Line Art scene with two spheres interescting 2- paint random weights in a vertex group 3- use the Vertex Weights Transfer to access the weights through Line Art 4- add a Thickness modifier to the line 5- set the Vertex Group on the Thickness modifier ![lineart_intersection_weights.png](https://archive.blender.org/developer/F12737802/lineart_intersection_weights.png) [intersection_weight_debug.blend](https://archive.blender.org/developer/F12737804/intersection_weight_debug.blend)
Author

Added subscriber: @AntoineP

Added subscriber: @AntoineP
Member

Added subscribers: @ChengduLittleA, @lichtwerk

Added subscribers: @ChengduLittleA, @lichtwerk
Member

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'
Member

Can confirm the behavior.
However this might not be a bug (it is also not clear to me which of the underlying vertexgroups it should use in the case of intersections? after all there are at least two to consider then)

So it looks a bit like a feature request, will let @ChengduLittleA decide

Can confirm the behavior. However this might not be a bug (it is also not clear to me which of the underlying vertexgroups it should use in the case of intersections? after all there are at least two to consider then) So it looks a bit like a feature request, will let @ChengduLittleA decide
YimingWu self-assigned this 2022-01-14 13:57:55 +01:00
Member

Hi there. Thanks for reporting.

Indeed this has not been implemented yet, but this function could be added relatively easily. I'll add this into my todo.

There's some ambiguity in this though, like if there's a point on one triangle, you could interpolate the weight pretty easily, but there's an intersection, it's coming from two points from two triangles, how would you like the weight to behave? I can do like maybe just an average, or min/max/multiply... This needs specific use case to determine. Maybe averaging can be enough? Would like to hear your thoughts @AntoineP :D

Hi there. Thanks for reporting. Indeed this has not been implemented yet, but this function could be added relatively easily. I'll add this into my todo. There's some ambiguity in this though, like if there's a point on one triangle, you could interpolate the weight pretty easily, but there's an intersection, it's coming from two points from two triangles, how would you like the weight to behave? I can do like maybe just an average, or min/max/multiply... This needs specific use case to determine. Maybe averaging can be enough? Would like to hear your thoughts @AntoineP :D
Member

Changed status from 'Needs Developer To Reproduce' to: 'Confirmed'

Changed status from 'Needs Developer To Reproduce' to: 'Confirmed'
Author

Hello! Thanks for taking some time to think about this.

I'm using the vertex weights to apply a noise to the line in a way that is temporally stable. The noise was generated from a world-space texture, so for this specific case the blending method is not important: both objects will have the same weights if they are aligned in world space, such as in intersecting areas.
For general cases, averaging seems to be the obvious first choice, but it's not always suitable. For example: If I'm trying to hide some lines using a painted B&W mask linked to the opacity line modifier, the averaged mask may end up gray and half-transparent. In that case, I would prefer a solution with no blending at all, such as always favouring one of the objects. But that would require the objects to be sorted, I'm not sure if that is possible?

Would it be too confusing to expose the blending mode to the user?
In any case, the current behaviour of dropping all the data is the hardest to deal with artistically, I'd be happy with any blend mode!

Hello! Thanks for taking some time to think about this. I'm using the vertex weights to apply a noise to the line in a way that is temporally stable. The noise was generated from a world-space texture, so for this specific case the blending method is not important: both objects will have the same weights if they are aligned in world space, such as in intersecting areas. For general cases, averaging seems to be the obvious first choice, but it's not always suitable. For example: If I'm trying to hide some lines using a painted B&W mask linked to the opacity line modifier, the averaged mask may end up gray and half-transparent. In that case, I would prefer a solution with no blending at all, such as always favouring one of the objects. But that would require the objects to be sorted, I'm not sure if that is possible? Would it be too confusing to expose the blending mode to the user? In any case, the current behaviour of dropping all the data is the hardest to deal with artistically, I'd be happy with any blend mode!
Member

Hi!

For the use case you described... it's quite easy to have a "min/max/multiply/average/add" mode because these are order-irrelevant. I actually couldn't really think there would potentially be more use cases out of these modes. Maybe it's good enough this way. The weight can be interpolated from the triangles they are on.

I'll add to my notes. Thanks!

Hi! For the use case you described... it's quite easy to have a "min/max/multiply/average/add" mode because these are order-irrelevant. I actually couldn't really think there _would_ potentially be more use cases out of these modes. Maybe it's good enough this way. The weight can be interpolated from the triangles they are on. I'll add to my notes. Thanks!
Author

I would be very happy with the blend modes you mentioned and I agree it would be good enough. However, if you are thinking about use cases, my initial problem would be best solved without blending. The noise that generates the thickness differences is tuned to create a specific look, and any of the blend modes mentionned would have a pretty visible effect on it. In my opinion the perfect solution for this use case is to keep the weight from only one of the objects, a bit similar to how freestyle has a priority system for overlapping segments.

I would be very happy with the blend modes you mentioned and I agree it would be good enough. However, if you are thinking about use cases, my initial problem would be best solved without blending. The noise that generates the thickness differences is tuned to create a specific look, and any of the blend modes mentionned would have a pretty visible effect on it. In my opinion the perfect solution for this use case is to keep the weight from only one of the objects, a bit similar to how freestyle has a priority system for overlapping segments.
Member

@AntoineP Hi! In the latest development of line art, it's technically possible to assign weight from one of the two objects, it may require more research as line art itself doesn't store weight info during the calculation at the moment,. But we are getting closer :)

@AntoineP Hi! In the latest development of line art, it's technically possible to assign weight from one of the two objects, it may require more research as line art itself doesn't store weight info during the calculation at the moment,. But we are getting closer :)
Author

Gotcha! Thank you for taking the time to reply and for all the amazing work!

Gotcha! Thank you for taking the time to reply and for all the amazing work!
Sergey Sharybin added
Module
Grease Pencil
and removed
Module
VFX & Video
labels 2023-02-13 18:10:16 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#94033
No description provided.