Merge arrays leaving edge marks (exposed by GP Lineart) #96846

Closed
opened 2022-03-29 09:24:20 +02:00 by Aleš Jelovčan · 9 comments

System Information
Operating system: Windows-10-10.0.22000-SP0 64 Bits
Graphics card: NVIDIA GeForce MX330/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 472.91

Blender Version
Broken: version: 3.2.0 Alpha, branch: master (modified), commit date: 2022-03-28 17:21, hash: 21e72496a6
Worked: probably never

Short description of error
Certain walls do not get merged properly (see image)
image.png

Exact steps for others to reproduce the error
Please find the file attached:

1.) add default cube
2.) add array modifier, use merge
3.) add Lineart

merger.blend

**System Information** Operating system: Windows-10-10.0.22000-SP0 64 Bits Graphics card: NVIDIA GeForce MX330/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 472.91 **Blender Version** Broken: version: 3.2.0 Alpha, branch: master (modified), commit date: 2022-03-28 17:21, hash: `21e72496a6` Worked: probably never **Short description of error** Certain walls do not get merged properly (see image) ![image.png](https://archive.blender.org/developer/F12953510/image.png) **Exact steps for others to reproduce the error** Please find the file attached: 1.) add default cube 2.) add array modifier, use merge 3.) add Lineart [merger.blend](https://archive.blender.org/developer/F12953509/merger.blend)

Added subscriber: @frogstomp-4

Added subscriber: @frogstomp-4
Member

Added subscribers: @ChengduLittleA, @lichtwerk

Added subscribers: @ChengduLittleA, @lichtwerk
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

I think this can be observed even without the modifier (or if you apply the modifier).

Think the way the Edge Crease edges are detected have way for improvement, @ChengduLittleA ?

I think this can be observed even without the modifier (or if you apply the modifier). Think the way the Edge Crease edges are detected have way for improvement, @ChengduLittleA ?

@lichtwerk thanks for testing.

I don't think this is a fault of lineart. As you can see in example, the bottom edges are are gone, which is what I would expect with others too.
Desired result of the merge would be an equevalent of extruding from a plane 3 times in this example.

Take a look at this exploding commieblock:
image.png

Ideally with having X,Y,Z arrays I'd be able to merge and get rid of those lines, but on mesh level this would mean getting rid of planes also.

Testing with just planes, I see edge merge is working correctly (one array has merge on, the other off):

image.png

So I guess this is technically not a bug but more of a feature request?

@lichtwerk thanks for testing. I don't think this is a fault of lineart. As you can see in example, the bottom edges are are gone, which is what I would expect with others too. Desired result of the merge would be an equevalent of extruding from a plane 3 times in this example. Take a look at this exploding commieblock: ![image.png](https://archive.blender.org/developer/F12954026/image.png) Ideally with having X,Y,Z arrays I'd be able to merge and get rid of those lines, but on mesh level this would mean getting rid of planes also. Testing with just planes, I see edge merge is working correctly (one array has merge on, the other off): ![image.png](https://archive.blender.org/developer/F12954047/image.png) So I guess this is technically not a bug but more of a feature request?
Member

I took some notes... We could potentially have an automatic handling of such cases.

I took some notes... We could potentially have an automatic handling of such cases.
Member

Changed status from 'Confirmed' to: 'Archived'

Changed status from 'Confirmed' to: 'Archived'
Member

Added subscriber: @ZedDB

Added subscriber: @ZedDB
Member

After a discussion with @ZedDB we concluded it's best not to "guess" what the real topology is, a good example would be a shape like this with internal faces:

图片.png

It would be impossible to automatically determine what is the real face that the user want, it's best to keep the input clean.

After a discussion with @ZedDB we concluded it's best not to "guess" what the real topology is, a good example would be a shape like this with internal faces: ![图片.png](https://archive.blender.org/developer/F12959491/图片.png) It would be impossible to automatically determine what is the real face that the user want, it's best to keep the input clean.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#96846
No description provided.