Sculpt Paint: Accumulative Painting/Sculpting #99773

Open
opened 2022-07-16 18:11:23 +02:00 by Julien Kaspar · 3 comments

NOTE: This design is still under discussion and is incomplete.

The recent addition of painting tools in sculpt mode also added an alternative design for accumulative painting.
Because of this there are now two different ways of handling accumulative strength.
This needs to be polished and properly integrated into the UI and painting workflow.

Strength and Accumulate

So far brushes always had an "Accumulate" setting for removing the maximum strength cap. Brushes would then keep adding their effect as long as the stroke continues.
Otherwise they would either accumulate up to a hard-coded upper strength cap (sculpt mode) or up to the set strength (painting modes).

The issues with this implementation are:

  • It is easy to accidentally clip the colors while painting (There is no upper cap with accumulate)
  • The setting is hidden in "Advanced" brush settings even though it is regularly used, and even preferred for painting.

Flow

The new painting brush in sculpt mode instead uses a "Flow" slider, which defines how strong each step of the stroke is.
The stroke will then keep accumulating more slowly towards the set Strength.

There are a few issues with this implementation:

  • The Flow setting is less accessible, even though it can sometimes to be the preferred way of changing the stroke intensity.
  • The relationship between Strength and Flow becomes very confusing, especially when comparing sculpting & painting brushes or when enabling pressure sensitivity settings

Proposal

How to make the settings and behaviours more predictable and accessible needs to be further discussed.

NOTE: This design is still under discussion and is incomplete. The recent addition of painting tools in sculpt mode also added an alternative design for accumulative painting. Because of this there are now two different ways of handling accumulative strength. This needs to be polished and properly integrated into the UI and painting workflow. # Strength and Accumulate So far brushes always had an "Accumulate" setting for removing the maximum strength cap. Brushes would then keep adding their effect as long as the stroke continues. Otherwise they would either accumulate up to a hard-coded upper strength cap (sculpt mode) or up to the set strength (painting modes). The issues with this implementation are: - It is easy to accidentally clip the colors while painting (There is no upper cap with accumulate) - The setting is hidden in "Advanced" brush settings even though it is regularly used, and even preferred for painting. # Flow The new painting brush in sculpt mode instead uses a "Flow" slider, which defines how strong each step of the stroke is. The stroke will then keep accumulating more slowly towards the set Strength. There are a few issues with this implementation: - The Flow setting is less accessible, even though it can sometimes to be the preferred way of changing the stroke intensity. - The relationship between Strength and Flow becomes very confusing, especially when comparing sculpting & painting brushes or when enabling pressure sensitivity settings # Proposal How to make the settings and behaviours more predictable and accessible needs to be further discussed.
Poster
Collaborator

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Poster
Collaborator
Added subscribers: @JulienKaspar, @JosephEagar, @Jeroen-Bakker, @Limarest, @DanielBystedt

I actually added the normal accumulation mode to sculpt-dev. I originally didn't port it to master due to bugs, though I think they've all been fixed now. I think both modes make sense, so we should port it over to master.

I actually added the normal accumulation mode to sculpt-dev. I originally didn't port it to master due to bugs, though I think they've all been fixed now. I think both modes make sense, so we should port it over to master.
Julien Kaspar added this to the Sculpt, Paint & Texture project 2023-02-08 10:20:48 +01:00
Philipp Oeser removed the
Interest
Sculpt, Paint & Texture
label 2023-02-10 09:11:14 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest: Wayland
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#99773
There is no content yet.