Vertex groups created with Geometry Nodes are not processed by subsequent modifiers #100042

Closed
opened 2022-07-28 13:15:32 +02:00 by Stephan Kellermayr · 22 comments

System Information
Operating system: Windows-10-10.0.19044-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 512.15

Blender Version
Broken: version: 3.2.0, branch: master, commit date: 2022-06-08 10:22, hash: e05e1e3691
Worked: (newest version of Blender that worked as expected)

Short description of error
Vertex groups created with Geometry Nodes are not processed by subsequent modifiers

Exact steps for others to reproduce the error
Suppose I have a cube where some vertices are assigned to a vertex group. If I then apply a bevel modifier and select this vertex group, the edges are rounded correctly.

If I then create further geometry with Geometry Nodes before the bevel modifier and also assign some vertices to this vertex group there, these are also rounded correctly.

However, if I do not include the original mesh in the Group Output, but only output the geometry created in Geometry Nodes, the vertex group is no longer processed correctly by the subsequent bevel modifier.

It then looks like this vertex group does not exist at all.

More details can be found here: https://blender.stackexchange.com/a/270569/145249

**System Information** Operating system: Windows-10-10.0.19044-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 512.15 **Blender Version** Broken: version: 3.2.0, branch: master, commit date: 2022-06-08 10:22, hash: `e05e1e3691` Worked: (newest version of Blender that worked as expected) **Short description of error** Vertex groups created with *Geometry Nodes* are not processed by subsequent modifiers **Exact steps for others to reproduce the error** Suppose I have a cube where some vertices are assigned to a vertex group. If I then apply a bevel modifier and select this vertex group, the edges are rounded correctly. If I then create further geometry with *Geometry Nodes* before the bevel modifier and also assign some vertices to this vertex group there, these are also rounded correctly. However, if I do not include the original mesh in the *Group Output*, but only output the geometry created in *Geometry Nodes*, the vertex group is no longer processed correctly by the subsequent bevel modifier. It then looks like this vertex group does not exist at all. More details can be found here: https://blender.stackexchange.com/a/270569/145249

Added subscriber: @Stephan-Kellermayr

Added subscriber: @Stephan-Kellermayr

#101364 was marked as duplicate of this issue

#101364 was marked as duplicate of this issue

#100186 was marked as duplicate of this issue

#100186 was marked as duplicate of this issue

Added subscriber: @TheJeran

Added subscriber: @TheJeran
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123
Member

Changed status from 'Needs Triage' to: 'Needs User Info'

Changed status from 'Needs Triage' to: 'Needs User Info'
Member

Thanks for the report. Could you share your .blend file so that we both will has same reference?

Thanks for the report. Could you share your .blend file so that we both will has same reference?

Here's a good example. Half of the instances here should be beveled, however, all of them are.

beveltest.blend

Here's a good example. Half of the instances here should be beveled, however, all of them are. [beveltest.blend](https://archive.blender.org/developer/F13324067/beveltest.blend)
Member

Changed status from 'Needs User Info' to: 'Needs Developer To Reproduce'

Changed status from 'Needs User Info' to: 'Needs Developer To Reproduce'
Member

Thanks for the file. I think behavior in your file is expected.
vertex groups are part of the mesh data. In you example, vertex groups exists for original cube only and not for the meshes generated from the Cube and Grid node.
With that setup you're not updating the vertex group but basically creating a new boolean attribute.
Also- Creating vertex groups for the default mesh nodes is not possible I guess.
I think we can archive this report but I'll forward this report to developers for the final check

Thanks for the file. I think behavior in your file is expected. vertex groups are part of the mesh data. In you example, vertex groups exists for original cube only and not for the meshes generated from the `Cube` and `Grid` node. With that setup you're not updating the vertex group but basically creating a new boolean attribute. Also- Creating vertex groups for the default mesh nodes is not possible I guess. I think we can archive this report but I'll forward this report to developers for the final check

Here is another example: https://blend-exchange.com/b/e6SbvWop/

The strange thing about this is that apparently this "bug" only comes into play when the mesh is not closed. In the example I show two different approaches. One of them does not work, but the other one does.

Here is another example: https://blend-exchange.com/b/e6SbvWop/ The strange thing about this is that apparently this "bug" only comes into play when the mesh is not closed. In the example I show two different approaches. One of them does not work, but the other one does.

In #100042#1396611, @PratikPB2123 wrote:
Thanks for the file. I think behavior in your file is expected.
vertex groups are part of the mesh data. In you example, vertex groups exists for original cube only and not for the meshes generated from the Cube and Grid node.
With that setup you're not updating the vertex group but basically creating a new boolean attribute.
Also- Creating vertex groups for the default mesh nodes is not possible I guess.
I think we can archive this report but I'll forward this report to developers for the final check

No, I would not see it that way. It works ...sort of or partially and the behavior is misleading. I have tested this extensively, and it does indeed work if the original geometry is hooked in with Join Geometry before the geometry created in GN.

It may well be that the attribute was not there before if the original geometry is not included, and I also realize that a vertex group cannot actually be created in GN. But an existing group can be "added" to.

And the funniest thing is: If I extrude a surface with GN, I can change it afterwards with a Bevel Modifier, although the original geometry was not transferred. All in all there is a bug in there somewhere, because the result is not conclusive.

Please take a look at https://blend-exchange.com/b/e6SbvWop/ and see for yourself.

> In #100042#1396611, @PratikPB2123 wrote: > Thanks for the file. I think behavior in your file is expected. > vertex groups are part of the mesh data. In you example, vertex groups exists for original cube only and not for the meshes generated from the `Cube` and `Grid` node. > With that setup you're not updating the vertex group but basically creating a new boolean attribute. > Also- Creating vertex groups for the default mesh nodes is not possible I guess. > I think we can archive this report but I'll forward this report to developers for the final check No, I would not see it that way. It works ...sort of or partially and the behavior is misleading. I have tested this extensively, and it does indeed work if the original geometry is hooked in with *Join Geometry* before the geometry created in GN. It may well be that the attribute was not there before if the original geometry is not included, and I also realize that a vertex group cannot actually be created in GN. But an existing group can be "added" to. And the funniest thing is: If I extrude a surface with GN, I can change it afterwards with a Bevel Modifier, although the original geometry was not transferred. All in all there is a bug in there somewhere, because the result is not conclusive. Please take a look at https://blend-exchange.com/b/e6SbvWop/ and see for yourself.
Member

Added subscriber: @HooglyBoogly

Added subscriber: @HooglyBoogly
Member

Changed status from 'Needs Developer To Reproduce' to: 'Archived'

Changed status from 'Needs Developer To Reproduce' to: 'Archived'
Member

The result is indeed a bit confusing, but @PratikPB2123's analysis is also correct.
The issue is that the modifiers don't know how to read the generic attributes created by geometry nodes. Nodes that create a new geometry internally will make vertex group into generic attributes.
The way we're planning to fix this is by implementing these modifiers as geometry nodes. There is already work underway for a new bevel implementation as a node.
That's just a regular development task though, so I will archive this report. Thanks though.

The result is indeed a bit confusing, but @PratikPB2123's analysis is also correct. The issue is that the modifiers don't know how to read the generic attributes created by geometry nodes. Nodes that create a new geometry internally will make vertex group into generic attributes. The way we're planning to fix this is by implementing these modifiers as geometry nodes. There is already work underway for a new bevel implementation as a node. That's just a regular development task though, so I will archive this report. Thanks though.

OK, I see, then this is a bug, but it won't be fixed because the causing mechanism will be replaced by another mechanism soon anyway?

OK, I see, then this is a bug, but it won't be fixed because the causing mechanism will be replaced by another mechanism soon anyway?
Member

Getting really technical, the definition of a bug is something we expect to work but doesn't, so technically this isn't a bug, but it does seem like one.
But yeah, that's basically it.

Getting really technical, the definition of a bug is something we expect to work but doesn't, so technically this isn't a bug, but it does seem like one. But yeah, that's basically it.

OK, then let's agree on an "incomplete feature" that causes a lot of confusion ;-)

Thanks anyway, I'm looking forward to the Bevel node!

OK, then let's agree on an "incomplete feature" that causes a lot of confusion ;-) Thanks anyway, I'm looking forward to the Bevel node!
Member

Added subscriber: @SergeL

Added subscriber: @SergeL
Member

Added subscriber: @pseudoua

Added subscriber: @pseudoua

Hi,
I tried the file: https://blend-exchange.com/b/e6SbvWop/
and got this:
image
Blender 4.0.0 Alpha :
image

It seems like it's not working anymore.

Hi, I tried the file: [https://blend-exchange.com/b/e6SbvWop/](https://blend-exchange.com/b/e6SbvWop/) and got this: ![image](/attachments/e147703a-af32-4c7e-a147-73525fc7ca7f) Blender 4.0.0 Alpha : ![image](/attachments/a419824b-dbd0-4ff7-b486-90198145282c) It seems like it's not working anymore.
752 KiB
5.6 KiB

I found a way to do it and even change the Bevel Weight Edge, all you have to do is use the Store Named Attribute node as the last node and with the Selection choose what you want to get the effect when the selection is made earlier.

I found a way to do it and even change the Bevel Weight Edge, all you have to do is use the Store Named Attribute node as the last node and with the Selection choose what you want to get the effect when the selection is made earlier.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
7 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#100042
No description provided.