Texture bake fills black when set clear texture #100708

Closed
opened 2022-08-30 13:59:47 +02:00 by Konstantin Kharkovschenko · 7 comments

System Information
Operating system: Windows-10-10.0.22000-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 512.77

Blender Version
Broken: version: 3.4.0 Alpha, branch: master, commit date: 2022-08-29 23:11, hash: 5ae3fa50e2
Worked: 2.93

Short description of error
After implemented CyclesX texture baking behaves differently. Before if you check "Clear texrure" that have alpha channel Blender bakes the texture with transparent empty spaces. Now it fills it black. If it was intentional it should be an option. Now it breaks pipeline with multilayer textures.

Exact steps for others to reproduce the error
Open blend file and click Bake
texture_bake_bug.blend

**System Information** Operating system: Windows-10-10.0.22000-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 512.77 **Blender Version** Broken: version: 3.4.0 Alpha, branch: master, commit date: 2022-08-29 23:11, hash: `5ae3fa50e2` Worked: 2.93 **Short description of error** After implemented CyclesX texture baking behaves differently. Before if you check "Clear texrure" that have alpha channel Blender bakes the texture with transparent empty spaces. Now it fills it black. If it was intentional it should be an option. Now it breaks pipeline with multilayer textures. **Exact steps for others to reproduce the error** Open blend file and click Bake [texture_bake_bug.blend](https://archive.blender.org/developer/F13434831/texture_bake_bug.blend)

Added subscriber: @Morphin

Added subscriber: @Morphin

Added subscribers: @brecht, @mano-wii

Added subscribers: @brecht, @mano-wii

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

I can confirm the problem.
Strange that this problem seems to be the same as #93711 (Cycles Diffuse baking does not preserve transparency (regression)) which was fixed by {856f7429a5de}.

Cc. @brecht

I can confirm the problem. Strange that this problem seems to be the same as #93711 (Cycles Diffuse baking does not preserve transparency (regression)) which was fixed by {856f7429a5de}. Cc. @brecht

This issue was referenced by 50069fb2a1

This issue was referenced by 50069fb2a11eb79c860be8c1d34817cadeafe04e

This issue was referenced by 3a605b23d0

This issue was referenced by 3a605b23d02263be6bca9046e20b46a60832d971

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Brecht Van Lommel self-assigned this 2022-08-31 20:56:12 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#100708
No description provided.