Deleting the default cube breaks face set initialization with joining objects #101623

Closed
opened 4 months ago by persun · 17 comments

System Information
Operating system: Windows-10-10.0.19043-SP0 64 Bits
Graphics card: Radeon RX 570 Series ATI Technologies Inc. 4.5.14800 Core Profile Context 22.5.1 30.0.15021.11005

Blender Version
Broken: version: 3.3.0, branch: master, commit date: 2022-09-06 15:39, hash: 0759f671ce
Worked: unknown. I can confirm this in 2.93 too.

Also confirmed with latest 3.4 daily b804f925c70c.

Short description of error
Joining objects should initialize face sets per their source objects. Deleting the default cube breaks this feature for the file.

Exact steps for others to reproduce the error

  • From the startup file, delete the default cube
  • Add two or more mesh objects
  • Join them
  • Switch to Sculpt mode with the joined object. No face sets are initilized

TheCurseoftheDefaultCube.mp4

(No, this is not a joke about the default cube!)

**System Information** Operating system: Windows-10-10.0.19043-SP0 64 Bits Graphics card: Radeon RX 570 Series ATI Technologies Inc. 4.5.14800 Core Profile Context 22.5.1 30.0.15021.11005 **Blender Version** Broken: version: 3.3.0, branch: master, commit date: 2022-09-06 15:39, hash: `0759f671ce` Worked: unknown. I can confirm this in 2.93 too. Also confirmed with latest 3.4 daily `b804f925c70c`. **Short description of error** Joining objects should initialize face sets per their source objects. Deleting the default cube breaks this feature for the file. **Exact steps for others to reproduce the error** * From the startup file, delete the default cube * Add two or more mesh objects * Join them * Switch to Sculpt mode with the joined object. No face sets are initilized [TheCurseoftheDefaultCube.mp4](https://archive.blender.org/developer/F13618197/TheCurseoftheDefaultCube.mp4) (No, this is not a joke about the default cube!)
Poster

Added subscriber: @persun

Added subscriber: @persun
Collaborator

Added subscriber: @HooglyBoogly

Added subscriber: @HooglyBoogly
Collaborator

This happens because the default cube in the factory startup file has a face sets layer. The "Initialize by Loose Parts" behavior when joining only happens when one of the meshes has face sets.
Joining mesh objects shouldn't create face sets from scratch when there are no face sets in the first place.

It is a bit confusing though, since there's no way to tell if a mesh has face sets if they all have the default value. To make it more predictable, I'd propose removing the face sets layer from the default startup file.

This happens because the default cube in the factory startup file has a face sets layer. The "Initialize by Loose Parts" behavior when joining only happens when one of the meshes has face sets. Joining mesh objects shouldn't create face sets from scratch when there are no face sets in the first place. It is a bit confusing though, since there's no way to tell if a mesh has face sets if they all have the default value. To make it more predictable, I'd propose removing the face sets layer from the default startup file.
Poster

Ah, that makes sense.

To make it more predictable, I'd propose removing the face sets layer from the default startup file.

Yeah this will also help the cases where beginning users who don't have the concept of face sets confuse the colors as a bug.

Ah, that makes sense. > To make it more predictable, I'd propose removing the face sets layer from the default startup file. Yeah this will also help the cases where beginning users who don't have the concept of face sets confuse the colors as a bug.
Collaborator

Added subscriber: @mano-wii

Added subscriber: @mano-wii
Collaborator

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'
Collaborator

It looks more like a design issue that needs feedback from the #sculpt_paint_texture team.

It looks more like a design issue that needs feedback from the #sculpt_paint_texture team.

Added subscriber: @TheRedWaxPolice

Added subscriber: @TheRedWaxPolice
Collaborator

Added subscriber: @JulienKaspar

Added subscriber: @JulienKaspar
Collaborator

This also applies to newly created geometry in edit mode, which used to be automatically marked as a new face set.

I'll look into the design of this. Personally I like that newly added geometry is always marked as a new face set,
but this behavior often lead to confusion and invalid bug reports for those that don't use or want face sets.

The new behavior has the upside that face sets are an opt-in feature.

This also applies to newly created geometry in edit mode, which used to be automatically marked as a new face set. I'll look into the design of this. Personally I like that newly added geometry is always marked as a new face set, but this behavior often lead to confusion and invalid bug reports for those that don't use or want face sets. The new behavior has the upside that face sets are an opt-in feature.
Collaborator

@HooglyBoogly We discussed this in the recent module meeting. We all agreed that the new behavior after the recent changes is more desirable.
This way the user needs to intentionally create or initialize a face set first, so that face sets are automatically created on join or edit operations.
If they want to create face sets per joined object in hindsight, the Initialize operators can still be used.

Next we should adjust existing code that tries to create face sets when joining objects, to work with this new behavior.

Also, if an object that has face sets is joined into an object that has none, it will result in all face sets being lost. This needs to be fixed.
Any existing face sets must be joined into another object as well.

And yes, the startup files need to be updated.

@HooglyBoogly We discussed this in the recent module meeting. We all agreed that the new behavior after the recent changes is more desirable. This way the user needs to intentionally create or initialize a face set first, so that face sets are automatically created on join or edit operations. If they want to create face sets per joined object in hindsight, the Initialize operators can still be used. Next we should adjust existing code that tries to create face sets when joining objects, to work with this new behavior. Also, if an object that has face sets is joined into an object that has none, it will result in all face sets being lost. This needs to be fixed. Any existing face sets must be joined into another object as well. And yes, the startup files need to be updated.
HooglyBoogly self-assigned this 4 months ago
Collaborator

Changed status from 'Needs Developer To Reproduce' to: 'Confirmed'

Changed status from 'Needs Developer To Reproduce' to: 'Confirmed'
Collaborator

Next we should adjust existing code that tries to create face sets when joining objects, to work with this new behavior.

Could you be more specific about what the join operator should do?

Also, if an object that has face sets is joined into an object that has none, it will result in all face sets being lost.

I wasn't able to reproduce this. Could you give steps to reproduce the issue? Thanks.

>Next we should adjust existing code that tries to create face sets when joining objects, to work with this new behavior. Could you be more specific about what the join operator should do? >Also, if an object that has face sets is joined into an object that has none, it will result in all face sets being lost. I wasn't able to reproduce this. Could you give steps to reproduce the issue? Thanks.
Collaborator

Added subscriber: @JosephEagar

Added subscriber: @JosephEagar
Collaborator

Could you be more specific about what the join operator should do?

@JosephEagar Can you talk with Hans about this since you brought this up at the meeting? You are more familiar with the code.

I wasn't able to reproduce this. Could you give steps to reproduce the issue? Thanks.

You are right, I cannot reproduce this anymore either in the latest master.

> Could you be more specific about what the join operator should do? @JosephEagar Can you talk with Hans about this since you brought this up at the meeting? You are more familiar with the code. > I wasn't able to reproduce this. Could you give steps to reproduce the issue? Thanks. You are right, I cannot reproduce this anymore either in the latest master.
Collaborator

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
HooglyBoogly closed this issue 3 months ago
Collaborator

I'm going to close this since we can't reproduce it and the main issues have been resolved. If it comes up again, we can reopen this report or open a new one.

I'm going to close this since we can't reproduce it and the main issues have been resolved. If it comes up again, we can reopen this report or open a new one.
Sign in to join this conversation.
No Label
good first issue
legacy module/Animation & Rigging
legacy module/Core
legacy module/Development Management
legacy module/Eevee & Viewport
legacy module/Grease Pencil
legacy module/Modeling
legacy module/Nodes & Physics
legacy module/Pipeline, Assets & IO
legacy module/Platforms, Builds, Tests & Devices
legacy module/Python API
legacy module/Rendering & Cycles
legacy module/Sculpt, Paint & Texture
legacy module/Triaging
legacy module/User Interface
legacy module/VFX & Video
legacy project/1.0.0-beta.2
legacy project/2.81
legacy project/2.82
legacy project/2.83
legacy project/2.90
legacy project/2.91
legacy project/2.92
legacy project/3.0
legacy project/3.1
legacy project/3.2
legacy project/3.3
legacy project/Alembic
legacy project/Animation & Rigging
legacy project/Asset Browser
legacy project/Asset Browser (Archived)
legacy project/Asset Browser Project Overview
legacy project/Audio
legacy project/Automated Testing
legacy project/BF Blender: 2.8
legacy project/BF Blender: After Release
legacy project/BF Blender: Next
legacy project/BF Blender: Regressions
legacy project/BF Blender: Unconfirmed
legacy project/Blender 2.70
legacy project/Blender Asset Bundle
legacy project/Code Quest
legacy project/Collada
legacy project/Compositing
legacy project/Core
legacy project/Cycles
legacy project/Datablocks and Libraries
legacy project/Dependency Graph
legacy project/Development Management
legacy project/Eevee
legacy project/EEVEE & Viewport
legacy project/Freestyle
legacy project/Game Animation
legacy project/Game Audio
legacy project/Game Data Conversion
legacy project/Game Engine
legacy project/Game Logic
legacy project/Game Physics
legacy project/Game Python
legacy project/Game Rendering
legacy project/Game UI
legacy project/Geometry Nodes
legacy project/Good First Issue
legacy project/GPU / Viewport
legacy project/Grease Pencil
legacy project/GSoC
legacy project/Images & Movies
legacy project/Import/Export
legacy project/Infrastructure: Websites
legacy project/LibOverrides - Usability and UX
legacy project/Line Art
legacy project/Masking
legacy project/Milestone 1: Basic, Local Asset Browser
legacy project/Modeling
legacy project/Modifiers
legacy project/Motion Tracking
legacy project/Nodes
legacy project/Nodes & Physics
legacy project/OpenGL Error
legacy project/Overrides
legacy project/Papercut
legacy project/Performance
legacy project/Physics
legacy project/Pipeline, Assets & I/O
legacy project/Platform: FreeBSD
legacy project/Platform: Linux
legacy project/Platform: macOS
legacy project/Platforms, Builds, Tests & Devices
legacy project/Platform: Windows
legacy project/Pose Library Basics
legacy project/Python API
legacy project/Render & Cycles
legacy project/Render Pipeline
legacy project/Retrospective
legacy project/Sculpt, Paint & Texture
legacy project/Text Editor
legacy project/Tracker Curfew
legacy project/Translations
legacy project/Triaging
legacy project/Undo
legacy project/USD
legacy project/User Interface
legacy project/UV Editing
legacy project/VFX & Video
legacy project/Video Sequencer
legacy project/Virtual Reality
legacy project/Wintab High Frequency
migration/requires-manual-verification
Module › Animation & Rigging
Module › Core
Module › Development Management
Module › Eevee & Viewport
Module › EEVEE & Viewport
Module › Grease Pencil
Module › Modeling
Module › Nodes & Physics
Module › Pipeline, Assets & IO
Module › Platforms, Builds Tests & Devices
Module › Platforms, Builds, Tests & Devices
Module › Python API
Module › Render & Cycles
Module › Sculpt, Paint & Texture
Module › Triaging
Module › User Interface
Module › VFX & Video
papercut
performance
Priority › High
Priority › Low
Priority › Normal
Priority › Unbreak Now!
Status › Archived
Status › Confirmed
Status › Duplicate
Status › Needs Information from Developers
Status › Needs Information from User
Status › Needs Triage
Status › Resolved
Type › Bug
Type › Design
Type › Known Issue
Type › Patch
Type › Report
Type › To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#101623
Loading…
There is no content yet.