LineArt: (Collection) Issue for Cameras in Orthographic View #101692

Open
opened 2022-10-08 09:03:19 +02:00 by Amit · 7 comments

System Information
Operating system: Windows-10-10.0.19044-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 2080 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 516.94

Blender Version
Broken: version: 3.3.1, branch: master, commit date: 2022-10-04 18:35, hash: b292cfe5a9
Checked in Blender version 3.4.0 Apha, commit date: 2022-10-08 02:26 - same issue

Short description of error
For orthographic Camera without any shifts - Line art modifier (for a Collection) showing lines for objects behind other objects - which otherwise should not be visible. And some lines are not visible which should be.
Happens with contours option in the Line Art modifier. Slight rotation on z axis solves the issue.

Noticed issue with some specific frames on my complete blend file.

Exact steps for others to reproduce the error
Open attached blend file and go to front orthographic view.

BugReport01.blend

**System Information** Operating system: Windows-10-10.0.19044-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 2080 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 516.94 **Blender Version** Broken: version: 3.3.1, branch: master, commit date: 2022-10-04 18:35, hash: `b292cfe5a9` Checked in Blender version 3.4.0 Apha, commit date: 2022-10-08 02:26 - same issue **Short description of error** For orthographic Camera without any shifts - Line art modifier (for a Collection) showing lines for objects behind other objects - which otherwise should not be visible. And some lines are not visible which should be. Happens with contours option in the Line Art modifier. Slight rotation on z axis solves the issue. Noticed issue with some specific frames on my complete blend file. **Exact steps for others to reproduce the error** Open attached blend file and go to front orthographic view. [BugReport01.blend](https://archive.blender.org/developer/F13636399/BugReport01.blend)
YimingWu was assigned by Amit 2022-10-08 09:03:19 +02:00
Author
Added subscribers: @amit1748, @ChengduLittleA, @lichtwerk, @MarcoFerrara, @Mauro_Amoruso
Antonio Vazquez changed title from Grease Pencil Line Art Modifier (Collection) Issue for Cameras in Orthographic View to LineArt: (Collection) Issue for Cameras in Orthographic View 2022-10-10 12:13:01 +02:00
Member

Added subscriber: @OmarEmaraDev

Added subscriber: @OmarEmaraDev
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

Also happens on older versions, so not a recent regression.

untitled.png

Also happens on older versions, so not a recent regression. ![untitled.png](https://archive.blender.org/developer/F13648476/untitled.png)
Member

From the description it doesn't seem to be the old inverted-z bug since a rotation could solve the issue, Must be something I have failed to take care of since the beginning. Let me check.

From the description it doesn't seem to be the old inverted-z bug since a rotation could solve the issue, Must be something I have failed to take care of since the beginning. Let me check.
Member

The only thing I can see is the object being too small. The current problem with stuff being too small is that chaining has a certain "simplification threshold" that turned out to be in absolute size only in ortho camera (thus perspective camera isn't affected). This means if the object is too small those "lines that are supposedly hidden" are connected to the visible ones as "simplification". I tuned the internal threshold manually to be able to get a correct result but looks like This method doesn't work very well in this geometry size either.

I'll think of a way to best handle this kind of situation. For now if you scale the scene up to like a regular cube's size, it should work just fine.

After some more tests: Apparently the armature scale is too small, simply applying the scale also does the trick

The only thing I can see is the object being too small. The current problem with stuff being too small is that chaining has a certain "simplification threshold" that turned out to be in absolute size only in ortho camera (thus perspective camera isn't affected). This means if the object is too small those "lines that are supposedly hidden" are connected to the visible ones as "simplification". I tuned the internal threshold manually to be able to get a correct result but looks like This method doesn't work very well in this geometry size either. I'll think of a way to best handle this kind of situation. For now if you scale the scene up to like a regular cube's size, it should work just fine. After some more tests: Apparently the armature scale is too small, simply applying the scale also does the trick
Member

@ChengduLittleA So you would consider this a known limitation?

@ChengduLittleA So you would consider this a known limitation?
Sergey Sharybin added
Module
Grease Pencil
and removed
Module
VFX & Video
labels 2023-02-13 18:04:16 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#101692
No description provided.