Regression: panels in the properties panel lose their place when scrolling one of the other property panels. #101913

Open
opened 2022-10-18 23:55:44 +02:00 by michael campbell · 19 comments

System Information
Operating system: Windows-10-10.0.19044-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 512.96

Blender Version
Broken: version: 3.4.0 Alpha, branch: master, commit date: 2022-10-08 18:43, hash: cee6c07f9e
Broken: 2.91
Worked: 2.90

This is caused by 940b239ad4

Short description of error
When we scroll down in any panel and switch to another panel then changing back to previous panel will reset its position (i.e. to the top)

Exact steps for others to reproduce the error

2022-10-18 22-54-24.mp4

**System Information** Operating system: Windows-10-10.0.19044-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 512.96 **Blender Version** Broken: version: 3.4.0 Alpha, branch: master, commit date: 2022-10-08 18:43, hash: `cee6c07f9e` Broken: 2.91 Worked: 2.90 This is caused by 940b239ad4 **Short description of error** When we scroll down in any panel and switch to another panel then changing back to previous panel will reset its position (i.e. to the top) **Exact steps for others to reproduce the error** [2022-10-18 22-54-24.mp4](https://archive.blender.org/developer/F13708494/2022-10-18_22-54-24.mp4)

Added subscriber: @3di

Added subscriber: @3di

Added subscriber: @mod_moder

Added subscriber: @mod_moder

It seemed to me that in all editors with 2d positioning, when you switch scopes/tabs/groups you keep the position. And if this position is truncated because your interface has become smaller and does not scroll, then in all the rest you will be higher.
2022-10-19 01-00-48.mp4

It seemed to me that in all editors with 2d positioning, when you switch scopes/tabs/groups you keep the position. And if this position is truncated because your interface has become smaller and does not scroll, then in all the rest you will be higher. [2022-10-19 01-00-48.mp4](https://archive.blender.org/developer/F13708529/2022-10-19_01-00-48.mp4)

Changed status from 'Needs Triage' to: 'Archived'

Changed status from 'Needs Triage' to: 'Archived'

yes, that's what I'm saying. It's still a bug though right?

yes, that's what I'm saying. It's still a bug though right?

Is this a request to remove the global position in the interface?

Is this a request to remove the global position in the interface?

Well that would be nice, but it doesn't seem to be related to this bug. The behaviour is correct until the panel switched to is sufficiently condensed to not be scrollable. So the panels are working correctly until that occurrence. Doesn't appear to be anything to do with the global position of things like the node editors for example.

So it's obviously been designed to remember the positioning when switching between tabs on the same panel, it's just not working after switching to a tab that can't scroll and then back again.

I'm not being funny, but you seem to be closing down bug reports like they're a nuisance. I think you should remember that people reporting bugs are going to some effort to try and help make the software better.

Well that would be nice, but it doesn't seem to be related to this bug. The behaviour is correct until the panel switched to is sufficiently condensed to not be scrollable. So the panels are working correctly until that occurrence. Doesn't appear to be anything to do with the global position of things like the node editors for example. So it's obviously been designed to remember the positioning when switching between tabs on the same panel, it's just not working after switching to a tab that can't scroll and then back again. I'm not being funny, but you seem to be closing down bug reports like they're a nuisance. I think you should remember that people reporting bugs are going to some effort to try and help make the software better.

That the coordinate is truncated is normal behavior. It has always been so. This report is not a bug, but a request to change this behavior. Which is everywhere.

2022-10-19 11-54-40.mp4 2022-10-19 11-57-29.mp4 2022-10-19 11-52-45.mp4
That the coordinate is truncated is normal behavior. It has always been so. This report is not a bug, but a request to change this behavior. Which is everywhere. | [2022-10-19 11-54-40.mp4](https://archive.blender.org/developer/F13713732/2022-10-19_11-54-40.mp4) | [2022-10-19 11-57-29.mp4](https://archive.blender.org/developer/F13713733/2022-10-19_11-57-29.mp4) | [2022-10-19 11-52-45.mp4](https://archive.blender.org/developer/F13713729/2022-10-19_11-52-45.mp4) | | -- | -- | -- |

The job of a bug tracker is to report bugs. In order to make the program better, write suggestions (on RCS), or if you are a developer, design.

The job of a bug tracker is to report bugs. In order to make the program better, write suggestions (on RCS), or if you are a developer, design.
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Changed status from 'Archived' to: 'Needs Triage'

Changed status from 'Archived' to: 'Needs Triage'
Member

In #101913#1434294, @mod_moder wrote:
It has always been so

Hm, dont think so.
If you do this in 2.90, it stays scrolled down after switching back to the tab
If you do this in 2.91, the behavior changed to the behavior described in this report.

We should at least check why/when this changed (because at first sight, this does not necessarily look like an improvement)

> In #101913#1434294, @mod_moder wrote: > It has always been so Hm, dont think so. If you do this in 2.90, it stays scrolled down after switching back to the tab If you do this in 2.91, the behavior changed to the behavior described in this report. We should at least check why/when this changed (because at first sight, this does not necessarily look like an improvement)
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

I'll mark this report as confirmed for now.
@lichtwerk , do you've closest good and bad versions?

I'll mark this report as confirmed for now. @lichtwerk , do you've closest `good and bad` versions?
Member

good 5c78c16b14
bad 940b239ad4
Will try to bisect myself.

good 5c78c16b14 bad 940b239ad4 Will try to bisect myself.
Member

Added subscriber: @HooglyBoogly

Added subscriber: @HooglyBoogly
Member

This is caused by 940b239ad4

So seems like an unintentional change, @HooglyBoogly , mind checking?

This is caused by 940b239ad4 So seems like an unintentional change, @HooglyBoogly , mind checking?
Philipp Oeser changed title from panels in the properties panel lose their place when scrolling one of the other property panels. to Regression: panels in the properties panel lose their place when scrolling one of the other property panels. 2022-10-20 10:38:07 +02:00
Hans Goudey self-assigned this 2022-10-20 14:39:16 +02:00

Wow. I'm sorry that I took it as something planned from the very beginning. I'll be watching more to see if another something like this has happened before.

Wow. I'm sorry that I took it as something planned from the very beginning. I'll be watching more to see if another something like this has happened before.
Philipp Oeser removed the
Interest
User Interface
label 2023-02-10 09:21:31 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#101913
No description provided.