Regression: Passepartout Flickers when using Solid Viewport Shading and Background > Viewport #104128

Open
opened 2023-01-25 00:41:49 +01:00 by Kevin C. Burke · 4 comments
Contributor

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 528.24

Blender Version
Broken: version: 2.93, 3.5
Worked: 2.83

Short description of error
The Passepartout flickers with every Viewport interaction when using Solid Viewport Shading and the Background set to Viewport

Exact steps for others to reproduce the error

  1. Create a 2D Animation workspace
  2. Zoom out to see the Passepartout
  3. Switch to Solid Viewport Shading and set the Background to Viewport

In this screencast, the Passepartout flickers with every Viewport interaction when using Solid Viewport Shading and the Background set to Viewport. In the video, it stops flickers when switching to World, however it is doing now. It does stop when using Material Preview Shading.

Passepartout.mp4

**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 528.24 **Blender Version** Broken: version: 2.93, 3.5 Worked: 2.83 **Short description of error** The Passepartout flickers with every Viewport interaction when using Solid Viewport Shading and the Background set to Viewport **Exact steps for others to reproduce the error** 1. Create a 2D Animation workspace 2. Zoom out to see the Passepartout 3. Switch to Solid Viewport Shading and set the Background to Viewport In this screencast, the Passepartout flickers with every Viewport interaction when using Solid Viewport Shading and the Background set to Viewport. In the video, it stops flickers when switching to World, however it is doing now. It does stop when using Material Preview Shading. [Passepartout.mp4](https://archive.blender.org/developer/F14194625/Passepartout.mp4)
Author
Contributor

Added subscriber: @KevinCBurke

Added subscriber: @KevinCBurke
Pratik Borhade changed title from Passepartout Flickers when using Solid Viewport Shading and Background > Viewport to Regression: Passepartout Flickers when using Solid Viewport Shading and Background > Viewport 2023-01-25 06:06:18 +01:00
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123
Philipp Oeser removed the
Interest
Grease Pencil
label 2023-02-09 15:19:05 +01:00

This also happens in 3D, and looks like the same problem. It's been a bug for years, at least you found a better workaround that isn't going into full screen, it might happen on optimus laptops (intel + nvidia)

I was reported on #61268 and #93875.
I reported it myself as well on #92884 but got closed.

Also google gives a fair amount of results like https://blender.stackexchange.com/questions/124189/nvidia-driver-causes-flickering-viewport-background and https://www.reddit.com/r/blender/comments/r8q5u1/blender_30_viewport_flashing_fix/

It's been there for years already, and the bug keeps getting reported and closed again, there are many people with laptops using this configuration, I can't believe is not getting fixed specially, when there are workarounds that might help to debug the problem.

This also happens in 3D, and looks like the same problem. It's been a bug for years, at least you found a better workaround that isn't going into full screen, it might happen on optimus laptops (intel + nvidia) I was reported on #61268 and #93875. I reported it myself as well on #92884 but got closed. Also google gives a fair amount of results like https://blender.stackexchange.com/questions/124189/nvidia-driver-causes-flickering-viewport-background and https://www.reddit.com/r/blender/comments/r8q5u1/blender_30_viewport_flashing_fix/ It's been there for years already, and the bug keeps getting reported and closed again, there are many people with laptops using this configuration, I can't believe is not getting fixed specially, when there are workarounds that might help to debug the problem.
Clément Foucault added the
Interest
Overlay
label 2024-05-11 13:06:23 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#104128
No description provided.