Regression: Incorrect wireframe overlay with subdivision surface modifier #104376

Closed
opened 2023-02-06 13:06:34 +01:00 by Sun Kim · 6 comments
Contributor

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: Radeon RX 570 Series ATI Technologies Inc. 4.5.0 Core Profile Context 22.11.2.221130

Blender Version
Broken: version: 3.5.0 Alpha, branch: master, commit date: 2023-02-06 01:50, hash: 2627635ff3
Worked: version: 3.5.0 Alpha, branch: master, commit date: 2022-11-03 18:41, hash: 9dfc134c9d
Broken between 2022-11-03 18:41 (9dfc134c9d) and 2022-11-22 00:01 (89349067b6)
Caused by 10131a6f62

Short description of error
Wireframe overlay is broken when subdivision surface modifier is set with Optimal Display enabled, and certain geometry changes (Decimate modifier or Dual Mesh via Geometry Nodes) happen after that.

(Tried tuning off GPU Subdivision and factory settings, but this still happens.)

Working Broken
WirefreameDisplayNoGlitch.png WirefreameDisplayGlitch.png

WirefreameDisplayGlitch.mp4

Exact steps for others to reproduce the error

WirefreameDisplayGlitch.blend

  • From startup file, enable wireframe overlay
  • Add subdivision surface modifier to the cube. (Setting it level 4 makes it easier to see the issue) Make sure that Optimal Display is enabled (default)
  • Add Decimate modifier or Dual Mesh via Geometry Nodes
**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: Radeon RX 570 Series ATI Technologies Inc. 4.5.0 Core Profile Context 22.11.2.221130 **Blender Version** Broken: version: 3.5.0 Alpha, branch: master, commit date: 2023-02-06 01:50, hash: `2627635ff3` Worked: version: 3.5.0 Alpha, branch: master, commit date: 2022-11-03 18:41, hash: `9dfc134c9d` Broken between 2022-11-03 18:41 (`9dfc134c9d`) and 2022-11-22 00:01 (`89349067b6`) Caused by 10131a6f62 **Short description of error** Wireframe overlay is broken when subdivision surface modifier is set with Optimal Display enabled, and certain geometry changes (Decimate modifier or Dual Mesh via Geometry Nodes) happen after that. (Tried tuning off GPU Subdivision and factory settings, but this still happens.) | Working | Broken | -- | -- | | ![WirefreameDisplayNoGlitch.png](https://archive.blender.org/developer/F14252021/WirefreameDisplayNoGlitch.png) | ![WirefreameDisplayGlitch.png](https://archive.blender.org/developer/F14252024/WirefreameDisplayGlitch.png) [WirefreameDisplayGlitch.mp4](https://archive.blender.org/developer/F14252078/WirefreameDisplayGlitch.mp4) **Exact steps for others to reproduce the error** [WirefreameDisplayGlitch.blend](https://archive.blender.org/developer/F14252036/WirefreameDisplayGlitch.blend) - From startup file, enable wireframe overlay - Add subdivision surface modifier to the cube. (Setting it level 4 makes it easier to see the issue) Make sure that Optimal Display is enabled (default) - Add Decimate modifier or Dual Mesh via Geometry Nodes
Author
Contributor

Added subscriber: @persun

Added subscriber: @persun
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123
Pratik Borhade changed title from Incorrect wireframe overlay with subdivision surface modifier to Regression: Incorrect wireframe overlay with subdivision surface modifier 2023-02-06 15:06:23 +01:00
Member

Added subscriber: @HooglyBoogly

Added subscriber: @HooglyBoogly
Member
Caused by 10131a6f62 @HooglyBoogly ^
Hans Goudey self-assigned this 2023-02-06 20:17:26 +01:00
Philipp Oeser removed the
Interest
Modeling
label 2023-02-09 15:27:02 +01:00
Member

Solved by 7ca651d182

Solved by 7ca651d18274acacfe8e0ecb7bc6fdd3399ea01b
Hans Goudey added
Status
Resolved
and removed
Status
Confirmed
labels 2023-02-09 15:57:34 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#104376
No description provided.