GPv3: Modifiers #106665

Open
opened 2023-04-07 15:49:29 +02:00 by Antonio Vazquez · 11 comments

List of modifiers to be converted to new data structure

Status Modifier Description Assignee
Texture Mapping Change stroke UV texture values @LukasTonne
Time Offset Offset keyframes @LukasTonne
Vertex Weight Angle Generate Vertex Weights base on stroke angle @ChengduLittleA
Vertex Weight Proximity Generate Vertex Weights base on distance to object @ChengduLittleA
Array Create array of duplicate instances @ChengduLittleA
Build Create duplication of strokes @ChengduLittleA
Dot Dash Generate dot-dash styled strokes @LukasTonne
Envelope Create an envelope shape @LukasTonne
Length Extend or shrink strokes @ChengduLittleA
Line Art Generate line art strokes from selected source @ChengduLittleA
Mirror Duplicate strokes like a mirror @LukasTonne
Multiple Strokes Produce multiple strokes along one stroke @ChengduLittleA
Outline Convert stroke to perimeter @LukasTonne
Simplify Simplify stroke reducing number of points @ChengduLittleA
Subdivide Subdivide stroke adding more control points @ChengduLittleA
Armature Deform stroke points using armature object @LukasTonne
Hook Deform stroke points using objects @ChengduLittleA
Lattice Deform strokes using lattice @LukasTonne
Noise Add noise to strokes @ChengduLittleA
Offset Change stroke location, rotation or scale @LukasTonne
Shrinkwrap Project the shape onto another object @LukasTonne
Smooth Smooth stroke @ChengduLittleA
Thickness Change stroke thickness @ChengduLittleA
Hue/Saturation Apply changes to stroke colors @LukasTonne
Opacity Opacity of the strokes @LukasTonne
Tint Tint strokes with new color @LukasTonne

Checklist before calling it done

  • Modifier baking
  • Leave out "Data" suffix for RNA struct names (GreasePencilMirrorModifier rather than GreasePencilMirrorModifierData)
  • Consistent flags in DNA/RNA (GP_ENVELOPE_SEGMENTS vs GREASE_PENCIL_ENVELOPE_SEGMENTS vs MOD_GREASE_PENCIL_ENVELOPE_SEGMENTS)
  • Call GeometryComponentEditData::remember_deformed_positions_if_necessary for modifiers that change the topology (adding/removing points or strokes).
  • Instead of supporting CURVE_TYPE_BEZIER in the modifiers, we need a function that checks if there are bezier curves in the CurvesGeometry and converts them to poly curves.
  • All the modifiers need to be converted from the legacy to the new type. See !118415.
  • All modifiers need to document any changes (e.g. RNA properties, renamings, etc.) in #114419
List of modifiers to be converted to new data structure **Status** | **Modifier** | **Description** | **Assignee** | | -- | -- | -- | -- | | <input type="checkbox" checked/> |Texture Mapping |Change stroke UV texture values | @LukasTonne | | <input type="checkbox" checked /> |Time Offset |Offset keyframes | @LukasTonne | |<input type="checkbox" checked /> |Vertex Weight Angle |Generate Vertex Weights base on stroke angle | @ChengduLittleA | |<input type="checkbox" checked /> |Vertex Weight Proximity |Generate Vertex Weights base on distance to object | @ChengduLittleA | | <input type="checkbox" checked /> |Array |Create array of duplicate instances | @ChengduLittleA | | <input type="checkbox" checked /> |Build |Create duplication of strokes | @ChengduLittleA | | <input type="checkbox" checked/> |Dot Dash |Generate dot-dash styled strokes | @LukasTonne | | <input type="checkbox" checked/> |Envelope |Create an envelope shape | @LukasTonne | | <input type="checkbox" checked /> |Length |Extend or shrink strokes | @ChengduLittleA | | <input type="checkbox" checked /> |Line Art |Generate line art strokes from selected source | @ChengduLittleA | | <input type="checkbox" checked/> |Mirror |Duplicate strokes like a mirror | @LukasTonne | | <input type="checkbox" checked/> |Multiple Strokes |Produce multiple strokes along one stroke | @ChengduLittleA | | <input type="checkbox" checked/> |Outline |Convert stroke to perimeter | @LukasTonne | | <input type="checkbox" checked/> |Simplify |Simplify stroke reducing number of points | @ChengduLittleA | | <input type="checkbox" checked/> |Subdivide |Subdivide stroke adding more control points | @ChengduLittleA | | <input type="checkbox" checked /> |Armature |Deform stroke points using armature object | @LukasTonne | | <input type="checkbox" checked /> |Hook |Deform stroke points using objects | @ChengduLittleA | | <input type="checkbox" checked/> |Lattice |Deform strokes using lattice | @LukasTonne | | <input type="checkbox" checked/> |Noise |Add noise to strokes | @ChengduLittleA | | <input type="checkbox" checked/> |Offset |Change stroke location, rotation or scale | @LukasTonne | | <input type="checkbox" checked/> |Shrinkwrap |Project the shape onto another object | @LukasTonne | | <input type="checkbox" checked/> |Smooth |Smooth stroke | @ChengduLittleA | | <input type="checkbox" checked/> |Thickness |Change stroke thickness | @ChengduLittleA | | <input type="checkbox" checked/> |Hue/Saturation |Apply changes to stroke colors | @LukasTonne | | <input type="checkbox" checked/> |Opacity |Opacity of the strokes | @LukasTonne | | <input type="checkbox" checked/> |Tint |Tint strokes with new color | @LukasTonne | ## Checklist before calling it done - [ ] Modifier baking - [ ] Leave out "Data" suffix for RNA struct names (`GreasePencilMirrorModifier` rather than `GreasePencilMirrorModifierData`) - [ ] Consistent flags in DNA/RNA (`GP_ENVELOPE_SEGMENTS` vs `GREASE_PENCIL_ENVELOPE_SEGMENTS` vs `MOD_GREASE_PENCIL_ENVELOPE_SEGMENTS`) - [ ] Call `GeometryComponentEditData::remember_deformed_positions_if_necessary` for modifiers that change the topology (adding/removing points or strokes). - [ ] Instead of supporting `CURVE_TYPE_BEZIER` in the modifiers, we need a function that checks if there are bezier curves in the `CurvesGeometry` and converts them to poly curves. - [x] All the modifiers need to be converted from the legacy to the new type. See !118415. - [ ] All modifiers need to document any changes (e.g. RNA properties, renamings, etc.) in #114419
Antonio Vazquez added the
Type
To Do
label 2023-04-07 15:49:29 +02:00
Antonio Vazquez added this to the Grease Pencil project 2023-04-07 15:49:30 +02:00
Falk David modified the project from Grease Pencil to (deleted) 2023-04-07 18:05:06 +02:00
Falk David changed title from GPencil 3.0: List of Modifiers to migrate to GPencil 3.0: List of modifiers to migrate 2023-04-07 18:06:06 +02:00
Falk David changed title from GPencil 3.0: List of modifiers to migrate to GPencil 3.0: List of modifiers to be migrated 2023-04-07 18:06:28 +02:00
Author
Member

@filedescriptor Maybe this task need a subtask to move the gp modifiers to the same list of meshes modifiers. This task would be before doing any conversion. Put all modifiers in the same list (meshes, curves and gpencil) will avoid duplicate code and make easier GN integration.

@filedescriptor Maybe this task need a subtask to move the gp modifiers to the same list of meshes modifiers. This task would be before doing any conversion. Put all modifiers in the same list (meshes, curves and gpencil) will avoid duplicate code and make easier GN integration.
Member

We would have to see if that requires versioning. But yes that could be a first step.

We would have to see if that requires versioning. But yes that could be a first step.
Falk David added a new dependency 2023-04-12 17:53:08 +02:00
Falk David modified the project from (deleted) to Grease Pencil 2023-06-02 18:06:41 +02:00
Falk David changed title from GPencil 3.0: List of modifiers to be migrated to GPv3: Modifiers 2023-12-12 10:36:05 +01:00
Member

Do we keep separate modifiers like "smooth" and "subdivide" etc or just remove these "simple" modifiers and let GN handle these?

Do we keep separate modifiers like "smooth" and "subdivide" etc or just remove these "simple" modifiers and let GN handle these?
Member

@ChengduLittleA The plan is to port all modifiers. Some might be replaced with GN, but we can't easily replicate the filtering options for example. In the future, GN will likely replace all these, but that won't be soon.

@ChengduLittleA The plan is to port all modifiers. Some might be replaced with GN, but we can't easily replicate the filtering options for example. In the future, GN will likely replace all these, but that won't be soon.
Member

For Simplify we should think about moving ramer_douglas_peucker_simplify from blender/source/blender/editors/grease_pencil/intern/grease_pencil_geom.cc into blender/source/blender/geometry.

For `Simplify` we should think about moving `ramer_douglas_peucker_simplify` from `blender/source/blender/editors/grease_pencil/intern/grease_pencil_geom.cc` into `blender/source/blender/geometry`.
Member

For Simplify we should think about moving ramer_douglas_peucker_simplify from blender/source/blender/editors/grease_pencil/intern/grease_pencil_geom.cc into blender/source/blender/geometry.

@filedescriptor Looks like the rest 3 modes (except sample) will require migrating the function to separate file under /blender/geometry ?

> For Simplify we should think about moving ramer_douglas_peucker_simplify from blender/source/blender/editors/grease_pencil/intern/grease_pencil_geom.cc into blender/source/blender/geometry. @filedescriptor Looks like the rest 3 modes (except sample) will require migrating the function to separate file under `/blender/geometry` ?
Member

I noticed that the noise modifier still has a todo: blender/source/blender/modifiers/intern/MOD_grease_pencil_noise.cc:211 says // TODO: UV hasn't been implemented yet.. @LukasTonne
Same for the smooth modifier.

I noticed that the noise modifier still has a todo: `blender/source/blender/modifiers/intern/MOD_grease_pencil_noise.cc:211` says `// TODO: UV hasn't been implemented yet.`. @LukasTonne Same for the smooth modifier.
Member

@filedescriptor I think at the time the UV isn't used yet, I guess it is now?

@filedescriptor I think at the time the UV isn't used yet, I guess it is now?
Member

@ChengduLittleA Yes. Since @LukasTonne and @casey-bianco-davis are already familiar with how they work, maybe they can take a look first.

@ChengduLittleA Yes. Since @LukasTonne and @casey-bianco-davis are already familiar with how they work, maybe they can take a look first.

Here's the smooth modifier #120032 and I will take a look at the noise modifier later.

Here's the smooth modifier #120032 and I will take a look at the noise modifier later.
Member

@filedescriptor @casey-bianco-davis I made a PR for the UV rotation mode in the noise modifier #120336

@filedescriptor @casey-bianco-davis I made a PR for the UV rotation mode in the noise modifier #120336
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Reference: blender/blender#106665
No description provided.