NLA hold forward extrapolation incorrectly holds backwards #107238

Closed
opened 2023-04-22 13:18:47 +02:00 by Julieta Riley · 1 comment

System Information
Operating system: Windows-10-10.0.19044-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 526.98

Blender Version
Broken: version: 3.5.1 Release Candidate, branch: blender-v3.5-release, commit date: 2023-04-05 07:29, hash: 8f3faae18bb8
Worked: (newest version of Blender that worked as expected)

Short description of error
NLA hold forward extrapolation incorrectly holds backwards

Exact steps for others to reproduce the error
open file with load UI option ticked, and press play. frame 1 has an nla strip with the bone rotated to the left extrapolation is hold forward, and the live strip above it has the bone rotated to the right on frame 60 using hold forward extrapolation. The bone is incorrectly rotated to the right from frame 1 because hold forward is acting as hold both ways.

**System Information** Operating system: Windows-10-10.0.19044-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 526.98 **Blender Version** Broken: version: 3.5.1 Release Candidate, branch: blender-v3.5-release, commit date: 2023-04-05 07:29, hash: `8f3faae18bb8` Worked: (newest version of Blender that worked as expected) **Short description of error** NLA hold forward extrapolation incorrectly holds backwards **Exact steps for others to reproduce the error** open file with load UI option ticked, and press play. frame 1 has an nla strip with the bone rotated to the left extrapolation is hold forward, and the live strip above it has the bone rotated to the right on frame 60 using hold forward extrapolation. The bone is incorrectly rotated to the right from frame 1 because hold forward is acting as hold both ways.
Julieta Riley added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-04-22 13:18:47 +02:00

This is same report as #100718 so will close as duplicate. Feel free to subscribe there for updates.

This is same report as #100718 so will close as duplicate. Feel free to subscribe there for updates.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-04-24 23:22:36 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#107238
No description provided.