Geometry Nodes - Realize Instances looses original collection meshes' autosmooth normal data #107376

Closed
opened 2023-04-26 17:29:19 +02:00 by Andres Stephens · 1 comment
Contributor

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 4090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.68

Blender Version
Broken: version: 3.5.1, branch: blender-v3.5-release, commit date: 2023-04-24 18:11, hash: e1ccd9d4a1d3
Worked: Blender 2.9.3

Short description of error

Issue

blender_nAFs9oQiAa.png
Right now when you reference a collection of objects with different normal settings (smooth/autosmooth/no smooth and custom split normals) and then realize instances to later apply them for export - you can't without loosing or resetting the normal data to a new autosmooth setting.

blender_0vFIPVwBrG.gif

  • Adding sharp edge splits in the original meshes in the collection doesn't 100% preserve the face normals, as the new autosmoothed normals on faces are re-calculated differently on the new GN mesh

Exact steps for others to reproduce the error

Desired UX

  1. Realize the instances of a collection
  2. Preserve the normals set per object in the collection on the GN object
  3. Apply GN tree on export for single meshes in FBX or other workflows, or for asset libraries that are much more performant in layout - with original applied normals.

In blend file attached:

  • mute the Realize Instances node to see how the normals of the green monkeys change their normals.

User Story:
This is useful for a user when they need to have an editable yet final object with applied normals and such made of multuple objects, but the project requirements requires minimal mesh data manipulation and instancing - ei.. 10 objects making a prop, but one prop mesh as single mesh data both for memory management and minimal scene management. Their art director needs to change the prop handle, this file needs to be exported again or saved as new linked data - single mesh. But the normals of all the sub-objects merged together need to be preserved - as this is a low poly asset designed for games and quick rendering in Eevee. This is impossible since now the FBX is exporting multiple meshes per collection, or the merging/marking sharp process has to be done manually over and over and over again - slowing down the pipeline and wearing the artist down.

Notes:

  • Seems normal attributes are no-longer a thing? Could this be the cause? (Blender 2.93)
    blender_0vFIPVwBrG.gif
**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 4090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.68 **Blender Version** Broken: version: 3.5.1, branch: blender-v3.5-release, commit date: 2023-04-24 18:11, hash: `e1ccd9d4a1d3` Worked: Blender 2.9.3 **Short description of error** ## Issue ![blender_nAFs9oQiAa.png](/attachments/fc289af5-45de-4764-b021-908cf2505ac7) Right now when you reference a collection of objects with different normal settings (smooth/autosmooth/no smooth and custom split normals) and then realize instances to later apply them for export - you can't without loosing or resetting the normal data to a new autosmooth setting. ![blender_0vFIPVwBrG.gif](/attachments/d17934b6-e906-4e32-9923-39a00d359818) - Adding sharp edge splits in the original meshes in the collection doesn't 100% preserve the face normals, as the new autosmoothed normals on faces are re-calculated differently on the new GN mesh **Exact steps for others to reproduce the error** ## Desired UX 1. Realize the instances of a collection 2. Preserve the normals set per object in the collection on the GN object 3. Apply GN tree on export for single meshes in FBX or other workflows, or for asset libraries that are much more performant in layout - with original applied normals. In blend file attached: - mute the Realize Instances node to see how the normals of the green monkeys change their normals. **User Story:** This is useful for a user when they need to have an editable yet final object with applied normals and such made of multuple objects, but the project requirements requires minimal mesh data manipulation and instancing - ei.. 10 objects making a prop, but one prop mesh as single mesh data both for memory management and minimal scene management. Their art director needs to change the prop handle, this file needs to be exported again or saved as new linked data - single mesh. But the normals of all the sub-objects merged together need to be preserved - as this is a low poly asset designed for games and quick rendering in Eevee. This is impossible since now the FBX is exporting multiple meshes per collection, or the merging/marking sharp process has to be done manually over and over and over again - slowing down the pipeline and wearing the artist down. **Notes:** - Seems normal attributes are no-longer a thing? Could this be the cause? (Blender 2.93) ![blender_0vFIPVwBrG.gif](/attachments/d17934b6-e906-4e32-9923-39a00d359818)
Andres Stephens added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-04-26 17:29:20 +02:00
Iliya Katushenock added the
Interest
Geometry Nodes
Interest
Nodes & Physics
labels 2023-04-26 17:38:33 +02:00
Member

Thanks for the detailed description. However, this is just a feature that isn't supported for now, it's expected to work this way. #93551 will indeed make this work, and should give significant performance improvements too.

Thanks for the detailed description. However, this is just a feature that isn't supported for now, it's expected to work this way. #93551 will indeed make this work, and should give significant performance improvements too.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-04-26 18:10:37 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#107376
No description provided.