Mac Hard Crash 3.5.1 with Metal Backend #107451

Closed
opened 2023-04-28 20:57:19 +02:00 by David-Stoddard-4 · 9 comments

Operating system: 13.2.1 (Ventura)
System: iMac Pro 18 Core Xeon, 64GB RAM, Radeon Pro Vega 64 16GB (not enabled in Blender)
Graphics card: Radeon RX 6900XT (Sonnet eGPU)

Blender Version
Broken: 3.5.1

Tried to load the "Tree Creature" Demo file with the Metal backend enabled.
System freeze- no mouse movement, or screen update for about 60 seconds, then screen went black, and I was "dumped" into the default login screen.
Never had a crash that logged me out of the current user before.

This file loads fine with openGL.

One of the files I found shows a "GPU restart" which seems to indicate the Vega card, but this card is disabled in Blender preferences, so I should only be rendering on the RX6900 XT.

Dave

Operating system: 13.2.1 (Ventura) System: iMac Pro 18 Core Xeon, 64GB RAM, Radeon Pro Vega 64 16GB (not enabled in Blender) Graphics card: Radeon RX 6900XT (Sonnet eGPU) **Blender Version** Broken: 3.5.1 Tried to load the "Tree Creature" Demo file with the Metal backend enabled. System freeze- no mouse movement, or screen update for about 60 seconds, then screen went black, and I was "dumped" into the default login screen. Never had a crash that logged me out of the current user before. This file loads fine with openGL. One of the files I found shows a "GPU restart" which seems to indicate the Vega card, but this card is disabled in Blender preferences, so I should only be rendering on the RX6900 XT. Dave
David-Stoddard-4 added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-04-28 20:57:20 +02:00

I was able to open the file with "load UI" disabled in the open dialog box options...

I was able to open the file with "load UI" disabled in the open dialog box options...

Strange- Activity Monitor shows Blender under the internal Vega GPU, not the RX6900 XT eGPU...

Also- switching to Eevee rendered mode has Blender unresponsive fr about 5 minutes.
At least it didnt crash.

Strange- Activity Monitor shows Blender under the internal Vega GPU, not the RX6900 XT eGPU... Also- switching to Eevee rendered mode has Blender unresponsive fr about 5 minutes. At least it didnt crash.

Definitely looks like 3.5.1 is rendering only on the built in GPU...
Not the eGPU as set in the prefs.

Definitely looks like 3.5.1 is rendering only on the built in GPU... Not the eGPU as set in the prefs.

Looks like you cannot select which device to render on unless it's cycles?

Looks like you cannot select which device to render on unless it's cycles?

Can you simplify the file as much as possible and upload it here?

Can you simplify the file as much as possible and upload it here?
Richard Antalik added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-05-10 18:23:33 +02:00

Hi, this was the "Tree Creature" Blender Demo file found here...
https://download.blender.org/demo/eevee/tree_creature/tree_creature.blend

As a new Blender user, It is beyond my ability to dissect and simplify this file.

It does appear that using an eGPU is only possible in Cycles.
So Eevee/ Metal backend (UI, etc.) are limited and cannot use the eGPU which is much more powerful.
Would be nice for all Metal rendering to run on the GPU selected in Prefs.

Hi, this was the "Tree Creature" Blender Demo file found here... https://download.blender.org/demo/eevee/tree_creature/tree_creature.blend As a new Blender user, It is beyond my ability to dissect and simplify this file. It does appear that using an eGPU is only possible in Cycles. So Eevee/ Metal backend (UI, etc.) are limited and cannot use the eGPU which is much more powerful. Would be nice for all Metal rendering to run on the GPU selected in Prefs.

For me it seems that Blender just hangs, without crashing. Does not seem that it wants to recover, so I guess I can confirm this issue.

Looks like you cannot select which device to render on unless it's cycles?

Not from Preferences. There may be option to configure which GPU should be used for OS or particular app, but I am not that familiar with Macs, so I can't tell.

As a new Blender user, It is beyond my ability to dissect and simplify this file.

I wouldn't say so, usually crash is caused by particular object, so deleting half of them and just checking each time is usually enough to pinpoint the issue. It's possible, that here there would be more objects that can be problematic.

For me it seems that Blender just hangs, without crashing. Does not seem that it wants to recover, so I guess I can confirm this issue. > Looks like you cannot select which device to render on unless it's cycles? Not from Preferences. There may be option to configure which GPU should be used for OS or particular app, but I am not that familiar with Macs, so I can't tell. > As a new Blender user, It is beyond my ability to dissect and simplify this file. I wouldn't say so, usually crash is caused by particular object, so deleting half of them and just checking each time is usually enough to pinpoint the issue. It's possible, that here there would be more objects that can be problematic.

I have been using the Mac platform for a LONG time... but I never knew this trick:

Select the Blender application and "get info".
There is a checkbox to "prefer external GPU".

This makes the external GPU the default for all drawing in 3.5 including eevee.

Project seems to load properly with the increased resources of the Radeon 6900XT vs the internal Vega 64.

I have been using the Mac platform for a LONG time... but I never knew this trick: Select the Blender application and "get info". There is a checkbox to "prefer external GPU". This makes the external GPU the default for all drawing in 3.5 including eevee. Project seems to load properly with the increased resources of the Radeon 6900XT vs the internal Vega 64.

Thanks for update, glad this is fixed for you. Will keep confirmed though stil it is not working well on my machine.

Thanks for update, glad this is fixed for you. Will keep confirmed though stil it is not working well on my machine.
Germano Cavalcante added the
Platform
macOS
label 2023-05-22 23:17:40 +02:00
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2023-06-26 14:12:59 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#107451
No description provided.