Sculpt Mode: Mesh hidden when Active UV Layer is selected (fixed already request for 3.3 LTS backport) #109199

Closed
opened 2023-06-21 12:30:28 +02:00 by Manuel · 8 comments

System Information
Operating system: Windows-10-10.0.19044-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 517.40

Blender Version
Broken: version: 3.3.0, branch: master, commit date: 2022-09-06 15:39, hash: rB0759f671ce1f
Worked: 3.1.0

Short description of error
When selecting the active UV channel on an object with four UV channels AND four vertex color channels, the mesh will be hidden in sculpt mode. Deselecting the uv channel, changing the active one (camera icon) or deleting either one of the UV or vertex color channels all fix the problem.

SEEMS TO BE FIXED IN 3.5 but might be relevant for 3.3 LTS(?)

Exact steps for others to reproduce the error
New file:

  • Select Cube
  • Add 4 uv channels
  • Add 4 vertex color channels
  • Go to sculpt mode
  • Select the active UV channel (the one with the camera icon)
**System Information** Operating system: Windows-10-10.0.19044-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 517.40 **Blender Version** Broken: version: 3.3.0, branch: master, commit date: 2022-09-06 15:39, hash: `rB0759f671ce1f` Worked: 3.1.0 **Short description of error** When selecting the active UV channel on an object with four UV channels AND four vertex color channels, the mesh will be hidden in sculpt mode. Deselecting the uv channel, changing the active one (camera icon) or deleting either one of the UV or vertex color channels all fix the problem. SEEMS TO BE FIXED IN 3.5 but might be relevant for 3.3 LTS(?) **Exact steps for others to reproduce the error** New file: - Select Cube - Add 4 uv channels - Add 4 vertex color channels - Go to sculpt mode - Select the active UV channel (the one with the camera icon)
Manuel added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-06-21 12:30:29 +02:00
Member

Can confirm, lets see when that changed/was fixed

Can confirm, lets see when that changed/was fixed
Philipp Oeser changed title from Sculpt Mode: Mesh hidden when Active UV Layer is selected to Sculpt Mode: Mesh hidden when Active UV Layer is selected (fixed already request for 3.3 LTS backport) 2023-06-21 15:06:05 +02:00
Philipp Oeser added
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-06-21 15:06:24 +02:00
Member

Boy, this bisect is a pain (and would probably not really be helpful either, so I dropped it).
There was a time when sculpt was so broken, you couldnt open a file in sculptmode at all...

So the whole thing was fixed somewhere between 8a68f4f808 and 22c3db72ca, can @JosephEagar name a commit that is suitable for backporting to 3.3 LTS that would fix this issue there?

Boy, this bisect is a **pain** (and would probably not really be helpful either, so I dropped it). There was a time when sculpt was so broken, you couldnt open a file in sculptmode at all... So the whole thing was fixed somewhere between 8a68f4f80814 and 22c3db72ca2f, can @JosephEagar name a commit that is suitable for backporting to 3.3 LTS that would fix this issue there?
Philipp Oeser added the
Module
Sculpt, Paint & Texture
label 2023-06-21 17:14:17 +02:00
Member

IIRC this was not a simple fix, what's the branch name for 3.3 LTS? Just blender-v3.3-release? I can take a look.

IIRC this was not a simple fix, what's the branch name for 3.3 LTS? Just blender-v3.3-release? I can take a look.
Pratik Borhade added this to the 3.3 LTS milestone 2023-06-22 06:34:40 +02:00
Member

Yep, it is blender-v3.3-release.
If you find something that applies cleanly, you can also add that commit(s) to #100749

Yep, it is `blender-v3.3-release`. If you find something that applies cleanly, you can also add that commit(s) to #100749
Member

a6ba8e5f38 was the main commit for this fix, but it already seems to be in the branch. It must be a follow-up fix commit.

a6ba8e5f38dbf62392088c3020aab549b7c80554 was the main commit for this fix, but it already seems to be in the branch. It must be a follow-up fix commit.
Member

Yeesh. How important is it to fix this? I think the problem is the original, highly broken PBVH drawing code. I had to rewrite it from scratch in C++ (and inside the proper code module, it was originally in the GPU module instead of draw).

The original code had no way to know which attributes were needed for the current set of viewport shaders. So it uploaded all of them, inside a single VBO. There's a limit to how many attributes a single VBO can contain, so once a certain number of attributes are created the mesh glitches or disappears . The new code only uploads the attributes the GPU needs and puts them in multiple VBOs.

Yeesh. How important is it to fix this? I think the problem is the original, highly broken PBVH drawing code. I had to rewrite it from scratch in C++ (and inside the proper code module, it was originally in the GPU module instead of draw). The original code had no way to know which attributes were needed for the current set of viewport shaders. So it uploaded all of them, inside a single VBO. There's a limit to how many attributes a single VBO can contain, so once a certain number of attributes are created the mesh glitches or disappears . The new code only uploads the attributes the GPU needs and puts them in multiple VBOs.
Member

I wasn't able to find a clean set of commits. If necessary I can backport the new code manually.

I wasn't able to find a clean set of commits. If necessary I can backport the new code manually.
Member

I would not backport the new code to LTS just for this fix (it might come with other bugs -- possibly unreported yet -- which somehow contradicts the purpose of LTS).

Therefor, I am closing this report, thx for the input everyone!

I would not backport the new code to LTS just for this fix (it might come with other bugs -- possibly unreported yet -- which somehow contradicts the purpose of LTS). Therefor, I am closing this report, thx for the input everyone!
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2023-06-23 09:17:24 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109199
No description provided.