Metal backend crashes entire macOS when Contact Shadows are enabled and Clearcoat materials are visible in the scene #109342

Closed
opened 2023-06-25 14:55:37 +02:00 by Matthias · 5 comments

System Information
Operating system: macOS 13.4.1
Computer: Mac Pro (2019) 3,3 GHz 12 Core Intel Xeon W, 96 GB Memory
Graphics card: AMD Radeon Pro W5700X 16 GB

Blender Version
Broken: 3.5, 3.6, 4.0
Worked: worked definitely with Blender 3.5 before, so it must be related to a recent macOS version update

Short description of error
With Metal backend enabled and EEVEE rendering in viewport turned on. Blender becomes unresponsive when any light has "Contact Shadows" enabled and a material with Principled Shader is visible in the scene where the Clearcoat value is not 0.0.
In case Blender is not "force quited" within the next 2-3 seconds the GPU starts to produce glitches in the entire macOS UI and the whole computer is becoming unresponsive und ultimately crashes.
This is very strange behaviour but can be reproduced reliantly (see below). I did not encounter this issue with the Metal Backend at the beginning when it was introduced and also not during the 3.5 beta phase. I assume it is a bug that got introduced by a recent macOS update. I also assume that it only occurs on Intel/AMD platforms, otherwise I assume it would have been reported already.

Exact steps for others to reproduce the error

  • Open Blender with default scene (with Metal backend enabled)
  • Turn on EEVEE viewport rendering for the default viewport
  • Select default Point Light and go into light properties
  • under Shadow section enable "Contact Shadows"
  • Select Default Cube and open Shader editor for Default material
  • In Default Principled BSDF Shader enter 1.0 in Clearcoat field
    --> Blender becomes unresponsive immediately, GPU glitches occur, system becomes unresponsive, computer crashes

A similar crash behaviour is also experienced when then a Transmission value is entered that is not 0.0. All other Principled BSDF parameter do not cause any crashes.

**System Information** Operating system: macOS 13.4.1 Computer: Mac Pro (2019) 3,3 GHz 12 Core Intel Xeon W, 96 GB Memory Graphics card: AMD Radeon Pro W5700X 16 GB **Blender Version** Broken: 3.5, 3.6, 4.0 Worked: worked definitely with Blender 3.5 before, so it must be related to a recent macOS version update **Short description of error** With Metal backend enabled and EEVEE rendering in viewport turned on. Blender becomes unresponsive when any light has "Contact Shadows" enabled and a material with Principled Shader is visible in the scene where the Clearcoat value is not 0.0. In case Blender is not "force quited" within the next 2-3 seconds the GPU starts to produce glitches in the entire macOS UI and the whole computer is becoming unresponsive und ultimately crashes. This is very strange behaviour but can be reproduced reliantly (see below). I did not encounter this issue with the Metal Backend at the beginning when it was introduced and also not during the 3.5 beta phase. I assume it is a bug that got introduced by a recent macOS update. I also assume that it only occurs on Intel/AMD platforms, otherwise I assume it would have been reported already. **Exact steps for others to reproduce the error** - Open Blender with default scene (with Metal backend enabled) - Turn on EEVEE viewport rendering for the default viewport - Select default Point Light and go into light properties - under Shadow section enable "Contact Shadows" - Select Default Cube and open Shader editor for Default material - In Default Principled BSDF Shader enter 1.0 in Clearcoat field --> Blender becomes unresponsive immediately, GPU glitches occur, system becomes unresponsive, computer crashes A similar crash behaviour is also experienced when then a Transmission value is entered that is not 0.0. All other Principled BSDF parameter do not cause any crashes.
Matthias added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-06-25 14:55:38 +02:00
Member

Hi, probably related to other reports on AMD platforms: #109096
@iss , can you confirm?

Hi, probably related to other reports on AMD platforms: #109096 @iss , can you confirm?

I am at HQ this week, so don't have mac machine available.

I am at HQ this week, so don't have mac machine available.

I believe this is caused by the same problem as resolved in this PR: #109358

would you please be able to verify whether this still occurs with the latest daily build? ( https://builder.blender.org/download/daily/ )
Thanks!

I believe this is caused by the same problem as resolved in this PR: https://projects.blender.org/blender/blender/pulls/109358 would you please be able to verify whether this still occurs with the latest daily build? ( https://builder.blender.org/download/daily/ ) Thanks!
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-06-28 05:25:04 +02:00
Author

@Michael-Parkin-White-Apple I've just downloaded the 3.6 release version and I'm happy to report that the issue is fixed. Thanks for the patch and for making lots of Mac/Intel/AMD Blender unsers happy again 👍

@Michael-Parkin-White-Apple I've just downloaded the 3.6 release version and I'm happy to report that the issue is fixed. Thanks for the patch and for making lots of Mac/Intel/AMD Blender unsers happy again 👍
Member

Thanks for the update, closing.

Thanks for the update, closing.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-07-03 04:10:38 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109342
No description provided.