Images and movies does not scale to match the viewport using compositor #109470

Closed
opened 2023-06-28 21:03:03 +02:00 by jack conradsen · 4 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.23

Blender Version
Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: (newest version of Blender that worked as expected)

Short description of error
when using the compositor preview. Compositing an image or movie underneath your render, it doesn't scale to match the viewport.

Exact steps for others to reproduce the error
Open the blend file. see that the compositor and 3d viewport is open. It is set to rendered mode with real-time compositing enabled.
press 0 so that the view is alligned to the camera. If you zoom in and out using the scroll view. You'll see that the composted image doesn't scale to match the camera at all. And if you render out the scene. the image does scale to match the viewport.
It is the same case if, within the compositor window you show a preview on the background it will not be aligned properly

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.23 **Blender Version** Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: (newest version of Blender that worked as expected) **Short description of error** when using the compositor preview. Compositing an image or movie underneath your render, it doesn't scale to match the viewport. **Exact steps for others to reproduce the error** Open the blend file. see that the compositor and 3d viewport is open. It is set to rendered mode with real-time compositing enabled. press 0 so that the view is alligned to the camera. If you zoom in and out using the scroll view. You'll see that the composted image doesn't scale to match the camera at all. And if you render out the scene. the image does scale to match the viewport. It is the same case if, within the compositor window you show a preview on the background it will not be aligned properly
jack conradsen added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-06-28 21:03:04 +02:00
Author

An extra example from my current project. It is the same compositor node setup

An extra example from my current project. It is the same compositor node setup

I'm not sure if this should be considered a bug, because unlike a scene render in the viewport, the resolution of an image is not directly related to the camera's aperture or camera position.
The nodes used do not update the image size in relation to the camera or viewport.
So this report appears to be more of a modified feature request than a bug report.

But I'll leave it to the VFX team to decide.

I'm not sure if this should be considered a bug, because unlike a scene render in the viewport, the resolution of an image is not directly related to the camera's aperture or camera position. The nodes used do not update the image size in relation to the camera or viewport. So this report appears to be more of a modified feature request than a bug report. But I'll leave it to the `VFX` team to decide.
Germano Cavalcante added
Module
VFX & Video
Status
Needs Info from Developers
and removed
Status
Needs Triage
labels 2023-06-28 23:04:12 +02:00
Author

So this report appears to be more of a modified feature request than a bug report.

But I'll leave it to the VFX team to decide.

it's up to them, but hitting render shows the image in a fixed position and size so the live preview is definitely misleading

> So this report appears to be more of a modified feature request than a bug report. > > But I'll leave it to the `VFX` team to decide. it's up to them, but hitting render shows the image in a fixed position and size so the live preview is definitely misleading
jack conradsen changed title from Images and movies does not scale to match the viewport using real-time compositor to Images and movies does not scale to match the viewport using compositor 2023-07-03 18:27:57 +02:00
Member

This is the expected behavior at the moment. If you want images and videos to be constrained to the camera area, enable camera passepartout and set its alpha to 1, this will make areas outside of the camera black and limit the compositing space to the camera region. Then, instead of a Transform node, use a Scale node with its type set to Render Size -> Fit.

This is the expected behavior at the moment. If you want images and videos to be constrained to the camera area, enable camera passepartout and set its alpha to 1, this will make areas outside of the camera black and limit the compositing space to the camera region. Then, instead of a Transform node, use a Scale node with its type set to Render Size -> Fit.
Blender Bot added
Status
Archived
and removed
Status
Needs Info from Developers
labels 2023-12-04 17:21:34 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109470
No description provided.