Disappearing Materials #109723

Closed
opened 2023-07-05 07:17:46 +02:00 by ftmouse · 4 comments

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 512.78

Blender Version
Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: (newest version of Blender that worked as expected)

Short description of error
[Please fill out a short description of the error here]
Create a material on an object and use the ALT+D link to copy the object. This is not a problem in Blender. The material on the copied object is still present, but when exporting to FBX, the material on the copied object no longer exists. This problem also exists in Blender 4.0, but it is not present in Blender 3.5.1
Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

**System Information** Operating system: Windows-10-10.0.19041-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 512.78 **Blender Version** Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: (newest version of Blender that worked as expected) **Short description of error** [Please fill out a short description of the error here] Create a material on an object and use the ALT+D link to copy the object. This is not a problem in Blender. The material on the copied object is still present, but when exporting to FBX, the material on the copied object no longer exists. This problem also exists in Blender 4.0, but it is not present in Blender 3.5.1 **Exact steps for others to reproduce the error** [Please describe the exact steps needed to reproduce the issue] [Based on the default startup or an attached .blend file (as simple as possible)]
ftmouse added the
Status
Needs Triage
Type
Report
Priority
Normal
labels 2023-07-05 07:17:46 +02:00
Member

Cant repro in a simple test.

Is the material also lost when you import it back into blender?
Or does this only happen when importing into another application?
If this does not happen in all files, please share a particular .blend file where this issue is present.

(also: if this turns out to be a legit bug in the FBX Addon, it would need to be submitted in the addons repository https://projects.blender.org/blender/blender-addons/issues)

Cant repro in a simple test. Is the material also lost when you import it back into blender? Or does this only happen when importing into another application? If this does not happen in all files, please share a particular .blend file where this issue is present. (also: if this turns out to be a legit bug in the FBX Addon, it would need to be submitted in the addons repository https://projects.blender.org/blender/blender-addons/issues)
Philipp Oeser added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-07-05 08:56:22 +02:00
Author

This blender file uses Default argument to export fbx, and then drag unity3d to find that one of the objects has no material

This blender file uses Default argument to export fbx, and then drag unity3d to find that one of the objects has no material
Philipp Oeser added
Status
Needs Triage
and removed
Status
Needs Information from User
labels 2023-07-05 09:39:20 +02:00
Member

I can confirm this as a bug in the FBX exporter and have created blender/blender-addons#104737

I can confirm this as a bug in the FBX exporter and have created https://projects.blender.org/blender/blender-addons/issues/104737
Member

Thx @Mysteryem , think we can close this one then
@ftmouse : please subscribe in blender/blender-addons#104737 if you want further updates

Thx @Mysteryem , think we can close this one then @ftmouse : please subscribe in blender/blender-addons#104737 if you want further updates
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-07-05 16:20:52 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109723
No description provided.