Blender crashes during rendering animation #110158

Closed
opened 2023-07-16 04:03:14 +02:00 by Reynaldo-Haynes · 7 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.79

Blender Version
Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: (newest version of Blender that worked as expected)

Short description of error
When trying to render the animation in the given project, it either crashes Blender or causes it to hang indefinitely.

Exact steps for others to reproduce the error

  1. Load the given project file
  2. Render Animation using Ctrl F12 or the menu
  3. Blender crashes after rendering a few frames

Recording of me rendering the project and making Blender crash.

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.79 **Blender Version** Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: (newest version of Blender that worked as expected) **Short description of error** When trying to render the animation in the given project, it either crashes Blender or causes it to hang indefinitely. **Exact steps for others to reproduce the error** 1. Load the given project file 2. Render Animation using Ctrl F12 or the menu 3. Blender crashes after rendering a few frames [Recording of me rendering the project and making Blender crash.](https://streamable.com/jdwitg)
Reynaldo-Haynes added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-07-16 04:03:14 +02:00
Member

Hi, thanks for the report. Unable to confirm the crash in 3.6
Does this happen when you start blender from command line with -t 1 argument?

Hi, thanks for the report. Unable to confirm the crash in 3.6 Does this happen when you start blender from command line with [-t 1](https://docs.blender.org/manual/en/latest/advanced/command_line/arguments.html#debug-options:~:text=list%20available%20engines.-,%2Dt,-%2C%20%2D%2Dthreads%20%3Cthreads) argument?
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-07-17 04:44:02 +02:00

Yes, I can reproduce it with -t 1, I've attached the crash log with it set:

Yes, I can reproduce it with `-t 1`, I've attached the crash log with it set:
Iliya Katushenock added the
Interest
Modeling
label 2023-07-17 23:07:58 +02:00

I explored a similar bug. Some kind of modifier, or something else, multithreadedly takes some single data for writing. A result of 10 copies, this is an attempt to delete itself 10 times.
But the scene file does not contain geometry nodes, so this is something new. If it has the same reproducing time range as #109583, then it's may a duplicate. But need to be sure that this is also related to normals. Otherwise, it can be considered a separate type of bug.

I explored a similar bug. Some kind of modifier, or something else, multithreadedly takes some single data for writing. A result of 10 copies, this is an attempt to delete itself 10 times. But the scene file does not contain geometry nodes, so this is something new. If it has the same reproducing time range as https://projects.blender.org/blender/blender/issues/109583, then it's may a duplicate. But need to be sure that this is also related to normals. Otherwise, it can be considered a separate type of bug.
Member

Thanks. This has now generated the call stack (and EXCEPTION_INT_DIVIDE_BY_ZERO exception).
From recent logs. it seems crash triggers while freeing the memory.
Maybe irrelevant but could you check whether it crashes with --debug-depsgraph-no-threads argument?

Thanks. This has now generated the call stack (and `EXCEPTION_INT_DIVIDE_BY_ZERO` exception). From recent logs. it seems crash triggers while freeing the memory. Maybe irrelevant but could you check whether it crashes with `--debug-depsgraph-no-threads` argument?

I can't reproduce it either. In addition, it is better to remove the script.

I can't reproduce it either. In addition, it is better to remove the script.

I've tried again with blender --debug-depsgraph-no-threads <THE_FILE> and it also produced the crash with the same traceback.

I then tried rendering with all scripts disabled, this time the crash does not occur and it renders all frames completely fine. I toggled each script and found that disabling the addon "Animation: Wiggle 2" from https://github.com/shteeve3d/blender-wiggle-2 stops the crash.

In one of the runs with "Wiggle 2" and --debug-depsgraph-no-threads enabled, this was printed in the console after crashing:

Traceback (most recent call last):
  File "C:\Users\James\AppData\Roaming\Blender Foundation\Blender\3.6\scripts\addons\wiggle_2.py", line 488, in wiggle_pre
    bpy.context.view_layer.update()
RuntimeError: Error: Dependency graph update requested during evaluation

I've only been able to cause that error once, all other runs just give the same EXCEPTION_INT_DIVIDE_BY_ZERO exception.

Occasionally, instead of crashing, Blender freezes indefinitely instead with this error:

Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFEAA513FA0
Module  : tbbmalloc.dll
Thread  : 00003d10
Writing: C:\Users\James\AppData\Local\Temp\render crash.crash.txt

The crash log file render crash.crash.txt is actually empty in this case, it seems Blender never actually writes to that file.

I've tried again with `blender --debug-depsgraph-no-threads <THE_FILE>` and it also produced the crash with the same traceback. I then tried rendering with all scripts disabled, this time the crash does not occur and it renders all frames completely fine. I toggled each script and found that disabling the addon "Animation: Wiggle 2" from https://github.com/shteeve3d/blender-wiggle-2 stops the crash. In one of the runs with "Wiggle 2" and `--debug-depsgraph-no-threads` enabled, this was printed in the console after crashing: ``` Traceback (most recent call last): File "C:\Users\James\AppData\Roaming\Blender Foundation\Blender\3.6\scripts\addons\wiggle_2.py", line 488, in wiggle_pre bpy.context.view_layer.update() RuntimeError: Error: Dependency graph update requested during evaluation ``` I've only been able to cause that error once, all other runs just give the same `EXCEPTION_INT_DIVIDE_BY_ZERO` exception. Occasionally, instead of crashing, Blender freezes indefinitely instead with this error: ``` Error : EXCEPTION_ACCESS_VIOLATION Address : 0x00007FFEAA513FA0 Module : tbbmalloc.dll Thread : 00003d10 Writing: C:\Users\James\AppData\Local\Temp\render crash.crash.txt ``` The crash log file `render crash.crash.txt` is actually empty in this case, it seems Blender never actually writes to that file.

In this case, you'd better report the bug to the addon author. We can't fix the problem if it's not in blender, but in a script.

In this case, you'd better report the bug to the addon author. We can't fix the problem if it's not in blender, but in a script.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-07-18 13:21:29 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110158
No description provided.