The usd* file size is huge when export a character animation #110184

Open
opened 2023-07-17 00:08:12 +02:00 by Ken-Jung-Lee · 12 comments

System Information
Operating system: Mac & Windows
Graphics card: M1 and Nvidia 1060

Blender Version
Blender 3.6 LTS

Short description of error
I export the character model to usdz with a 300 frames animation. The exported file size tops to 1.x Gb. The character has around 200k verts.
The file size can be as small as 20 Mb when I export it into a glb file in Blender.
How do I export usd* file into a similar size scale of glb?

Exact steps for others to reproduce the error

  • Open 1bison.blend`
  • Export selected objects with animation in usdz and glb formats. You can see the difference right away.

bison.blend

**System Information** Operating system: Mac & Windows Graphics card: M1 and Nvidia 1060 **Blender Version** Blender 3.6 LTS **Short description of error** I export the character model to usdz with a 300 frames animation. The exported file size tops to 1.x Gb. The character has around 200k verts. The file size can be as small as 20 Mb when I export it into a glb file in Blender. How do I export usd* file into a similar size scale of glb? **Exact steps for others to reproduce the error** - Open 1bison.blend` - Export selected objects with animation in usdz and glb formats. You can see the difference right away. [bison.blend](https://projects.blender.org/attachments/78c86891-ce2e-4f38-892f-0977f08dca46)
Ken-Jung-Lee added the
Status
Needs Triage
Type
Report
Priority
Normal
labels 2023-07-17 00:08:13 +02:00
Member

Hi @Ken-Jung-Lee , it's best if you could provide such a blend file for us to try and see what exactly is going on with the exporter. Thanks!

Hi @Ken-Jung-Lee , it's best if you could provide such a blend file for us to try and see what exactly is going on with the exporter. Thanks!
Author

Sure! You can try with the attached file, and see the huge difference between the glb and usdz file sizes(6 Mb vs 1.2 Gb).

Sure! You can try with the attached file, and see the huge difference between the glb and usdz file sizes(6 Mb vs 1.2 Gb).
Member

Hi, I'm not able to redo this locally.
What are your export settings for both gltf and usd? I exported with default preset.
Could it be textures and other data from add-ons affecting the file size?

Hi, I'm not able to redo this locally. What are your export settings for both gltf and usd? I exported with default preset. Could it be textures and other data from add-ons affecting the file size?
Member

In image, you've created usdz file. Storing in "usd" format would reduce the size since data is stored in binary: https://en.wikipedia.org/wiki/Universal_Scene_Description#File_formats

In image, you've created usdz file. Storing in "usd" format would reduce the size since data is stored in binary: https://en.wikipedia.org/wiki/Universal_Scene_Description#File_formats
Author

I have tried to export to usd, but the file sizes are pretty much the same big (1.21GB)
I basically use the default export settings, but just checked animation options.
btw, I am using Blender 3.6.0. I will try to update it to 3.6.2 to see how it makes difference.
I am thinking if the animation data affects the size?! I checked the raw usd file content and it looks like the animations occupies a large chunk of the file.

I have tried to export to usd, but the file sizes are pretty much the same big (1.21GB) I basically use the default export settings, but just checked animation options. btw, I am using Blender 3.6.0. I will try to update it to 3.6.2 to see how it makes difference. I am thinking if the animation data affects the size?! I checked the raw usd file content and it looks like the animations occupies a large chunk of the file.

I have the same problem.
The skeletal point animation when exported to GLTF is 13 megabytes. Export from Blender to USDZ is 460 megabytes.
If you use gltf2usdz converter, the final file size is 6 megabytes.
Static files are exported in USDZ format in normal size. If necessary I can attach the source file with animation.

on Blender 3.6.5 stl and 4.1.0 alpha

I have the same problem. The skeletal point animation when exported to GLTF is 13 megabytes. Export from Blender to USDZ is 460 megabytes. If you use gltf2usdz converter, the final file size is 6 megabytes. Static files are exported in USDZ format in normal size. If necessary I can attach the source file with animation. on Blender 3.6.5 stl and 4.1.0 alpha
Member

Could it be some add-on or linked files causing this?
I was asked to run rigify script after opening bison.blend

Sorry for the delayed reply. Email somehow slipped through my eyes (sometimes email notification goes to "socials" category instead of "primary")

Could it be some add-on or linked files causing this? I was asked to run rigify script after opening `bison.blend` Sorry for the delayed reply. Email somehow slipped through my eyes (sometimes email notification goes to "socials" category instead of "primary")
Author

I only use a few plug-in in my blender. I believe the Rigify is the only relevant plug-in for this export purpose. However, I don’t believe rigify contribute to this file size leap, since it’s just for transforming armatures to a more control-able rig.

I only use a few plug-in in my blender. I believe the Rigify is the only relevant plug-in for this export purpose. However, I don’t believe rigify contribute to this file size leap, since it’s just for transforming armatures to a more control-able rig.
Member

Checked again with animation option, indeed file size increases with that (~970mb with animation, ~20mb without animation).
@makowalski hi, can you check?

Checked again with `animation` option, indeed file size increases with that (~970mb with animation, ~20mb without animation). @makowalski hi, can you check?

Thanks for reporting this. I'm investigating this issue.

Thanks for reporting this. I'm investigating this issue.

Hi @Ken-Jung-Lee. Currently, the Blender main branch does not support exporting animating skeletons to USD (UsdSkel), so the animation is always exported as a point cache, which explains the size difference. Our goal is to add support for USD skeleton export to 4.1 in this pull request: #110912

(Incidentally, exporting to UsdSkel is already supported in the universals-scene-description branch, and I confirmed the size is much smaller when exporting the bison animation from a build of that branch. )

Hi @Ken-Jung-Lee. Currently, the Blender `main` branch does not support exporting animating skeletons to USD (UsdSkel), so the animation is always exported as a point cache, which explains the size difference. Our goal is to add support for USD skeleton export to 4.1 in this pull request: https://projects.blender.org/blender/blender/pulls/110912 (Incidentally, exporting to UsdSkel is already supported in the `universals-scene-description` branch, and I confirmed the size is much smaller when exporting the bison animation from a build of that branch. )
Author

I see, it makes sense. Thank you for checking and explaining!

I see, it makes sense. Thank you for checking and explaining!
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110184
No description provided.