Crash with bpy.ops.uv.pack_islands() #110235

Closed
opened 2023-07-18 10:42:49 +02:00 by Juanfran Matheu · 1 comment

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 535.98

Blender Version
Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: 3.5

Short description of error
Executing bpy.ops.uv.pack_islands from script, console or addon will crash Blender, BUT if you use 'INVOKE_DEFAULT' option, it will work as expected.

Exact steps for others to reproduce the error

Reproduce with the Console:

  1. Open Blender and go to Scripting workspace.
  2. Turn the text editor into UV Editor.
  3. Go to edit mode.
  4. Select All in the UV Editor.
  5. In the console editor type bpy.ops.uv.pack_islands() and hit enter.
  6. Enjoy the crash.

Reproduce with a Script with the provided .blend:

  1. Download the provided .blend TEST_UV_PACK.blend
  2. Execute the script.

image

**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 535.98 **Blender Version** Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: 3.5 **Short description of error** Executing bpy.ops.uv.pack_islands from script, console or addon will crash Blender, BUT if you use 'INVOKE_DEFAULT' option, it will work as expected. **Exact steps for others to reproduce the error** ### Reproduce with the Console: 1. Open Blender and go to Scripting workspace. 2. Turn the text editor into UV Editor. 3. Go to edit mode. 4. Select All in the UV Editor. 5. In the console editor type `bpy.ops.uv.pack_islands()` and hit enter. 6. Enjoy the crash. ### Reproduce with a Script with the provided .blend: 1. Download the provided .blend `TEST_UV_PACK.blend` 2. Execute the script. ![image](/attachments/500998a4-ce98-4bc4-94c5-2e1ca9b36584)
Juanfran Matheu added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-07-18 10:42:49 +02:00

This is a duplicate of #108171 and is fixed for 3.6.1 which should release sometime soon.

This is a duplicate of #108171 and is fixed for 3.6.1 which should release sometime soon.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-07-18 10:56:49 +02:00
Jesse Yurkovich added
Status
Duplicate
and removed
Status
Archived
labels 2023-07-18 10:56:57 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110235
No description provided.