Edit bones draw as if they were groupless pose bones #110694

Closed
opened 2023-08-01 17:25:17 +02:00 by Demeter Dzadik · 4 comments
Member

Blender Version
Broken: version: 4.0.0 Alpha, branch: main, commit date: 2023-08-01 11:24, hash: cd74ba641316
Probably borked by @dr.sybren 's recent refactor (I would link to it but I have no idea how to find anything on Gitea)

The head and tail draw with the usual orange color, but the body with the pose mode whiteish color (even if the bone has a group with a color)

image

**Blender Version** Broken: version: 4.0.0 Alpha, branch: main, commit date: 2023-08-01 11:24, hash: `cd74ba641316` Probably borked by @dr.sybren 's recent refactor (I would link to it but I have no idea how to find anything on Gitea) The head and tail draw with the usual orange color, but the body with the pose mode whiteish color (even if the bone has a group with a color) ![image](/attachments/85d254f8-f134-4ff8-b47f-71d68fd0673c)
Demeter Dzadik added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-01 17:25:18 +02:00
Demeter Dzadik added
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-08-01 21:49:10 +02:00
Sybren A. Stüvel was assigned by Demeter Dzadik 2023-08-01 21:49:18 +02:00
Demeter Dzadik added this to the Animation & Rigging project 2023-08-01 21:49:26 +02:00
Member

First broke by (selection overlay is missing): 4aef0204ac

Then overlay changed to blue in : a478a4cd92

Regression so raising the priority :)

First broke by (selection overlay is missing): 4aef0204ac97b7676dc8d30743bf4fad426b1fae Then overlay changed to blue in : a478a4cd927977cf7374d23ff47ed504d2e7b843 Regression so raising the priority :)
Pratik Borhade added
Module
Animation & Rigging
Priority
High
and removed
Priority
Normal
labels 2023-08-02 07:26:30 +02:00
Member

Looks like ctx->bcolor color has not assigned any value in armature_context_setup
Checking for possible fix

Looks like `ctx->bcolor` color has not assigned any value in `armature_context_setup` Checking for possible fix
Member

or we can add additional case of ARM_DRAW_MODE_EDIT in get_pchan_color_wire and assign select/active colors to wire

or we can add additional case of `ARM_DRAW_MODE_EDIT` in `get_pchan_color_wire` and assign select/active colors to wire
Member

fix: #110715 :)

fix: https://projects.blender.org/blender/blender/pulls/110715 :)
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2023-08-03 11:03:50 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110694
No description provided.