Clearing library overrides from the object menu differs from the outliner #110750

Open
opened 2023-08-03 12:42:50 +02:00 by Robert S · 6 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: Quadro RTX 3000 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.67

Blender Version
Broken: version: 3.6.1 Release Candidate, branch: blender-v3.6-release, commit date: 2023-07-16 02:43, hash: edc1a09966a7
Worked: (newest version of Blender that worked as expected)

Short description of error
Please see the attached movie. Using the "wrong" menu will cause the material properties panel to become unresponsive (beginning of movie) with overrides still in place until you use the outliner (end of the movie).

Exact steps for others to reproduce the error

  1. Link some objects from a file
  2. Override them down to the materials
  3. Swap out some materials
  4. Use the clear library override from the object menu

Result:

The material overrides aren't cleared, but you also can't access the properties panel anymore.

Expected:

The material overrides should be cleared.

Workaround:

Use the outliner instead.

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: Quadro RTX 3000 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.67 **Blender Version** Broken: version: 3.6.1 Release Candidate, branch: blender-v3.6-release, commit date: 2023-07-16 02:43, hash: `edc1a09966a7` Worked: (newest version of Blender that worked as expected) **Short description of error** Please see the attached movie. Using the "wrong" menu will cause the material properties panel to become unresponsive (beginning of movie) with overrides still in place until you use the outliner (end of the movie). **Exact steps for others to reproduce the error** 1. Link some objects from a file 2. Override them down to the materials 3. Swap out some materials 4. Use the clear library override from the object menu Result: The material overrides aren't cleared, but you also can't access the properties panel anymore. Expected: The material overrides should be cleared. Workaround: Use the outliner instead.
Robert S added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-03 12:42:51 +02:00
Author

Managed to make a repeatable example:

BREP_1_2.002 already has the greyed out override icon, a result from clearing it from the Object menu. You can no longer make it a local object when it's in that state.

Select any other object and use the clear from the object menu to replicate it.

And similarly, instead using the context menus in the outliner properly clears the overrides.

I have not yet found any workarounds for getting an object out of that darkened, disabled state.

Managed to make a repeatable example: BREP_1_2.002 already has the greyed out override icon, a result from clearing it from the Object menu. You can no longer make it a local object when it's in that state. Select any other object and use the clear from the object menu to replicate it. And similarly, instead using the context menus in the outliner properly clears the overrides. I have not yet found any workarounds for getting an object out of that darkened, disabled state.
Iliya Katushenock added the
Interest
Overrides
label 2023-08-04 03:21:25 +02:00
Author

One thing to note perhaps, is a bug I haven't managed to make a reproducible file for, but you can see in the video here that in one of my files (which I can't share), when I attempt to make overrides on some linked objects, duplicate objects which are already "greyed out" like in this report gets created:

#110742 (comment)

One thing to note perhaps, is a bug I haven't managed to make a reproducible file for, but you can see in the video here that in one of my files (which I can't share), when I attempt to make overrides on some linked objects, duplicate objects which are already "greyed out" like in this report gets created: https://projects.blender.org/blender/blender/issues/110742#issuecomment-991887
Member

Library Overrides can be hairy, agreed, will try to understand what is going on

Library Overrides can be hairy, agreed, will try to understand what is going on

I think there was similar report, but perhaps for different outliner feature. Closest I was able to find is #101802. In any case outliner often does things differently things than operators in 3D viewport menu.

I think there was similar report, but perhaps for different outliner feature. Closest I was able to find is #101802. In any case outliner often does things differently things than operators in 3D viewport menu.
Member

Well the main difference is probably the fact that you can only do "selected" from the menu (whereas you have the choice of "selected and content" from the Outliner).
Doing only "selected" does the same as reported here from the Outliner afaict.

However, I'd like to inspect the whole behavior here, it boils down to these two operator descriptions (and if they work as advertised:

Delete the selected local overrides and relink their usages to the linked data-blocks if possible, else reset them and mark them as non editable

Delete the selected local overrides (including their hierarchies of override dependencies) and relink their usages to the linked data-blocks

Also note once overrides are marked non-editable, you can always re-enable editability in the Outliner as well:
image

Well the main difference is probably the fact that you can only do "selected" from the menu (whereas you have the choice of "selected and content" from the Outliner). Doing only "selected" does the same as reported here from the Outliner afaict. However, I'd like to inspect the whole behavior here, it boils down to these two operator descriptions (and if they work as advertised: >Delete the selected local overrides and relink their usages to the linked data-blocks if possible, else reset them and mark them as non editable >Delete the selected local overrides (including their hierarchies of override dependencies) and relink their usages to the linked data-blocks Also note once overrides are marked non-editable, you can always re-enable editability in the Outliner as well: ![image](/attachments/20fa95b1-3add-4670-800e-fd2698caaffb)
Member

So, lets break this down into smaller pieces

You can no longer make it a local object when it's in that state.

Think, this is even true without having tried to clear the overrides, I believe this is due to parent relationships, so if you link an object that has a parent in the source file:

  • then make a library override, then try to make that object local it fails
  • doing this without an override has no issues

I reported this separately in #111439

Will look at the material next.

Btw. : have you checked enabling the overrides again (see screenshot above)?

So, lets break this down into smaller pieces >You can no longer make it a local object when it's in that state. Think, this is even true without having tried to clear the overrides, I believe this is due to parent relationships, so if you link an object that has a parent in the source file: - then make a library override, then try to make that object local it fails - doing this without an override has no issues I reported this separately in #111439 Will look at the material next. Btw. : have you checked enabling the overrides again (see screenshot above)?
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110750
No description provided.