viewport axis display is incorrect #111025

Closed
opened 2023-08-10 23:03:01 +02:00 by Vince Herried · 8 comments

System Information
Operating system: fedora linux 6.4.9-200.fc38.x86_64
Graphics card: GeForce 940MX

Blender Version
broken blender-3.6.1-linux-x64, also 3.6.0
works blender-2.93.

Short description of error
when the axis letters are displayed X, Y, and Z all show up as pointing in the same direction.

Exact steps for others to reproduce the error
so trivial in object mode -> object properties -> viewport display turn on axis.

**System Information** Operating system: fedora linux 6.4.9-200.fc38.x86_64 Graphics card: GeForce 940MX **Blender Version** broken blender-3.6.1-linux-x64, also 3.6.0 works blender-2.93. **Short description of error** when the axis letters are displayed X, Y, and Z all show up as pointing in the same direction. **Exact steps for others to reproduce the error** so trivial in object mode -> object properties -> viewport display turn on axis.
Vince Herried added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-10 23:03:01 +02:00
Author

blender 3.3 lts displays correctly.

blender 3.3 lts displays correctly.

maybe you come across a Gimbal lock situation after doing some rotations, search on gimbal lock see this also
https://youtu.be/XaBwdwnwV7Y

maybe you come across a Gimbal lock situation after doing some rotations, search on gimbal lock see this also https://youtu.be/XaBwdwnwV7Y
Author

Thank you for your response, I watched the video. I don't think I have that issue. As I mentioned in the problem record, the problem is not there in version 3.3. Just to check, I created a cube in version 2.93.17 , verifying it was showing OK, then saved it and opened it using 3.6.1. 3.6.1 shows the wrong orientation again it is only the letters, the colored axis lines are correct. Please see the image I uploaded. It points out the issue clearly.

Thank you for your response, I watched the video. I don't think I have that issue. As I mentioned in the problem record, the problem is not there in version 3.3. Just to check, I created a cube in version 2.93.17 , verifying it was showing OK, then saved it and opened it using 3.6.1. 3.6.1 shows the wrong orientation again it is only the letters, the colored axis lines are correct. Please see the image I uploaded. It points out the issue clearly.
Member

@vince_549 could you give us the file you are having trouble with? From the look of the axis drawing, it might be a driver issue. Are you on a laptop with hybrid graphics? in which case could you use sudo prime-select nvidia to force nvidia card?

Also please use Help -> Save System Info and upload the txt so we can get a better idea of what's going on with your graphics.

The axis are supposed to look like diamonds, so there must be some problems with the drawing.

图片

@vince_549 could you give us the file you are having trouble with? From the look of the axis drawing, it might be a driver issue. Are you on a laptop with hybrid graphics? in which case could you use `sudo prime-select nvidia` to force nvidia card? Also please use `Help -> Save System Info` and upload the txt so we can get a better idea of what's going on with your graphics. The axis are supposed to look like diamonds, so there must be some problems with the drawing. ![图片](/attachments/3e6bd493-eb14-4bea-92ee-afb64eec1522)
Author

Yes I am on a laptop. I find no such command "prime-select NVIDIA " on my distro ( fedora F38).
I tested on my desktop, no problem found, then saved the file and copied it to my laptop and the problem was recreated.
Attached find my laptop system info, and the blend file..

My I though this was going to be a silly easy to diagnose issue. I guess my decades of programming on an IBM mainframe system are not helping me here :). Thank you for your very prompt attention to this strange issue.

Yes I am on a laptop. I find no such command "prime-select NVIDIA " on my distro ( fedora F38). I tested on my desktop, no problem found, then saved the file and copied it to my laptop and the problem was recreated. Attached find my laptop system info, and the blend file.. My I though this was going to be a silly easy to diagnose issue. I guess my decades of programming on an IBM mainframe system are not helping me here :). Thank you for your very prompt attention to this strange issue.
Member

Hi @vince_549 , from the system info file it seems that blender is running with your integrated graphics, not nvidia. Is there a nvidia control panel in your system? It should come with nvidia prime, otherwise please try download and install the driver from nvidia. Then selecting the nvidia card to run blender.

The problem with integrated graphics will be categorized as well.

Hi @vince_549 , from the system info file it seems that blender is running with your integrated graphics, not nvidia. Is there a nvidia control panel in your system? It should come with nvidia prime, otherwise please try download and install the driver from nvidia. Then selecting the nvidia card to run blender. The problem with integrated graphics will be categorized as well.
Author

Wow, I have been using blender on this laptop for some time and not seen this issue. Blender recognizes my nVidia card.

I did some digging and found a procedure to use the nVidia vidio card all the time.
https://docs.fedoraproject.org/en-US/quick-docs/how-to-set-nvidia-as-primary-gpu-on-optimus-based-laptops/

I did it and the blender display was fixed. So is this a blender bug or a Vince bug?
Thanks for you help.

Wow, I have been using blender on this laptop for some time and not seen this issue. Blender recognizes my nVidia card. I did some digging and found a procedure to use the nVidia vidio card all the time. [](url)https://docs.fedoraproject.org/en-US/quick-docs/how-to-set-nvidia-as-primary-gpu-on-optimus-based-laptops/ I did it and the blender display was fixed. So is this a blender bug or a Vince bug? Thanks for you help.
Member

Hi @vince_549 , glad you found a solution :D

Although the drawing in intel GPU is still wrong, we can mark this issue as resolved for now. The iGPU problem can still be referenced by #111162. Maybe in the future when we found some solution we'll notify you guys from that issue list and have you test the fix to see if it really does fix. Thanks for reporting!

Hi @vince_549 , glad you found a solution :D Although the drawing in intel GPU is still wrong, we can mark this issue as resolved for now. The iGPU problem can still be referenced by #111162. Maybe in the future when we found some solution we'll notify you guys from that issue list and have you test the fix to see if it really does fix. Thanks for reporting!
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-08-17 04:05:41 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111025
No description provided.